Pagina 3 di 5

Re: Compiz-git

Inviato: dom feb 24, 2008 11:40
da Vito
vanno benissimo 4modalità....però secondo me bisognerebbe trovare il modo di staccarsi da gconf e orbit...per una questione di pulizia...infatti quando scarico manualmente compiz-git non è necessario avere quei 2 pacchetti... :-k

Re: Compiz-git

Inviato: dom feb 24, 2008 16:21
da Ansa89
Quando si scarica e basta non servono gconf e orbit, ma servono quando vai a compilare compiz. Almeno io ho avuto problemi legati alla mancanza di quei due pacchetti.
Sono pienamente d'accordo quando dici che per una questione di pulizia sarebbe bene non installarli, però non ho idea di come poter compilare compiz senza quei pacchetti :? :?

Re: Compiz-git

Inviato: lun feb 25, 2008 0:35
da alexxxius
ciao, ho provato il tuo script, non ho avuto più voglia di aggiornarmi da solo compiz e ricompilare, aspettavo il giorno in cui avresti fatto i tgz, però ho ricevuto questo errore:

Codice: Seleziona tutto

checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for CCS... configure: error: Package requirements (libcompizconfig >= 0.6.99 glib-2.0 >= 2.6 ) were not met:

No package 'libcompizconfig' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CCS_CFLAGS
and CCS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

make: *** No rule to make target `clean'.  Stop.
make: *** No targets specified and no makefile found.  Stop.

Non sono riuscito ad installare compizconfig-python
Mi fermo


Naturalmente grazie del tuo lavoro. :)

Re: Compiz-git

Inviato: mar feb 26, 2008 18:15
da Ansa89
Dunque dunque...Prova a fare

Codice: Seleziona tutto

$echo $PKG_CONFIG_PATH

Poi leggi le directory che ti stampa (dovrebbero essere "/usr/local/lib/pkgconfig" e "/usr/lib/pkgconfig") e fai

Codice: Seleziona tutto

$ls -l /usr/local/lib/pkgconfig/ | grep libcompizconfig.pc
$ls -l /usr/lib/pkgconfig/ | grep libcompizconfig.pc

Se nessuno dei due comandi ti restituisce output vuole dire che libcompizconfig (se si è installato) si è installato in un path strano.
Puoi provare a cercarlo facendo

Codice: Seleziona tutto

$find / libcompizconfig.pc | grep libcompizconfig.pc

Se trovi la directory dove è dentro puoi creare un link simbolico dentro a "/usr/local/lib/pkgconfig/"

Codice: Seleziona tutto

$su
Password:
#cd /usr/local/lib/pkgconfig/
#ln -s /path/dove/c'è/libcompizconfig.pc ./


Comunque è uno strano errore...A me non è mai successo, se riesci a risolverlo posta come hai fatto.

Re: Compiz-git

Inviato: mar feb 26, 2008 20:57
da alexxxius
mi aveva scaricato tutto il pacchetto in / :? , bisogna capire il perchè..

[edit]viene creato il pacchetto tgz di libcompizconfig in maniera anomala, ci sono tante cose assieme, sorgenti make, script d'installazione [/edit]

[edit2]

penso di aver trovato qualcosa, alla riga 187 (aperto con kwrite) nel tuo script:

Codice: Seleziona tutto

su -c "makepkg -l y -c n $HERE/$i-$VERSION-$ARCH-$BUILD.tgz && upgradepkg --install-new --reinstall $HERE/$i-$VERSION-$ARCH-$BUILD.tgz"


quel $HERE dovrebbe essere in realtà $PKG, poichè avendo fatto make install DESTDIR=$PKG, è lì che deve costruire il pacchetto, infatti credo che sia per questo che mi viene creato il pacchetto libcompizconfig che ti ho desritto sopra, cioè la directory con i sorgenti e binari. fammi sapere che ne pensi ciao.

[edit 3] niente ho detto una emerita caz@@ata!!![edit]

Re: Compiz-git

Inviato: mar feb 26, 2008 22:46
da Ansa89
No aspetta...Forse hai ragione, io non ricordo di preciso cosa mi passava per la testa quando ho scritto quello script :roll: ...Adesso vado a controllare...
[edit]Ho controllato ed effettivamente è un po' strano...Però ho anche riguardato lo slackbuid di compiz-fusion di slacky.eu e anche in questo si viene usata la variabile "$CWD" che equivale al mio "$HERE". Quindi suppongo vada bene così com'è :roll: [/edit]

Re: Compiz-git

Inviato: dom mar 02, 2008 15:40
da Ansa89
alexxxius ha scritto:ciao, ho provato il tuo script, non ho avuto più voglia di aggiornarmi da solo compiz e ricompilare, aspettavo il giorno in cui avresti fatto i tgz, però ho ricevuto questo errore:

Codice: Seleziona tutto

checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for CCS... configure: error: Package requirements (libcompizconfig >= 0.6.99 glib-2.0 >= 2.6 ) were not met:

No package 'libcompizconfig' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CCS_CFLAGS
and CCS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

make: *** No rule to make target `clean'.  Stop.
make: *** No targets specified and no makefile found.  Stop.

Non sono riuscito ad installare compizconfig-python
Mi fermo


Naturalmente grazie del tuo lavoro. :)

Ho capito il perché!!! \:D/
Sono un deficiente: quando creavo i pacchetti dopo "compiz", lo script non entrava nella directory $PKG e faceva un gran casino!!
Adesso l'ho messo a posto e lo sto uppando qui.
Appena hai tempo provalo e dimmi se funziona... [-o<

Re: Compiz-git

Inviato: dom mar 02, 2008 19:31
da JohnnyMnemonic
Problemino nella parte di fusion-icon

Codice: Seleziona tutto

su -c "python setup.py clean && python setup.py bild && python setup.py install"


te lo lascio scovare da solo ;)

Re: Compiz-git

Inviato: dom mar 02, 2008 19:46
da Ansa89
Eh insomma....Non si può essere sempre perfetti... :roll:
Uffa!! Odio gli errori di battitura :evil: :evil:

Re: Compiz-git

Inviato: dom mar 02, 2008 21:55
da alexxxius
l'ho provato, certo quel problema è risolto, adesso però i plugin quando parte il configure non trovano bcop, ma bcop è installato..

Purtroppo non ho tempo sennò ti aiuterei..l'altro giorno volevo mettermi 5 minuti, ma per adesso non è cosa.

Re: Compiz-git

Inviato: lun mar 03, 2008 16:11
da Ansa89
alexxxius ha scritto:l'ho provato, certo quel problema è risolto, adesso però i plugin quando parte il configure non trovano bcop, ma bcop è installato..

Purtroppo non ho tempo sennò ti aiuterei..l'altro giorno volevo mettermi 5 minuti, ma per adesso non è cosa.

Risolto con la versione 3.3 :thumbright:

Spero che adesso siano davvero finiti i problemi... :roll:

Re: Compiz-git

Inviato: mar mar 04, 2008 16:57
da alexxxius
allora, \:D/ funziona, però se vuoi raggiungere la perfezione, mi devi fare comparire le icone in compizConfig setting manager... :thumbright:

Re: Compiz-git

Inviato: mar mar 04, 2008 17:11
da Ansa89
alexxxius ha scritto:allora, \:D/ funziona, però se vuoi raggiungere la perfezione, mi devi fare comparire le icone in compizConfig setting manager... :thumbright:

Questo è un bel problema...È dalla prima volta che ho installato la versione git che non mi compaiono quelle icone!! :evil: :evil:
Ho cercato ovunque su internet, provando almeno cinque soluzioni diverse, ma non ci sono ancora riuscito :(
La perfezione è lontana (anche perché adesso sta emergendo il problema 64bit... :roll: )

Re: Compiz-git

Inviato: mar mar 11, 2008 20:36
da Ansa89
alexxxius ha scritto:allora, \:D/ funziona, però se vuoi raggiungere la perfezione, mi devi fare comparire le icone in compizConfig setting manager... :thumbright:

Prova a vedere qui...
Poi dimmi se funziona ;)

Re: Compiz-git

Inviato: sab mar 29, 2008 23:05
da eto_demertzel
Ciao! Quando ho visto il tuo script non mi è parso quasi vero di potermi risparmiare tutta la fatica di aggiornare i pacchetti singolarmente... così l'ho scaricato e lanciato direttamente da root.

Ho scaricato tutto su /root/Desktop/ e poi è partica l'installazione (ho unsato l'opzione "install").
Con mia somma delusione, pochi istanti dopo il completamente del download, mi sono ritrovato difronte a questo output di errore:

Per primo compilo compiz con i seguenti flags: --enable-librsvg --enable-gtk --disable-metacity --disable-static --disable-gconf --enable-kde --build=i686-slackware-linux --prefix=/usr/local
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/auto ... ng-aclocal
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of AM_PATH_GDK_IMLIB
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFILE
/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --copy
/usr/share/aclocal/nspr.m4:8: warning: underquoted definition of AM_PATH_NSPR
run info '(automake)Extending aclocal'
or see http://sources.redhat.com/automake/auto ... ng-aclocal
/usr/share/aclocal/imlib.m4:9: warning: underquoted definition of AM_PATH_IMLIB
/usr/share/aclocal/imlib.m4:167: warning: underquoted definition of AM_PATH_GDK_IMLIB
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition of AM_PATH_AUDIOFIL
/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
autoreconf: running: /usr/bin/autoconf
configure.ac:23: error: possibly undefined macro: AC_PROG_INTLTOOL
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
make: *** No targets specified and no makefile found. Stop.


Ho fatto vari tentativi, anke direttamente da testuale, senza lanciare X, ma la cosa non è cambiata. Sebbene io non lo usi spesso, aclocal è installato e funzionante....