Repository 32bit  Forum
Repository 64bit  Wiki

Progetto "Gnome Slacky"

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Messaggioda gohanz » mer mag 02, 2007 11:01

Ho trovato un bug in gnome-screenshot! In pratica quando si cerca di salvare la schermata da user, il programma si blocca all'atto del salvataggio!
Il problema sta nella directory /tmp/gnome-screenshot che non ha i diritti di scrittura per user! Per farlo funzionare occorre modificare i diritti di accesso alla directory in 777. Il problema è che questa dir viene cancellata ad ogni boot! :roll:
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda submax82 » gio mag 03, 2007 0:11

gohanz ha scritto:Ho trovato un bug in gnome-screenshot! In pratica quando si cerca di salvare la schermata da user, il programma si blocca all'atto del salvataggio!
Il problema sta nella directory /tmp/gnome-screenshot che non ha i diritti di scrittura per user! Per farlo funzionare occorre modificare i diritti di accesso alla directory in 777. Il problema è che questa dir viene cancellata ad ogni boot! :roll:


qui trovi la patch

http://bugzilla.gnome.org/show_bug.cgi?id=427870

basta "adattarla" alla nuova versione di gnome 2.18.1 e inserirla nello slackbuild ;)
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda gohanz » gio mag 03, 2007 7:13

Perfetto provo ad adattarla a Gnome-Utils 2.18.0! ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda submax82 » gio mag 03, 2007 16:13

gohanz ha scritto:Perfetto provo ad adattarla a Gnome-Utils 2.18.0! ;)


no non hai capito... è per gnome utils 2.18.0 .... e và adattata alla 2.18.1 .... ma penso andrà anche così...
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda gohanz » gio mag 03, 2007 18:07

Si avevo capito che era una patch per la versione 2.18.0 vedrò di adattare! ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda submax82 » gio mag 03, 2007 19:50

gohanz ha scritto:Si avevo capito che era una patch per la versione 2.18.0 vedrò di adattare! ;)


patch sistemata... inviata via mail... ho cambiato solo 2 righe

Codice: Seleziona tutto
--- gnome-utils-2.18.0/gnome-screenshot/screenshot-save.c   2007-03-10 14:19:50.000000000 +0100
+++ gnome-utils-2.18.0.new/gnome-screenshot/screenshot-save.c   2007-04-09 12:21:13.000000000 +0200


in queste

Codice: Seleziona tutto
--- ./gnome-screenshot/screenshot-save.c   2007-03-10 14:19:50.000000000 +0100
+++ ./gnome-screenshot/screenshot-save.c   2007-04-09 12:21:13.000000000 +0200


poi ho provata ad applicarla hai sorgenti e ha funzionato senza errori

per applicare nello slackbuild devi copiarla dentro la directory temporanea di gnome-utils e poi lanciare

patch -p0 < gnome-utils-fix-screenshots.patch

(che è il nome che gli ho dato... se vuoi cambialo)
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda gohanz » ven mag 04, 2007 7:23

Grazie Submax82, funziona benissimo! ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda submax82 » ven mag 04, 2007 13:07

gohanz ha scritto:Grazie Submax82, funziona benissimo! ;)


prego ;) hai un pm

inoltre ti ho inviato un'altra patch via mail 8)
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Messaggioda gohanz » sab mag 05, 2007 9:56

Anche VLC con pieno supporto Gnome, nella versione 2 di Gnome-Slacky (2.18.1)

Immagine
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » sab mag 05, 2007 21:51

Secondo me era molto ma molto più stabile la 2.18.0! La 2.18.1 ha qualcosa che non va con ESD! Infatti disabilitando il mix dei suoni del desktop via ESD non c'è più il minimo problema! :roll:

Comunque novità!

Planner!

Immagine


GnuCash!

Immagine


Gthumb con libgphoto!

Immagine


Gimp con il plugin Gtkam per la cattura delle vostre foto direttamente dalla Cam!


Immagine



Pidgin alias Gaim con supporo per le notifiche di freedestop.org!


Immagine


Liferea per i feed rss!


Immagine
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda The_Dreaming_Mind » dom mag 06, 2007 10:29

prima di tutto un grandissimo ringraziamento a Gohanz per il lavorone svolto! era da tempo che volevo installare Gnome su slackware e ho sempre fallito, ma con il tuo CD e` stato semplicissimo!

in compenso, riporto un paio di bachi riscontrati:

1 banale, e non rilevante, l'icona del menu` delle applicazioni non mostra nessuna immagine (capita solo a me).

2 dopo un po' di tempo che gnome e` lanciato e il desktop non e` utilizzato, spariscono i menu` "applications", "Places", "System" dal pannello in alto (piu` altre applicazioni collocate sullo stesso pannello); notabene, questo mi capita anche su un altra macchina con ubuntu installato, ma su ubuntu dopo un attimo risolve il problema, e ripristina tutto. sempre parte di questo punto, dopo che si osservsa questo fenomeno, non riesco a cliccare il pannello su cui questi menu` sono collocati, MA riesco a le applicazioni che non sono sparite.


byez
The_Dreaming_Mind
Linux 1.0
Linux 1.0
 
Messaggi: 51
Iscritto il: sab feb 25, 2006 11:22

Messaggioda gohanz » dom mag 06, 2007 12:44

Senti potresti postare uno screenshot! Comunque prova anche a dare

Codice: Seleziona tutto
update-mime-database /usr/share/mime


e
Codice: Seleziona tutto
update-desktop-database


Prova anche a disabilitare ESD in preferenze audio
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda nicop » dom mag 06, 2007 14:26

ciaoo gohanz due domande :
1 - non riesco a trovare come scaricare l'iso della versione 2.18.1
2 - per fare l'upgrade che procedura bisogna seguire??

grazie nicola
Avatar utente
nicop
Linux 2.4
Linux 2.4
 
Messaggi: 232
Iscritto il: mer gen 18, 2006 11:21
Località: San Martino In P. (Cb)
Nome Cognome: Nicola Palmieri
Slackware: 12.0
Kernel: 2.6.21.5
Desktop: Gnome Slacky

Messaggioda gohanz » dom mag 06, 2007 14:54

Ancora non è disponibile! E' pronta al 95%, pee l'installazione ed eventuale upgrade, sarà semplicissimo, basterà lanciare l'installer di Submax ;)
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda strummer » dom mag 06, 2007 17:55

Anche io volevo ringraziare tutti coloro che hanno lavorato e contribuito alla realizzazione di slacky-gnome.
Riporto qualche bag (o errore mio, dipende :) non se se può aiutare o se mi potete aiutare a risolvere.
1-Non riesco a mettera la tastiera italiana, una volta configurata nelle impostazioni tastiera, sia in shell, che in qualsiasi file di testo scrivo ancora con quella inglese
2-Non riesco a cambiare sfondo al desktop in quanto non mi riconosce nessun file immagine, tipo jpg o png
3-Quantop ho provato a disinstallare usando la 5 voce del menu dell install.sh ho notato che firefox, thunderbird e mplayer non funzionavano più uscendo con l'errore: impossibile caricare la libreria condivisa libpangocairo... ?!?!

Ho installato ache ubuntu e i primi due problemi sopracitati non si verificano...

grazie in anticipo
strummer
Linux 2.4
Linux 2.4
 
Messaggi: 276
Iscritto il: mar set 28, 2004 23:00
Località: Firenze

PrecedenteProssimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti