Errore gnome-slacky [RISOLTO]

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » mar mag 22, 2007 2:15

Beh, ci avevo pensato, i cd sono stato masterizzati con nero sotto win, ma non ho controllato, comunque mi affido alle probabilità... ho usato:

2 cd di gnome slacky con 2 versioni diverse
3 cd di slack (1 della 11, due della current)

stessi errori.
dovrei essere stato proprio jellato!

BodomLx
Linux 1.0
Linux 1.0
Messaggi: 48
Iscritto il: ven mag 18, 2007 20:12
Località: South Tyrol =)
Contatta:

Messaggioda BodomLx » mar mag 22, 2007 9:12

Hai provato a seguire la mia guida per la current?

Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Messaggioda submax82 » mar mag 22, 2007 17:38

algol ha scritto:Beh, ci avevo pensato, i cd sono stato masterizzati con nero sotto win, ma non ho controllato, comunque mi affido alle probabilità... ho usato:

2 cd di gnome slacky con 2 versioni diverse
3 cd di slack (1 della 11, due della current)

stessi errori.
dovrei essere stato proprio jellato!


controlla gli md5 ... magari sono le iso danneggiate

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » ven mag 25, 2007 0:28

Guarda non credo proprio si questo, ho installato anche l'ultima GSlacky 2.18.1Tr2 e l'effetto è lo stesso.

Gli errori sono individuabili in glib2 e alcuni in gtk2, pacchetti che gnome installa di per se.

Visto che praticamente a tutti funziona sia su 11 che su current con al massimo qualche problemino di icone, non so più che pensare...

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » ven mag 25, 2007 8:28

algol ha scritto:Guarda non credo proprio si questo, ho installato anche l'ultima GSlacky 2.18.1Tr2 e l'effetto è lo stesso.

Gli errori sono individuabili in glib2 e alcuni in gtk2, pacchetti che gnome installa di per se.

Visto che praticamente a tutti funziona sia su 11 che su current con al massimo qualche problemino di icone, non so più che pensare...


Algol prova a ricompilare per i486 Glib2 e Gtk2! Così vediamo se puù essere quello il problema!

Gli SlackBuild li trovi qui http://gnome.slacky.eu/gnome/11.0/2.18. ... /platform/

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » ven mag 25, 2007 16:25

Ciao,
ho già provato a compilarmi le glib, senza però specificare l'architettura (come si fa non da slackbuild? :oops: ) ma l'errore persiste chiamando ancora in causa il famigerato goption-context, e aggiungendovi un nuovo errore su bonobo....

L' errore delle gtk è più raro, parla di gdk-pixbuf o qualcosa del genere (nopn sto a casa per controllare), ma viene sempre preceduto dall'errore precedente...

comunque proverò con gli slackbuild.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda gohanz » dom mag 27, 2007 8:43

Algol prova a dare questi comandi da shell


Codice: Seleziona tutto

gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders

gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » dom mag 27, 2007 23:54

Ua, leggendo da un altro 3d, l'ho fatto proprio adesso, e non è la prima volta, a parte che lo fa con gli script di post-installazione, no?
comunque non cambia niente.

Aggiungo alle cose precedenti, che installando gnome slacky mi peggiora la "condizione di salute" di kde, cioè kbuildsyscoca crasha praticamente a ogni avvio e ogni volta che installo qualcosa che si mette nel menu, basta che clicco ok e tutto va, anche se quando faccio akppfinder va in loop, non credo che il mio menu sia molto aggiornato...

In più, arts non fa bene il suo lavoro, ricordo che appenza installai la current, varie installazioni fa :? , per la prima volta sentivo tutti i suoni di kde ad ogni evento, ma è durato poco, ora se da kcontrol faccio "prova suono" lo riproduce, ma i vari suoni all'avvio o ai vari eventi non ci sono più! :cry:

Provo con gli slackbuilds...

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » lun mag 28, 2007 2:14

Vi aggiorno...

Ho appena finito di compilare glib e gtk2 con gli slackbuilds e per i486...
cambia poco, la stessa cosa che ottenni compilando glib a a mano:

Codice: Seleziona tutto

GLib-GObject-WARNING **: IA__g_object_get_valist: object class `GnomeProgram' has no property named `goption-context'

Bonobo-ERROR **: file bonobo-ui-init-gtk.c: line 91 (add_gtk_arg_callback): assertion failed: (init_info != NULL)
aborting...
Abortito


nella compilazione ci sono stati vari warning, alcuni significativi:
glib:

Codice: Seleziona tutto

object.c: In function 'object_floating_flag_handler':
gobject.c:1561: warning: dereferencing type-punned pointer will break strict-aliasing rules
gobject.c:1567: warning: dereferencing type-punned pointer will break strict-aliasing rules
gobject.c: In function 'IA__g_object_ref':
gobject.c:1722: warning: pointer targets in passing argument 1 of 'g_atomic_int_exchange_and_add' differ in signedness
gobject.c:1724: warning: dereferencing type-punned pointer will break strict-aliasing rules
gobject.c: In function 'IA__g_object_unref':
gobject.c:1750: warning: pointer targets in passing argument 1 of 'g_atomic_int_compare_and_exchange' differ in signedness
gobject.c:1754: warning: dereferencing type-punned pointer will break strict-aliasing rules
gobject.c:1767: warning: pointer targets in passing argument 1 of 'g_atomic_int_compare_and_exchange' differ in signedness
gobject.c:1771: warning: dereferencing type-punned pointer will break strict-aliasing rules
gobject.c:1783: warning: pointer targets in passing argument 1 of 'g_atomic_int_exchange_and_add' differ in signedness

e

Codice: Seleziona tutto

find: /usr/lib/perl5/site_perl/5.8.8/i486-linux/Net/DBus/~ŸPŒPŒ: No such file or directory
find: /usr/lib/perl5/site_perl/5.8.8/i486-linux/Net/DBus/TýsüPŒPŒ: No such file or directory


per gtk (sono un sacco, solo alcuni):

molti di questo tipo:

Codice: Seleziona tutto

queryloaders.c: In function 'query_module':
queryloaders.c:164: warning: dereferencing type-punned pointer will break strict-aliasing rules
queryloaders.c:165: warning: dereferencing type-punned pointer will break strict-aliasing rules
____________________

gdkevents-x11.c: In function 'IA__gdk_x11_screen_get_window_manager_name':
gdkevents-x11.c:2674: warning: dereferencing type-punned pointer will break strict-aliasing rules
gdkevents-x11.c: In function 'IA__gdk_x11_screen_supports_net_wm_hint':
gdkevents-x11.c:2774: warning: dereferencing type-punned pointer will break strict-aliasing rules

____________________

gdkgeometry-x11.c: In function 'queue_item_free':
gdkgeometry-x11.c:1044: warning: dereferencing type-punned pointer will break strict-aliasing rules
gdkgeometry-x11.c: In function 'gdk_window_queue':
gdkgeometry-x11.c:1120: warning: dereferencing type-punned pointer will break strict-aliasing rules

____________________

gtkstyle.c: In function 'gtk_style_finalize':
gtkstyle.c:593: warning: ignoring return value of 'g_slist_remove', declared with attribute warn_unused_result
gtkstyle.c: In function 'gtk_default_draw_focus':
gtkstyle.c:4523: warning: pointer targets in initialization differ in signedness
gtkstyle.c:4540: warning: pointer targets in assignment differ in signedness
gtkstyle.c:4559: warning: pointer targets in passing argument 1 of 'strlen' differ in signedness


molti altri di questo tipo:

Codice: Seleziona tutto

/bin/sh ../../libtool --mode=link i486-slackware-linux-gcc  -DG_DISABLE_DEPRECATED -O2 -march=i486   -mtune=i686 -Wall   -o im-xim.la -rpath /usr/lib/gtk-2.0/2.10.0/immodules -rpath /usr/lib/gtk-2.0/2.10.0/immodules -avoid-version -module  gtkimcontextxim.lo imxim.lo ../../gdk-pixbuf/libgdk_pixbuf-2.0.la ../../gdk/libgdk-x11-2.0.la ../../gtk/libgtk-x11-2.0.la -lpangocairo-1.0 -lpango-1.0 -lX11 -lXfixes -latk-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 -lcairo -lm
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libpangocairo-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libpango-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libcairo.la' seems to be moved
libtool: link: warning: `/usr/X11R6/lib/libfontconfig.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libfontconfig.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXext.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXrender.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libX11.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXinerama.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXi.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXrandr.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXcursor.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXfixes.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libfontconfig.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXext.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXrender.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXinerama.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXi.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXrandr.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXcursor.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libpangocairo-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libpango-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libX11.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libXfixes.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libatk-1.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libgobject-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libgmodule-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libglib-2.0.la' seems to be moved
libtool: link: warning: `/usr/lib/gcc/i486-slackware-linux/4.1.2/../../..//libcairo.la' seems to be moved
libtool: link: warning: `/usr/X11R6/lib/libfontconfig.la' seems to be moved
libtool: link: warning: `/usr/X11R6/lib/libfontconfig.la' seems to be moved
libtool: link: warning: `/usr/X11R6/lib/libfontconfig.la' seems to be moved


ma i file si sono.

e questo:

Codice: Seleziona tutto

i486-slackware-linux-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../.. -I../../gdk-pixbuf -I../../contrib -DGDK_PIXBUF_DISABLE_DEPRECATED -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DG_DISABLE_DEPRECATED -O2 -march=i486 -mtune=i686 -Wall -MT gdk-pixbuf-xlib-drawable.lo -MD -MP -MF .deps/gdk-pixbuf-xlib-drawable.Tpo -c gdk-pixbuf-xlib-drawable.c  -fPIC -DPIC -o .libs/gdk-pixbuf-xlib-drawable.o
gdk-pixbuf-xlib-drawable.c: In function 'rgb1':
gdk-pixbuf-xlib-drawable.c:158: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb1a':
gdk-pixbuf-xlib-drawable.c:197: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb8':
gdk-pixbuf-xlib-drawable.c:248: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb8a':
gdk-pixbuf-xlib-drawable.c:289: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb565lsb':
gdk-pixbuf-xlib-drawable.c:343: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb565msb':
gdk-pixbuf-xlib-drawable.c:414: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb565alsb':
gdk-pixbuf-xlib-drawable.c:486: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb565amsb':
gdk-pixbuf-xlib-drawable.c:543: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb555lsb':
gdk-pixbuf-xlib-drawable.c:599: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb555msb':
gdk-pixbuf-xlib-drawable.c:670: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb555alsb':
gdk-pixbuf-xlib-drawable.c:742: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb555amsb':
gdk-pixbuf-xlib-drawable.c:799: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb888alsb':
gdk-pixbuf-xlib-drawable.c:847: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb888lsb':
gdk-pixbuf-xlib-drawable.c:878: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb888amsb':
gdk-pixbuf-xlib-drawable.c:908: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'rgb888msb':
gdk-pixbuf-xlib-drawable.c:956: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'convert_real_slow':
gdk-pixbuf-xlib-drawable.c:990: warning: pointer targets in initialization differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'xlib_window_is_viewable':
gdk-pixbuf-xlib-drawable.c:1150: warning: pointer targets in passing argument 6 of 'XQueryTree' differ in signedness
gdk-pixbuf-xlib-drawable.c: In function 'gdk_pixbuf_xlib_get_from_drawable':
gdk-pixbuf-xlib-drawable.c:1271: warning: pointer targets in passing argument 6 of 'XGetGeometry' differ in signedness
gdk-pixbuf-xlib-drawable.c:1271: warning: pointer targets in passing argument 7 of 'XGetGeometry' differ in signedness
gdk-pixbuf-xlib-drawable.c:1271: warning: pointer targets in passing argument 8 of 'XGetGeometry' differ in signedness
gdk-pixbuf-xlib-drawable.c:1271: warning: pointer targets in passing argument 9 of 'XGetGeometry' differ in signedness


soprattutto ce ne sono certi si riferiscono proprio ai miei errori riguardo goption e gdk-pixbuf-xlib.

Per chi volesse ( :oops: ) posso mandare tutti gli errori (che sono riuscito a copiarmi)
Perdonate il lungo post...

Ciao

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » gio mag 31, 2007 2:49

Mmmhhh... vedo che un sacco di gente sta leggendo questo 3d... ma vi ricordo che io rimango impelagato! 8) :cry:

Allora, nessuno è così subgenioso da aiutarmi???

Guardate che repasso alla freerock... :lol: vecchia e buona almeno mi funzionava!

A.

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Errore gnome-slacky [RISOLTO]

Messaggioda algol » gio giu 07, 2007 3:12

Allloooora...

MIRACOLO! 8) 8) 8)

Ho reinstllato, per l'ennesima volta, come prova della mia inconsiderata affezione al progetto, current e Gslacky su un altro HD, risultato? Funziona!!!

Non so ancora dir bene perchè, ma ho imparato alcune cose sul connubbio current + Gslacky... posto in quest' altro 3d http://www.slacky.eu/forum/viewtopic.php?p=144897#144897.

Chiedo scusa per il certo fastidio arrecato, ma resta ancora ignota l natura dell'errore :oops:

A.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Errore gnome-slacky [RISOLTO]

Messaggioda gohanz » gio giu 07, 2007 8:01

algol ha scritto:Allloooora...

MIRACOLO! 8) 8) 8)

Ho reinstllato, per l'ennesima volta, come prova della mia inconsiderata affezione al progetto, current e Gslacky su un altro HD, risultato? Funziona!!!

Non so ancora dir bene perchè, ma ho imparato alcune cose sul connubbio current + Gslacky... posto in quest' altro 3d http://www.slacky.eu/forum/viewtopic.php?p=144897#144897.

Chiedo scusa per il certo fastidio arrecato, ma resta ancora ignota l natura dell'errore :oops:

A.


Meno male sono contentissimo! :p Riprepara un'altro disco per Gnome-Slacky 2.18.2! :D

Avatar utente
algol
Linux 2.6
Linux 2.6
Messaggi: 969
Iscritto il: gio set 07, 2006 1:19
Slackware: 12.1
Kernel: 2.6.26.1
Desktop: xfce4.4.2
Contatta:

Messaggioda algol » ven giu 08, 2007 1:07

Beh sì, minimo!!! Ho solo i soliti problemi nello scaricare...

comunque grazie per la disponibilità!

A.


Torna a “Gnome Slacky”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti