Repository 32bit  Forum
Repository 64bit  Wiki

How-To: Installare Gnome Slackware su Slackware Current

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Messaggioda BodomLx » mar mag 22, 2007 16:44

Giusto per informazione, sono da poco passate le mie prime 24 ore di lavoro con Gnome Slacky sulla current, ed è tutto a posto..
BodomLx
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: ven mag 18, 2007 19:12
Località: South Tyrol =)

Messaggioda vaquerito » lun mag 28, 2007 1:14

Ciao a tutti, vorrei evitare il piu possibile di essere pedante e infatti non la faro' pero' non e' un mistero che fossi scettico sul risultato di "metti gnome slacky sulla current e vai no problem"... ;)
Avrei gioito anch'io, se avessi provato il "colpo gobbo" e vedevo che gnome si avviava, ma non mettiamo annunci in grassetto che tutto va bene , perche se uno viene sul forum lo legge e se lo installa si trova con un sistema impicciato :evil: e non e' detto che sappia come venirne fuori :roll: ... piuttosto mettiamoci su una bella scritta tipo "guide avanzate" o "tentativi di current a vostro rischio e pericolo!" :D
@bodom: ovviamente nulla di personale pero' mettiti nei panni di chi non smanetta
Bon.

Dopo aver installato la Tr2 ho provato la prima cosa che mi ricordavo usasse python e cioe' la deskbar-applet, che tra l'altro contiene un integrazione sia per tracker che per beagle, e ovviamente crasha per via della versione.
Per chi volesse fare la prova, puo lanciarla da terminale cosi
Codice: Seleziona tutto
/usr/lib/deskbar-applet/deskbar-applet -w

e vedere i risultati.
Per adesso bisogna di sicuro rimpiazzare 'pygobject', 'pygtk' e 'pycairo' (e questi per fortuna sono gia' pacchettizati per la current su mytux) e ricompilare a mano 'gnome-applets' che dipende da 'gail', queste le dipendenze rotte che ha fatto emergere la deskbar-applet se viene fuori qualcos'altro lo posto.

Poi c'e un problema con il pacchetto m4 ed il comando aclocal, io non riuscivo a compilare nessun pacchetto gnome ne' alcuni altri come compiz-git, se anche a voi da problemi la colpa e' di '/usr/share/aclocal/pilot-link.m4', commentate la prima riga di questo file, e' un bug noto gia risolto nella prossima versione.
Ciao!
vaquerito
 

Messaggioda gohanz » lun mag 28, 2007 7:46

Poi c'e un problema con il pacchetto m4 ed il comando aclocal, io non riuscivo a compilare nessun pacchetto gnome ne' alcuni altri come compiz-git, se anche a voi da problemi la colpa e' di '/usr/share/aclocal/pilot-link.m4', commentate la prima riga di questo file, e' un bug noto gia risolto nella prossima versione.
Ciao!


Non ho capito il bug, dove sarebbe nel pacchetto pilot-link della 11.0? :roll: [/quote]
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Messaggioda BodomLx » lun mag 28, 2007 8:34

Codice: Seleziona tutto
 
/usr/lib/deskbar-applet/deskbar-applet -w
Traceback (most recent call last):
  File "/usr/lib/deskbar-applet/deskbar-applet", line 10, in <module>
    import gobject
ImportError: No module named gobject

Non credo che questo sia un problema legato alla versione di python, ma a dei moduli mancanti :-) mi dispiace per te comunque..altre applicazioni che usano python funzionano..

Intanto ho aggiornato sulla guida nel wiki come risolvere il problema delle applicazioni che richiedono libpython 2.4

vaquerito, grazie del feedback in ogni caso!
BodomLx
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: ven mag 18, 2007 19:12
Località: South Tyrol =)

Messaggioda BodomLx » lun mag 28, 2007 23:31

vaquerito ha scritto:@bodom: ovviamente nulla di personale pero' mettiti nei panni di chi non smanetta
Bon.
!

Scusa, é un forum di Ubuntu questo? :D

Mettiti anche tu nei miei di panni, secondo te Slackware Current + Gnome Slacky é per chi non smanetta? Io l´ho detto da subito che ci sono delle piccole smanettate da fare..é ovvio che non funziona tutto alla perfezione, se no non ci scrivevo un how-to e non lo aggiornavo ogni piccolo problema che veniva fuori..tra l´altro la current che ho usato per installare gslacky é cambiata in questi pochi giorni, com´é subito cambiato gslacky stesso (nuova release)..

Prima di parlare di speculazioni su colpi gobbi, prova a vedere quante modifiche ho fatto a quella pagina del wiki per stare dietro a tutti i cambiamenti di slackware current o gslacky..
BodomLx
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: ven mag 18, 2007 19:12
Località: South Tyrol =)

Messaggioda vaquerito » mar mag 29, 2007 18:36

senti eh... ero tentato di abbandonare la discussione perche a piu riprese mi sono trattenuto, dalla prima volta che hai detto che ti funzionava... ma a sto punto...
1- e me la chiami una guida? hai preso una current ci hai messo gnome-slacky hai visto che si avviava e questo hai scritto... una guida e' una cosa che contiene dei passi che altrimenti non sapresti per avere una roba funzionante.. sul serio. installi slack+installi gnome +avvii non e' nessuna guida.
2- certo che manca un modulo ti ho anche detto di che pacchetto ma e' un python-binding
3- non e' un forum ubuntu ma manco un forum di mandrake dove uno si sogna di risolvere i conflitti di dipendenze di versione con un link simbolico, slack e' pulita e' roba seria poi ovviamente gli intrugli si possono fare con tutto. io non mi sognerei mai di dire su una guida di linkare python 2.5 alla 2.4
4- Posso sapere dove hai letto "speculazione" ? la parola "colpo gobbo" e' molto amichevole e indica quando uno "ce prova e je va bene" insomma quando si riesce a fare qualcosa che in teoria non ci si aspettava.

tanta' superficialita' nel gestire la parte tecnica come il post,t'ho indicato espressamente che non era personale e infatti ti ho dato 2 feedback oggettivi e con tanto di soluzioni regolari... certo che se poi mi concludi
Prima di parlare di speculazioni su colpi gobbi, prova a vedere
??? cose che non ho mai scritto allora cambiano i toni.
Ultima modifica di vaquerito il mar mag 29, 2007 19:04, modificato 2 volte in totale.
vaquerito
 

Messaggioda vaquerito » mar mag 29, 2007 18:55

@gohanz
l'errore di cui parlavo e'
Codice: Seleziona tutto
/usr/bin/m4:/usr/share/aclocal/pilot-link.m4:1: ERROR: end of file in string
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: autom4te failed with exit status: 1
*error* aclocal failed. (exit code = 1)

discusso per esempio qui: http://www.pilot-link.org/compilation-e ... ot-link-m4
in cui si riporta che
But this was solved 2 months ago in CVS. Try 0.12.3 and see if that solves it.

infatti la versione attuale e' la 0.12.2

e anche se non appartiene a gnome-slacky, si verifica sulla current se provi a compilarti qualcosa per gnome che usa aclocal e automake.
Ciao
vaquerito
 

Messaggioda BodomLx » mar mag 29, 2007 19:06

1- e me la chiami una guida? hai preso una current ci hai messo gnome-slacky hai visto che si avviava e questo hai scritto... una guida e' una cosa che contiene dei passi che altrimenti non sapresti per avere una roba funzionante.. sul serio. installi slack+installi gnome +avvii non e' nessuna guida.

te hai visto cosa ho scritto appena mi sono iscritto qui? "grazie di aver creato gnome slacky, é tutto a posto"..neanche lo sapevo che normalmente non andava sulla current..mi é stato chiesto come avevo fatto e cosí é stato, ho scritto passo per passo come avevo fatto per farlo andare.. avevo pure specificato che c´erano da fare pochi cambiamenti, devi prendertela con me? Ho anche scritto che ho avuto un sacco di c**o, non mi sembra di prendere in giro nessuno!
Sinceramente dei tentativi precedenti non ne so nulla né ne voglio sapere niente..a me é funzionata ed ho scritto cosa ho fatto per farla funzionare,e ci ho perso anche un sacco di tempo se é per quello!

2- certo che manca un modulo ti ho anche detto di che pacchetto ma e' un python-binding


Ed é colpa mia? Di gnome slacky? Direi proprio di no, gnome slacky sulla current funziona, se poi non va un applet di gnome non é che significhi che non funziona niente..io la sto usando tranquillamente e non ho mai avuto problemi di nessun tipo, la chiamo funzionante una cosa cosí..se poi devi andare a cercare il pelo nell´uovo..neanche su archlinux mi sembra che funzionassero alcune applet...e? Funzionava lo stesso
3- non e' un forum ubuntu ma manco un forum di mandrake dove uno si sogna di risolvere i conflitti di dipendenze di versione con un link simbolico, slack e' pulita e' roba seria poi ovviamente gli intrugli si possono fare con tutto. io non mi sognerei mai di dire su una guida di linkare python 2.5 alla 2.4

Su questo si puó discutere, non dico né di avere ragione né di avere torto..Per quello che serve ad un utente comune, funziona.. Se vuoi avere sia python 2.4 che python 2.5 beh te li installi..
Questo é il mio semplice workaround..poi é un wiki chi vuole puó modificarlo, qui si sta solo cercando di aiutare la gente,se quello che ho scritto é una base che puó essere ampliata, sono solo felice..

4- Posso sapere dove hai letto "speculazione" ? la parola "colpo gobbo" e' molto amichevole e indica quando uno "ce prova e je va bene" insomma quando si riesce a fare qualcosa che in teoria non ci si aspettava..

Scusa ho interpretato male, colpa mia.. mi sono irritato per niente, l´ho pensatonegativamente..si é stato un colpo gobbo allora, ma l´ho detto da subito :D

Comunque é tutto in buona fede, ho semplicemente installato la current, gnome slacky andava, ho ringraziato chi l´ha creata, specificando che é quasi tutto andato bene senza troppe modifiche, gentilmente gohanz mi ha chiesto di scrivere come ho fatto e io l´ho scritto.. tutto qui..
BodomLx
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: ven mag 18, 2007 19:12
Località: South Tyrol =)

Messaggioda vaquerito » mar mag 29, 2007 23:34

Ascolta, pur mantenendo tutti i miei punti, ti ringrazio sinceramente per la risposta equilibrata.
Poiche' credo di capire e condividere lo spirito che sta dietro alla creazione di un progetto o di una guida, che immagino sia quello di condividere le proprie conoscenze e aiutarsi con gli altri, l'unica cosa che posso aggiungere e' che se trovero' dei modi piu vicini alla "filosofia" della nostra distro per adattare gnome-slacky alla current li postero' qui come ho fatto con in precedenza. ;)
Ciao !
vaquerito
 

Messaggioda BodomLx » mar mag 29, 2007 23:55

Bene, sono contento sia di trovarti d´accordo con me, che di poter contare su di te per rendere la guida completa :D
Notte
BodomLx
Linux 1.0
Linux 1.0
 
Messaggi: 48
Iscritto il: ven mag 18, 2007 19:12
Località: South Tyrol =)

Precedente

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite

cron