Pagina 1 di 1

[FIXED] A problem with GSlacky 2.24.1

Inviato: sab nov 15, 2008 20:00
da tftd
Hey,

I'm having a strange problem after I've updated to 2.24.1.
When I attempt to start X11 I get this in the logs:

Codice: Seleziona tutto

gnome-session[2614]: WARNING: Could not make bus activated clients aware of DISPLAY=:0.0 environment variable: org.freedesktop.DBus does not understand message UpdateActivationEnvironment
gnome-session[2614]: WARNING: Could not make bus activated clients aware of GNOME_DESKTOP_SESSION_ID=this-is-deprecated environment variable: org.freedesktop.DBus does not understand message UpdateActivationEnvironment
gnome-session[2614]: WARNING: Could not make bus activated clients aware of SESSION_MANAGER=local/ibm:/tmp/.ICE-unix/2614 environment variable: org.freedesktop.DBus does not understand message UpdateActivationEnvironment
gnome-session[2614]: WARNING: No required applications specified
gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xinit:  connection to X server lost.


After I start X11 I can only move my mouse... nothing else happens/loads or whatsoever.
I got no idea what does it mean nor what to do from now on.

Any help would be appreciated !



FIX:
Just delete /etc/gconf and everything should work.



Thanks in advance,
tftd

Re: A problem with GSlacky 2.24.1

Inviato: sab nov 15, 2008 20:23
da gohanz
Mhhh very strange! Do you have updated from GSlacky 2.24.0, or from 2.23.* series? Your system is a Slackware 12.1 or current?

Re: A problem with GSlacky 2.24.1

Inviato: sab nov 15, 2008 20:52
da tftd
My slack is 12.1 and I've updated from GSlacky 2.22.2.
Also I've tried to fully uninstall GSlacky and then install it again but the problem remains. :(

Edit:
Because I have work to do, I've downgraded back to GSlacky 2.22.2.
I've tried to uninstall first 2.22.2, then uninstall 2.24.1 and re-install 2.24.1 but that doesn't seem to fix the problem.
What I've noticed is that in the packages you have "boost-1.35.0" and after that "boost-1.36.0". Also I've noticed on other places that
you have the previous version of the package and the new version. The problem seems to be that the installer first installs 1.36 and then 1.35... After that everything becomes a big mess. I'm not sure if that's the problem though...

Re: A problem with GSlacky 2.24.1

Inviato: dom nov 16, 2008 18:22
da tftd
Does anybody has a clue how to fix this ?
If I update from 2.22.2 to 2.23 and then 2.24 will that help me or it'll be a waste of time ?

Re: A problem with GSlacky 2.24.1

Inviato: dom nov 16, 2008 18:32
da gohanz
Thanks for boost problem report. It will be fixed maybe for the next GSlacky-2.24.2. About your problem try to delete the directory /etc/gconf.
Reinstall all the GSlacky packages and make a new test account. I think that some gconf settings of GSlacky 2.22.2 conflict with the latest 2.24.1.

Re: A problem with GSlacky 2.24.1

Inviato: dom nov 16, 2008 22:09
da tftd
Ok thanks for the info.
I'll try this in the next few days and report what happened ;)

Re: A problem with GSlacky 2.24.1

Inviato: lun nov 17, 2008 12:58
da tftd
Hey again...
The problem was exactly in /etc/gconf. After I've removed the directory everything is working fine in GSlacky 2.24.1
Thanks for the help !