Repository 32bit  Forum
Repository 64bit  Wiki

Aggiornamento a Gslacky 2.24.1

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Aggiornamento a Gslacky 2.24.1

Messaggioda litino » dom nov 23, 2008 12:10

Ciao a tutti,
sto per aggiornare da Gslacky 2.22.3 alla 2.24.1. Visto che è la prima volta che lo faccio volevo chiedere qualche consiglio su eventuali accorgimenti da prendere. Ad esempio ho letto che aggiornando dalla 2.22.2 alla 2.24.1 bisogna cancellare la directory /etc/gconf (questo è il relativo post http://www.slacky.eu/forum/viewtopic.php?f=13&t=26671) . Questo problema si verifica anche con la 2.22.3? Grazie
Ultima modifica di litino il lun dic 08, 2008 14:03, modificato 2 volte in totale.
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda gohanz » dom nov 23, 2008 12:47

Si è credo che avrai lo stesso problema anche con la 2.22.3. Gli aggiornamenti in genere funzionano bene solo tra le stesse versioni di Gnome. Quindi per intenderci dalla 2.22.0 si può effettuare tranquillamente l'upgrade fino alla 2.22.3.
Se fai un upgrade alla serie 2.24.* dovresti cancellare la directory /etc/gconf e creare anche un'altro account di test. Questo perchè i settaggi gconf vengono scritti anche nella tua home nella directory ~/.gconf.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » dom nov 23, 2008 14:25

Ho fatto l'aggiornamento ed è andato tutto bene. Ottengo però questo warning prima di che si avvii X11:
rm: cannot remove '/.pulse' : No such file or directory
Ho sbagliato qualcosa?
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda gohanz » dom nov 23, 2008 14:45

litino ha scritto:Ho fatto l'aggiornamento ed è andato tutto bene. Ottengo però questo warning prima di che si avvii X11:
rm: cannot remove '/.pulse' : No such file or directory
Ho sbagliato qualcosa?



Niente di preoccupante. La versione di PulseAudio presente in GSlacky-2.22.* ha un fastidioso bug. Al'avvio del demone viene creata la directory '/.pulse' allo stesso livello della /. Avevo risolto quel problema con un workaround. In pratica inserendo rm /.pulse nello script di avvio di PulseAudio.
Ora questo bug non c'è più nelle versioni recenti di PulseAudio, quindi quel workaround non è più necessario.
Nel tuo caso però lo script di avvio di PulseAudio è quello della versione precedente. Quindi ti da quell'errore perchè effettivamente quella directory '/.pulse non viene più creata e di conseguenza non può essere rimossa.
Un po contorto, Spero di essermi spiegato.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » dom nov 23, 2008 17:07

L'unico problema che ho riscontrato finora è che non riesco a sentire nessun tipo di audio anche avendo inserito il mio user nei gruppi pulse-rt e pulse-access.
Qualche idea?
Grazie

EDIT:
Se lancio alsamixer ottengo:
ALSA lib pulse.c:266:(pulse_connect) PulseAudio: Unable to connect: Connection refused
alsamixer: function snd_ctl_open failed for default: Connection refused
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda gohanz » dom nov 23, 2008 18:02

PulseAudio è in esecuzione? Se si prova a killarlo
Codice: Seleziona tutto
killall pulseaudio
e poi lancialo da shell
Codice: Seleziona tutto
pulseaudio -v
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » dom nov 23, 2008 18:27

Questo è l'output di
Codice: Seleziona tutto
pulseaudio -v

I: caps.c: Dropping root priviliges.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
I: main.c: This is PulseAudio 0.9.13
I: main.c: Page size is 4096 bytes
I: main.c: Machine ID is 739cb66f2a3b3c23582939fc489ebe2e.
I: main.c: Using runtime directory /home/emanuele/.pulse/739cb66f2a3b3c23582939fc489ebe2e:runtime.
I: main.c: Using state directory /home/emanuele/.pulse.
I: main.c: Running in system mode: no
W: pid.c: Stale PID file, overwriting.
I: main.c: Dude, your kernel stinks! The chef's recommendation today is Linux with high-resolution timers enabled!
E: module-hal-detect.c: Couldn't connect to hald: (null): (null)
process 11737: Attempt to remove filter function 0xb39ff380 user data 0x807b1b0, but no such filter has been added
D-Bus not built with -rdynamic so unable to print a backtrace
Aborted
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda gohanz » dom nov 23, 2008 19:11

Non ho mai visto questo tipo di errore, sembra che non riesca a connettersi con hal e dbus. Io proverei a riavviare il pc. Sperando che non sia rimato qualche file di configurazione della versione precedente.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » dom nov 23, 2008 19:38

Ho riavviato ma non è cambiato nulla. Nella directory /etc/rc.d ho visto che ci sono dei file con suffisso new
rc.font.new*
rc.networkmanager.new
rc.pulseaudio.new*

Ho provato a fermare rc.pulseaudio e far partire rc.pulseaudio.new, ma quando fermo il primo:
Stopping PulseAudio Daemon: /usr/bin/pulseaudiopulseaudio: no process killed
... pulseaudio is not running.
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda gohanz » dom nov 23, 2008 19:45

Litini prova a cancellare la directory /etc/pulse. Cancella anche tutti i file rc.pulseaudio che trovi in /etc/rc.d. Rimuovi il pacchetto di PulseAudio e reinstallalo manualmente. Lo trovi nella directory /packages/pulseaduio.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » dom nov 23, 2008 20:00

Non va nemmeno così. Pensi che a questo punto mi convenga reinstallare slackware da zero?
Comunque grazie mille per l'aiuto
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda gohanz » lun nov 24, 2008 19:25

litino ha scritto:Non va nemmeno così. Pensi che a questo punto mi convenga reinstallare slackware da zero?
Comunque grazie mille per l'aiuto



Litino non saprei. Prova a ricompilare il pacchetto di PulseAudio. Lo slackbuild lo trovi in /source/pulseaudio.Altrimenti puoi impostare Gnome per usare direttamente alsa, questo dalle preferenze audio. Se fai questa scelta dovresti rinominare il file /etc/asound.conf. Perchè quest'ultimo è impostato per usare il plugin alsa di PulseAudio. Usando direttamente alsa probabilmente gli effetti sonori del desktop non funzioneranno. Questo perchè in Gnome-2.24.* gli effetti sonori usano libcanberra, che a sua volta richiede PulseAudio.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » sab dic 06, 2008 14:08

Litino non saprei. Prova a ricompilare il pacchetto di PulseAudio. Lo slackbuild lo trovi in /source/pulseaudio.Altrimenti puoi impostare Gnome per usare direttamente alsa, questo dalle preferenze audio. Se fai questa scelta dovresti rinominare il file /etc/asound.conf. Perchè quest'ultimo è impostato per usare il plugin alsa di PulseAudio. Usando direttamente alsa probabilmente gli effetti sonori del desktop non funzioneranno. Questo perchè in Gnome-2.24.* gli effetti sonori usano libcanberra, che a sua volta richiede PulseAudio.

Ho finalmente trovato il tempo di reinsatallare da zero la slack. Come mi avevi suggerito ho impostato Gnome per usare direttamente alsa e ho rinominato il file /etc/asound.conf. Fino a ieri tutto ok, l'audio andava. Oggi ho fatto degli aggiornamenti (i security fix contenuti in slackware-12.1/patches/packages dei mirror slack) e l'audio non va piu. O meglio, va solo se mi loggo come root. Da utente normale, se provo a cliccare sull'icona del volume:
No volume control GStreamer plugins and/or devices found.

L'utente fa parte dei gruppi pulse-rt e pulse-access (anche se non so se serva piu vista la mia sitazione)

Qualche idea?
Grazie


EDIT:
Come non detto. Ho riavviato ed ora è tutto OK.
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » lun dic 08, 2008 11:25

Dovendo masterizzare un CD oggi ho riscontrato un altro problema. Brasero non parte. Facendo partire da console, questo è il log:
Codice: Seleziona tutto
emanuele@darkstar:~$ brasero

(brasero:4863): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstmsgsm.so': /usr/lib/gstreamer-0.10/libgstmsgsm.so: undefined symbol: gst_msgsmdec_get_type

(brasero:4862): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.HalVolumeMonitor is not supported

(brasero:4862): GVFS-RemoteVolumeMonitor-WARNING **: remote volume monitor with dbus name org.gtk.Private.GPhoto2VolumeMonitor is not supported

** (brasero:4862): WARNING **: Failed to initialize hal : (null)

process 4862: Attempt to remove filter function 0xb753e380 user data 0x818c850, but no such filter has been added
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted

Il problema sembra derivare ancora da dbus e hal.
Qualche consiglio?
Grazie
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Re: Aggiornamento a Gslacky 2.24.1

Messaggioda litino » lun dic 08, 2008 14:11

Il problema sembrerebbe proprio derivare dal fatto che HAL non parte:
root@darkstar:~# /etc/rc.d/rc.hald restart
/etc/rc.d/rc.hald: line 25: kill: (3294) - No such process
Starting HAL daemon: /usr/sbin/hald --daemon=yes

Facendo qualche ricerca ho trovato questo http://www.linuxquestions.org/questions/slackware-14/hald-dies-immediately-on-12.1-662009/ ma non sembrerebbe risolvere il problema.
Premetto che ho due partizioni tutte e due con Slackware 12.1, una con KDE e l'altra con GNOME(GSlacky). Su KDE tutto ok. A qualcuno è mai accaduto qualcosa del genere?
litino
Linux 1.0
Linux 1.0
 
Messaggi: 86
Iscritto il: lun nov 12, 2007 13:08
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite