Repository 32bit  Forum
Repository 64bit  Wiki

Pulseaudio è morto, e Alsa pure

Questo forum raccoglie tutte le discussioni sul progetto Gnome Slacky (Gnome per Slackware).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Gslacky usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 18:48

Scusate il titolo da Nietsche ma è all'incirca la realtà.
Uso Slackware 12.1 e il kernel 2.6.24.5-SMP e ho installato giusto oggi Gnome con GSlacky. Funziona tutto senza problemi tranne l'audio: non si sente proprio nulla. La mia scheda audio con Alsa va col modulo snd-hda-intel, con Pulseaudio immagino non venga proprio vista (il mixer la segna come "Null output"). Ho provato a disinstallare Pulseaudio, a riconfigurare Alsa (varie volte) ma è stato inutile.
Come posso fare a farlo fungere?
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:01

Hai configurato gstreamer per usare PulseAudio? Da Sistema > Preferenze > Audio
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:08

Ho installato il pacchetto gst-pulseaudio, dalle preferenze dell'audio facendo il test con Pulseaudio non si sente nulla, con tutti gli altri ricevo un amichevole
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink profile=music: Could not open audio device for playback.
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:11

tirallenta ha scritto:Ho installato il pacchetto gst-pulseaudio, dalle preferenze dell'audio facendo il test con Pulseaudio non si sente nulla, con tutti gli altri ricevo un amichevole
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink profile=music: Could not open audio device for playback.



Dove hai preso questo pacchetto? Parlo di gst-pulseaudio. Non c'è in GSlacky-2.24.1. Forse parli di gst-pulse, ma quello è un "vecchio" plugin non più usato. Ora è gst-plugins-good che contiene il plugin per Gstreamer.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:14

Non so, l'ho preso da swaret :P
Comunque era gst-pulse, in ogni caso non funziona proprio.
Grazie della sopportazione :P
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:18

tirallenta ha scritto:Non so, l'ho preso da swaret :P
Comunque era gst-pulse, in ogni caso non funziona proprio.
Grazie della sopportazione :P



Ho capito il problema. Hai installato gst-pulse presente su Slacky. Questo ha sovrascritto il plugin buono contenuto in gst-plugins-good. Devi disinstallare gst-pulse e poi reinstallare gst-plugins-good. Lo trovi nell'iso in /packages/desktop.

Ps. Poi parlerò con Loris per far togliere quel pacchetto dal repository.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:22

Ho fatto quello che hai detto tu, ma Pulseaudio continua a vedere solo ed esclusivamente Null output, e quindi non sento nulla.
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:24

tirallenta ha scritto:Ho fatto quello che hai detto tu, ma Pulseaudio continua a vedere solo ed esclusivamente Null output, e quindi non sento nulla.



Non è che hai installato anche PulseAudio presente su Slacky?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:30

Swaret mi segna come presente solo quello senza il -gslacky alla fine, in effetti.
Ho installato quello di gslacky e tolto l'altro ed è tutto come prima :cry:
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:34

tirallenta ha scritto:Swaret mi segna come presente solo quello senza il -gslacky alla fine, in effetti.
Ho installato quello di gslacky e tolto l'altro ed è tutto come prima :cry:



Credo che ti siano incasinati i file di configurazione. Prova a cancellare /etc/pulse e anche /etc/rc.d/rc.pulseaudio. Rimuovi PulseAudio qualsiasi versione hai installato adesso e reinstalla il pacchetto originale GSlacky.
Poi riavvia il pc.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:41

Fatto, esattamente come prima :(
Mi sa che neanche Volkerding riuscirebbe a risolvere.
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:43

tirallenta ha scritto:Fatto, esattamente come prima :(
Mi sa che neanche Volkerding riuscirebbe a risolvere.


Dai da shell
Codice: Seleziona tutto
killall pulseaudio
e poi lancialo da console
Codice: Seleziona tutto
pulseaudio -v
posta l'output, così vediamo se c'è qualche errore di PulseAudio.
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:45

I: caps.c: Dropping root priviliges.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTTIME, (1000000, 1000000)) failed: Invalid argument
W: main.c: High-priority scheduling enabled in configuration but not allowed by policy.
W: core-util.c: setpriority(): Permission denied
I: main.c: This is PulseAudio 0.9.13
I: main.c: Page size is 4096 bytes
I: main.c: Machine ID is 3e30bdcd2c93b8737a47a93449368b21.
I: main.c: Using runtime directory /home/paolo/.pulse/3e30bdcd2c93b8737a47a93449368b21:runtime.
I: main.c: Using state directory /home/paolo/.pulse.
I: main.c: Running in system mode: no
I: main.c: Dude, your kernel stinks! The chef's recommendation today is Linux with high-resolution timers enabled!
I: module-hal-detect.c: Trying capability alsa
N: module-alsa-sink.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM front:0
I: alsa-util.c: Couldn't open PCM device front:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround40:0
I: alsa-util.c: Couldn't open PCM device surround40:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround41:0
I: alsa-util.c: Couldn't open PCM device surround41:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround50:0
I: alsa-util.c: Couldn't open PCM device surround50:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround51:0
I: alsa-util.c: Couldn't open PCM device surround51:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: Invalid argument
I: (alsa-lib)pcm_hw.c: Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such file or directory
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_1002_437b_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
N: module-alsa-source.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM front:0
I: alsa-util.c: Couldn't open PCM device front:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround40:0
I: alsa-util.c: Couldn't open PCM device surround40:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround41:0
I: alsa-util.c: Couldn't open PCM device surround41:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround50:0
I: alsa-util.c: Couldn't open PCM device surround50:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround51:0
I: alsa-util.c: Couldn't open PCM device surround51:0: Invalid argument
I: (alsa-lib)conf.c: Unknown parameters 0
I: (alsa-lib)pcm.c: Unknown PCM surround71:0
I: alsa-util.c: Couldn't open PCM device surround71:0: Invalid argument
I: (alsa-lib)pcm_hw.c: Invalid value for card
E: alsa-util.c: Error opening PCM device hw:0: No such file or directory
E: module.c: Failed to load module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_1002_437b_sound_card_0_alsa_capture_0 tsched=1"): initialization failed.
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module-stream-restore.c: Sucessfully opened database file '/home/paolo/.pulse/3e30bdcd2c93b8737a47a93449368b21:stream-volumes.i486-slackware-linux-gnu.gdbm'.
I: module.c: Loaded "module-stream-restore" (index: #3; argument: "").
I: module-device-restore.c: Sucessfully opened database file '/home/paolo/.pulse/3e30bdcd2c93b8737a47a93449368b21:device-volumes.i486-slackware-linux-gnu.gdbm'.
I: module.c: Loaded "module-device-restore" (index: #4; argument: "").
I: module-default-device-restore.c: Saved default sink 'auto_null' not existant, not restoring default sink setting.
I: module-default-device-restore.c: Saved default source 'auto_null.monitor' not existant, not restoring default source setting.
I: module.c: Loaded "module-default-device-restore" (index: #5; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #6; argument: "").
I: module-device-restore.c: Restoring volume for sink auto_null.
I: module-device-restore.c: Restoring mute state for sink auto_null.
I: sink.c: Created sink 0 "auto_null" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-device-restore.c: Restoring volume for source auto_null.monitor.
I: module-device-restore.c: Restoring mute state for source auto_null.monitor.
I: source.c: Created source 0 "auto_null.monitor" with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module.c: Loaded "module-null-sink" (index: #7; argument: "sink_name=auto_null").
I: module.c: Loaded "module-always-sink" (index: #8; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #9; argument: "").
I: module.c: Loaded "module-console-kit" (index: #10; argument: "").
I: module.c: Loaded "module-position-event-sounds" (index: #11; argument: "").
I: module.c: Loaded "module-gconf" (index: #12; argument: "").
I: main.c: Daemon startup complete.
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Re: Pulseaudio è morto, e Alsa pure

Messaggioda gohanz » lun dic 08, 2008 19:47

Funziona bene, ma hai aggiunto il tuo accout al gruppo
Codice: Seleziona tutto
pulse-access
?
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Pulseaudio è morto, e Alsa pure

Messaggioda tirallenta » lun dic 08, 2008 19:51

Prima no, ora l'ho fatto. Ho sloggato e riloggato, ora il controllo volume di gnome mi fa regolare il volume, ma non sento comunque perchè l'unica periferica di output è il solito Null output.

PS: hai una pazienza infinita
tirallenta
Linux 1.0
Linux 1.0
 
Messaggi: 13
Iscritto il: lun dic 08, 2008 18:39
Slackware: 12.1
Kernel: 2.6.24-5-SMP
Desktop: GNOME

Prossimo

Torna a Gnome Slacky

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti