Repository 32bit  Forum
Repository 64bit  Wiki

Intel HD Graphics 4000 e problema driver Intel

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Intel HD Graphics 4000 e problema driver Intel

Messaggioda relay » mer nov 28, 2012 13:25

Ciao a tutti,ho un portatile ASUS N56VZ con due schede video:
-Intel HD Graphics 4000
-NVIDIA GeForce GT 650M, 2GB
Il mio problema e che andando su preferenze monitor mi dice:
Monitor Unknow e con l'unica risoluzione 1920x1080 (risoluzione nativa) non modificabile.
Il problema sta nel fatto che sembra che i driver Intel per la mia scheda grafica non vengano caricati.
Un po di output per darvi l'idea:
Premesso che il pacchetto xserver-xorg-video-intel è gia installato.
lspci:
Codice: Seleziona tutto
00:00.0 Host bridge: Intel Corporation Device 0154 (rev 09)
00:01.0 PCI bridge: Intel Corporation Device 0151 (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 0166 (rev 09)
00:14.0 USB Controller: Intel Corporation Device 1e31 (rev 04)
00:16.0 Communication controller: Intel Corporation Device 1e3a (rev 04)
00:1a.0 USB Controller: Intel Corporation Device 1e2d (rev 04)
00:1b.0 Audio device: Intel Corporation Device 1e20 (rev 04)
00:1c.0 PCI bridge: Intel Corporation Device 1e10 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Device 1e12 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Device 1e16 (rev c4)
00:1d.0 USB Controller: Intel Corporation Device 1e26 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Device 1e59 (rev 04)
00:1f.2 SATA controller: Intel Corporation Device 1e03 (rev 04)
00:1f.3 SMBus: Intel Corporation Device 1e22 (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation Device 0fd1 (rev a1)
03:00.0 Network controller: Intel Corporation Device 0887 (rev c4)
04:00.0 Ethernet controller: Atheros Communications Device 1091 (rev 10)

lshw -C display:
Codice: Seleziona tutto
 *-display UNCLAIMED     
       description: VGA compatible controller
       product: nVidia Corporation
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:44 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64)

/var/log/Xorg.0.log:
Codice: Seleziona tutto
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.0.0-1-amd64 x86_64 Debian
Current Operating System: Linux debby 3.2.0-0.bpo.3-amd64 #1 SMP Thu Aug 23 07:41:30 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-0.bpo.3-amd64 root=UUID=e2f788cc-3c47-4b9b-aa0d-d335e956ff85 ro quiet
Build Date: 29 October 2011  06:58:14PM
xorg-server 2:1.7.7-14 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.16.4
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 27 16:57:34 2012
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(==) No screen section available. Using defaults.
(**) |-->Screen "Default Screen Section" (0)
(**) |   |-->Monitor "<default monitor>"
(==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/100dpi/:unscaled,
   /usr/share/fonts/X11/75dpi/:unscaled,
   /usr/share/fonts/X11/Type1,
   /usr/share/fonts/X11/100dpi,
   /usr/share/fonts/X11/75dpi,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x7c8a40
(II) Module ABI versions:
   X.Org ANSI C Emulation: 0.4
   X.Org Video Driver: 6.0
   X.Org XInput driver : 7.0
   X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:0:2:0) 8086:0166:1043:2103 Intel Corporation rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
(--) PCI: (0:1:0:0) 10de:0fd1:1043:2103 nVidia Corporation rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension SELinux
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.13.0
   Module class: X.Org Server Extension
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(==) Matched intel as autoconfigured driver 0
(==) Matched vesa as autoconfigured driver 1
(==) Matched fbdev as autoconfigured driver 2
(==) Assigned the driver to the xf86ConfigLayout
(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.13.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vesa"
(II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
(II) Module vesa: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.3.0
   Module class: X.Org Video Driver
   ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
(II) Module fbdev: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 0.4.2
   ABI class: X.Org Video Driver, version 6.0
(II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
   Sandybridge, Sandybridge
(II) VESA: driver for VESA chipsets: vesa
(II) FBDEV: driver for framebuffer: fbdev
(II) Primary Device is: PCI 00@00:02:0
(EE) VESA: Kernel modesetting driver in use, refusing to load
(WW) Falling back to old probe method for vesa
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/linux/libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 0.0.2
   ABI class: X.Org Video Driver, version 6.0
(**) FBDEV(0): claimed PCI slot 0@0:2:0
(II) FBDEV(0): using default device
(II) FBDEV(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
(==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
(==) FBDEV(0): RGB weight 888
(==) FBDEV(0): Default visual is TrueColor
(==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) FBDEV(0): hardware: inteldrmfb (video memory: 8100kB)
(II) FBDEV(0): checking modes against framebuffer device...
(II) FBDEV(0): checking modes against monitor...
(--) FBDEV(0): Virtual size is 1920x1080 (pitch 1920)
(**) FBDEV(0):  Built-in mode "current"
(==) FBDEV(0): DPI set to (96, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(**) FBDEV(0): using shadow framebuffer
(II) Loading sub module "shadow"
(II) LoadModule: "shadow"
(II) Loading /usr/lib/xorg/modules/libshadow.so
(II) Module shadow: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 1.1.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) UnloadModule: "intel"
(II) Unloading /usr/lib/xorg/modules/drivers/intel_drv.so
(==) Depth 24 pixmap format is 32 bpp
(==) FBDEV(0): Backing store disabled
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(EE) FBDEV(0): FBIOPUTCMAP: Invalid argument
(==) FBDEV(0): DPMS enabled
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
SELinux: Disabled on system, not enabling in X server
(II) AIGLX: Screen 0 is not DRI2 capable
(II) AIGLX: Screen 0 is not DRI capable
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
(II) GLX: Initialized DRISWRAST GL provider for screen 0
(II) config/udev: Adding input device Power Button (/dev/input/event3)
(**) Power Button: Applying InputClass "evdev keyboard catchall"
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 2.3.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event3"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device Video Bus (/dev/input/event8)
(**) Video Bus: Applying InputClass "evdev keyboard catchall"
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event8"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device Video Bus (/dev/input/event7)
(**) Video Bus: Applying InputClass "evdev keyboard catchall"
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event7"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device Lid Switch (/dev/input/event1)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Sleep Button (/dev/input/event2)
(**) Sleep Button: Applying InputClass "evdev keyboard catchall"
(**) Sleep Button: always reports core events
(**) Sleep Button: Device: "/dev/input/event2"
(II) Sleep Button: Found keys
(II) Sleep Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device USB 2.0 UVC HD Webcam (/dev/input/event6)
(**) USB 2.0 UVC HD Webcam: Applying InputClass "evdev keyboard catchall"
(**) USB 2.0 UVC HD Webcam: always reports core events
(**) USB 2.0 UVC HD Webcam: Device: "/dev/input/event6"
(II) USB 2.0 UVC HD Webcam: Found keys
(II) USB 2.0 UVC HD Webcam: Configuring as keyboard
(II) XINPUT: Adding extended input device "USB 2.0 UVC HD Webcam" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event10)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event9)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
(**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event5)
(**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
(**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
   compiled for 1.7.6.901, module version = 1.2.2
   Module class: X.Org XInput Driver
   ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.2.2
(**) Option "Device" "/dev/input/event5"
(II) ETPS/2 Elantech Touchpad: x-axis range 0 - 3420
(II) ETPS/2 Elantech Touchpad: y-axis range 0 - 2052
(II) ETPS/2 Elantech Touchpad: pressure range 0 - 255
(II) ETPS/2 Elantech Touchpad: finger width range 0 - 15
(II) ETPS/2 Elantech Touchpad: buttons: left right double triple
(--) ETPS/2 Elantech Touchpad: touchpad found
(**) ETPS/2 Elantech Touchpad: always reports core events
(II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD)
(**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
(**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 0
(**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
(**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
(--) ETPS/2 Elantech Touchpad: touchpad found
(II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
(**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
(II) Synaptics touchpad driver version 1.2.2
ETPS/2 Elantech Touchpad no synaptics event device found
(**) Option "Device" "/dev/input/mouse0"
Query no Synaptics: 6003C8
(--) ETPS/2 Elantech Touchpad: no supported touchpad found
(EE) ETPS/2 Elantech Touchpad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "ETPS/2 Elantech Touchpad"
(II) UnloadModule: "synaptics"
(II) config/udev: Adding input device PC Speaker (/dev/input/event4)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device ACPI Virtual Keyboard Device (/dev/input/event11)
(**) ACPI Virtual Keyboard Device: Applying InputClass "evdev keyboard catchall"
(**) ACPI Virtual Keyboard Device: always reports core events
(**) ACPI Virtual Keyboard Device: Device: "/dev/input/event11"
(II) ACPI Virtual Keyboard Device: Found keys
(II) ACPI Virtual Keyboard Device: Configuring as keyboard
(II) XINPUT: Adding extended input device "ACPI Virtual Keyboard Device" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "it"
(II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/mouse1)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/event12)
(**) Logitech USB Optical Mouse: Applying InputClass "evdev pointer catchall"
(**) Logitech USB Optical Mouse: always reports core events
(**) Logitech USB Optical Mouse: Device: "/dev/input/event12"
(II) Logitech USB Optical Mouse: Found 12 mouse buttons
(II) Logitech USB Optical Mouse: Found scroll wheel(s)
(II) Logitech USB Optical Mouse: Found relative axes
(II) Logitech USB Optical Mouse: Found x and y relative axes
(II) Logitech USB Optical Mouse: Configuring as mouse
(**) Logitech USB Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Optical Mouse" (type: MOUSE)
(II) Logitech USB Optical Mouse: initialized for relative axes.
(II) config/udev: removing device Logitech USB Optical Mouse
(II) Logitech USB Optical Mouse: Close
(II) UnloadModule: "evdev"
(II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/mouse1)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/event12)
(**) Logitech USB Optical Mouse: Applying InputClass "evdev pointer catchall"
(**) Logitech USB Optical Mouse: always reports core events
(**) Logitech USB Optical Mouse: Device: "/dev/input/event12"
(II) Logitech USB Optical Mouse: Found 12 mouse buttons
(II) Logitech USB Optical Mouse: Found scroll wheel(s)
(II) Logitech USB Optical Mouse: Found relative axes
(II) Logitech USB Optical Mouse: Found x and y relative axes
(II) Logitech USB Optical Mouse: Configuring as mouse
(**) Logitech USB Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Optical Mouse" (type: MOUSE)
(II) Logitech USB Optical Mouse: initialized for relative axes.
(II) config/udev: removing device Logitech USB Optical Mouse
(II) Logitech USB Optical Mouse: Close
(II) UnloadModule: "evdev"
(II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/mouse1)
(II) No input driver/identifier specified (ignoring)
(II) config/udev: Adding input device Logitech USB Optical Mouse (/dev/input/event12)
(**) Logitech USB Optical Mouse: Applying InputClass "evdev pointer catchall"
(**) Logitech USB Optical Mouse: always reports core events
(**) Logitech USB Optical Mouse: Device: "/dev/input/event12"
(II) Logitech USB Optical Mouse: Found 12 mouse buttons
(II) Logitech USB Optical Mouse: Found scroll wheel(s)
(II) Logitech USB Optical Mouse: Found relative axes
(II) Logitech USB Optical Mouse: Found x and y relative axes
(II) Logitech USB Optical Mouse: Configuring as mouse
(**) Logitech USB Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB Optical Mouse" (type: MOUSE)
(II) Logitech USB Optical Mouse: initialized for relative axes.

Come si puo vedere il driver Intel video viene caricato ma in seguito lasciato:
Codice: Seleziona tutto
II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[...]
(II) LoadModule: "fbdev"
(II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[...]
(II) UnloadModule: "intel"
(II) Unloading /usr/lib/xorg/modules/drivers/intel_drv.so

Consigli?
relay
Linux 2.4
Linux 2.4
 
Messaggi: 290
Iscritto il: mar ago 28, 2007 15:36

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda joseph » mer nov 28, 2012 18:26

Guarda molto probabilmente utilizza il modulo "i915" vedi se viene caricato correttamente!
comunque ti anticipo che ho dovuto smanettarci parecchio prima di farla funzionare "diciamo correttamente"
Purtroppo queste schede intel integrate danno un pò di grattacapi.
Potresti risolvere disabilitando completamente la intel e utilizzando solo la NVIDIA 8)
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda rik70 » gio nov 29, 2012 9:59

Che sia la versione di Xorg - e del relativo driver intel - troppo "vecchia"?

Codice: Seleziona tutto
X.Org X Server 1.7.7
Release Date: 2010-05-04

[...]

(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
   compiled for 1.7.7, module version = 2.13.0



P.s.
Hai provato con una distro live recente?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1037
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda Eberoth » ven nov 30, 2012 19:17

Ciao,
Ho preso da poco un pc con esattamente le tue stesse schede video, ed all'inizio ho avuto lo stesso problema. Controlla che nel kernel sia abilitato (come moduli) intel_i915 e relativo drm e kms, poi elimina tutti i vari xf86-video-* trannte xf86-video-intel e, volendo, vesa.

La nvida, se la vuoi far andare, devi installare Bunblebee seguendo la guida su docs.slackware ed usando glislackbuild linkati lì. Ti garantisco che per gli usi "normali" la scheda intel se la cava alla grande...per tutto il resto c'è optirun.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda relay » mer dic 05, 2012 19:17

i moduli mi sembra vengano caricati:
Codice: Seleziona tutto
root@debby:/home/enrico# lsmod
Module                  Size  Used by
parport_pc             22191  0
ppdev                  12725  0
lp                     17190  0
parport                31650  3 parport_pc,ppdev,lp
bridge                 69831  0
stp                    12392  1 bridge
bnep                   17386  2
cpufreq_userspace      12576  0
cpufreq_conservative    13147  0
rfcomm                 32744  8
cpufreq_stats          12762  0
cpufreq_powersave      12454  0
binfmt_misc            12914  1
uinput                 17392  1
fuse                   61427  1
loop                   22699  0
arc4                   12458  2
snd_hda_codec_realtek   188466  1
nouveau               570360  0
i915                  362150  2
ttm                    52224  1 nouveau
drm_kms_helper         26950  2 nouveau,i915
snd_hda_intel          26023  1
snd_hda_codec          81579  2 snd_hda_codec_realtek,snd_hda_intel
uvcvideo               57559  0
iwlwifi               169448  0
videodev               70686  1 uvcvideo
snd_hwdep              13148  1 snd_hda_codec
snd_pcm                67465  2 snd_hda_intel,snd_hda_codec
drm                   167089  4 nouveau,i915,ttm,drm_kms_helper
mac80211              195629  1 iwlwifi
coretemp               12929  0
snd_seq                44678  0
crc32c_intel           12704  0
snd_timer              22658  2 snd_pcm,snd_seq
snd_seq_device         13155  1 snd_seq
asus_wmi               18670  0
ghash_clmulni_intel    13061  0
cfg80211              140318  2 iwlwifi,mac80211
sparse_keymap          12760  1 asus_wmi
media                  18148  2 uvcvideo,videodev
v4l2_compat_ioctl32    16663  1 videodev
i2c_algo_bit           12834  2 nouveau,i915
snd                    52458  10 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
i2c_i801               16870  0
i2c_core               23766  7 nouveau,i915,drm_kms_helper,videodev,drm,i2c_algo_bit,i2c_i801
btusb                  17417  2
joydev                 17138  0
ac                     12624  0
battery                13109  0
bluetooth             122093  23 bnep,rfcomm,btusb
acpi_cpufreq           12893  0
power_supply           13475  2 ac,battery
button                 12895  2 nouveau,i915
mxm_wmi                12473  1 nouveau
rfkill                 18970  5 asus_wmi,cfg80211,bluetooth
soundcore              13014  1 snd
snd_page_alloc         12969  2 snd_hda_intel,snd_pcm
aesni_intel            50498  1
cryptd                 14463  2 ghash_clmulni_intel,aesni_intel
aes_x86_64             16796  1 aesni_intel
aes_generic            37122  2 aesni_intel,aes_x86_64
tpm_tis                17315  0
tpm                    17841  1 tpm_tis
mperf                  12411  1 acpi_cpufreq
video                  17553  2 nouveau,i915
processor              27639  9 acpi_cpufreq
wmi                    13243  2 asus_wmi,mxm_wmi
tpm_bios               12903  1 tpm
psmouse                64191  0
pcspkr                 12579  0
serio_raw              12875  0
evdev                  17512  26
ext4                  355363  2
mbcache                12930  1 ext4
jbd2                   60877  1 ext4
crc16                  12343  2 bluetooth,ext4
sg                     25769  0
sr_mod                 21824  0
sd_mod                 35644  3
cdrom                  35134  1 sr_mod
crc_t10dif             12348  1 sd_mod
usbhid                 39946  0
hid                    80937  1 usbhid
ehci_hcd               39586  0
ahci                   24997  2
libahci                22714  1 ahci
libata                139579  2 ahci,libahci
scsi_mod              161684  4 sg,sr_mod,sd_mod,libata
xhci_hcd               72574  0
usbcore               127444  6 uvcvideo,btusb,usbhid,ehci_hcd,xhci_hcd
usb_common             12354  1 usbcore
thermal                17330  0
thermal_sys            17992  3 video,processor,thermal

Quando dici elimina i vari...intendi tutti i pacchetti xserver-xorg-video tipo apm ark ati chirrus che vengono descritti come display driver.Tenendo quindi solo xserver-xorg-video-intel display driver?
relay
Linux 2.4
Linux 2.4
 
Messaggi: 290
Iscritto il: mar ago 28, 2007 15:36

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda Eberoth » mer dic 05, 2012 22:38

sì, esatto.
A me capitava ad un certo punto che X usasse xf86-video-vmware come driver video, pensa te.... eliminando la "concorrenza" ha finalmente riconosciuto l'intel
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda relay » gio dic 06, 2012 13:55

Ciao, ho provato a disinstallare il pacchetto x-server-xorg-video-fbdev.Volevo vedere se escludendo questo mi caricava i driver Intel.Il risultato e che al riavvio non mi parte piu X.
Per tornare allo stato di prima dovrei reinstallare il pacchetto fbdev da riga di comando ma ancora prima avviare una connessione internet usando la shell di debian per connettermi al repository.
Mi daresti una mano nella procedura.
Grazie
relay
Linux 2.4
Linux 2.4
 
Messaggi: 290
Iscritto il: mar ago 28, 2007 15:36

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda Eberoth » gio dic 06, 2012 16:38

Io ti avevo consigliato di eliminare i pacchetti "xf86-video-*", che sono i vari "drivers" open; _non_ quelli con la parola "server", perché sono invece pacchetti necessari ad X per il suo funzionamento.

tra l'altro, tra xf86-video-* e x-server-*-video-* c'è una certa differenza...

Comunque, se hai il dvd di installazione, non serve che ti colleghi ad internet: ti basta montare manualmente il dvd da qualche parte ed installare il pacchetto a direttamente da lì.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda relay » lun dic 10, 2012 18:22

ok fatto.Comunque ricontrollando ho solo pacchetti x-server-video non xf86-video.
Grazie
relay
Linux 2.4
Linux 2.4
 
Messaggi: 290
Iscritto il: mar ago 28, 2007 15:36

Re: Intel HD Graphics 4000 e problema driver Intel

Messaggioda Eberoth » dom dic 23, 2012 2:22

ahem...mi sembra assai strano che tu non abbia pacchetti il cui nome cominci con xf86-video, visto che nel ramo x del DVD di installazione ce ne sono una decina...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 376
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite