Repository 32bit  Forum
Repository 64bit  Wiki

Non riesco a caricare l´agpgart

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Non riesco a caricare l´agpgart

Messaggioda Steffino » sab ago 28, 2004 18:24

Purtroppo non riesco a caricare questo benedetto modulo. <BR> <BR>dmesg mi da questo: <BR> <BR>Linux agpgart interface v0.99 (c) Jeff Hartmann <BR>agpgart: Maximum main memory to use for agp memory: 439M <BR>agpgart: Detected Via Apollo Pro KT400 chipset <BR>agpgart: unable to determine aperture size. <BR> <BR> <BR>Se provo a fare modprobe agpgart ho invece questo: <BR> <BR>/lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: init_module: Invalid argument <BR>/lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. <BR> You may find more information in syslog or the output from dmesg <BR>/lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: insmod /lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz failed <BR>/lib/modules/2.4.26/kernel/drivers/char/agp/agpgart.o.gz: insmod agpgart failed <BR> <BR>Facendo una ricerca con google ho trovato qualcuno che diceva che i kernel della famiglia 2.4.xx non supportano l´agp a 8x su chipset via kt400 (ed è il mio caso). <BR>Voi cosa ne sapete? Mi devo rassegnare e risolvere il problema passando al kernel 2.6? <BR> <BR>P.S.: La scheda video è una FX5900XT<br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda dennyv » sab ago 28, 2004 20:39

Ciao! Prova modprobe agpgart agp_try_unsupported=1 con il mio vecchio Apollo 133 funziona! <BR><BR><BR>[ Questo Messaggio è stato Modificato da: dennyv il 28-08-2004 21:40 ]<br>
dennyv
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: dom apr 25, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda Steffino » dom ago 29, 2004 16:53

Mi dispiace ma così non va, mi restituisce lo stesso errore di sopra. <BR>Comunque grazie. <BR>Hai (avete) altri suggerimenti?<br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda KiaZ » mar ago 31, 2004 11:01

Ho un problema mooooolto simile (mi pare che lo avevo anche postato nel forum specifico slack) con un chipset via KM400 e una sk ati radeon 9200 , ma anche a me il try_unsupported=1 non mi cambia la vita . <BR>Se hai una ati mi pare che ci sia un howto proprio su questo sito per fare andare l´agp in cui si parlava anche del chip KT400 in accpiata a sk video ati . <BR><br>
KiaZ
Linux 1.0
Linux 1.0
 
Messaggi: 32
Iscritto il: lun ago 23, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda Steffino » mar ago 31, 2004 17:42

Come ho scritto nel post di apertura (nel post scrittum), la mia scheda video è una nVidia FX 5900XT. <BR> <BR>A questo indirizzo (http://lists.debian.org/debian-user/200 ... 13012.html) c´è la pagina in cui si parla dei kernel 2.4.xx che non supportano l´agp a 8x sui chipset kt400. E´ solo una risposta in una discussione perciò volevo sapere se qualcuno di voi ne sapesse di più. <BR> <BR>Grazie.<br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda KiaZ » mer set 01, 2004 8:48

Io credo di aver risolto con il kernel 2.6.8.1 e i drivers ati (ho una radeon 9200) , non mi da piu´ quell´errore di unsupported . comunque ho sentito anche io in giro che con il 2.4 non si riesce ad usare l´agp 6x o 8x . <br>
KiaZ
Linux 1.0
Linux 1.0
 
Messaggi: 32
Iscritto il: lun ago 23, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda Steffino » mer set 01, 2004 15:06

Beh... a quanto pare allora non sono l´unico ad aver sentito questa voce sui kernel 2.4 e l´agp 8x. <BR>Un grazie a voi che avete risposto. Vuol dire che mi rassegnerò e passerò al 2.6. <BR>Ciao.<br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda useless » mer set 01, 2004 15:47

se può esservi utile: <BR>sukko@unholycathedral Mail $ /sbin/lspci <BR>00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge (rev 80) <BR>00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge <BR>00:0a.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10) <BR>00:0d.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 04) <BR>00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 01) <BR>00:10.0 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80) <BR>00:10.1 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80) <BR>00:10.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80) <BR>00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82) <BR>00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge <BR>00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06) <BR>01:00.0 VGA compatible controller: nVidia Corporation NV35 [GeForce FX 5900] (rev a1) <BR> <BR>sukko@unholycathedral Mail $ uname -a <BR>Linux unholycathedral 2.6.7 #2 Mon Aug 30 20:36:07 CEST 2004 i686 unknown unknown GNU/Linux <BR> <BR>sukko@unholycathedral Mail $ cat /proc/driver/nvidia/agp/card <BR>Fast Writes: Supported <BR>SBA: Supported <BR>AGP Rates: 8x 4x <BR>Registers: 0x1f000e1b:0x1f000302 <BR> <BR>sukko@unholycathedral Mail $ cat /proc/driver/nvidia/agp/host-bridge <BR>Host Bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge <BR>Fast Writes: Supported <BR>SBA: Supported <BR>AGP Rates: 8x 4x <BR>Registers: 0x1f000a1b:0x00000b02 <BR> <BR>sukko@unholycathedral Mail $ cat /proc/driver/nvidia/agp/status <BR>Status: Enabled <BR>Driver: NVIDIA <BR>AGP Rate: 8x <BR>Fast Writes: Disabled <BR>SBA: Enabled <BR> <BR>notare che io NON uso agpgart, bensì il modulo agp di nvidia, infatti: <BR>sukko@unholycathedral Mail $ grep -i nvagp /etc/X11/xorg.conf <BR> Option "NvAGP" "1" <BR> <BR>se volete altre info sparate ;-).<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Non riesco a caricare l´agpgart

Messaggioda Steffino » gio set 02, 2004 18:18

x useless <BR> <BR>Dall´ uname vedo che hai il kernel 2.6.7. Il problema che ho descritto si verifica con la serie 2.4. <BR> <BR>Comunque il tuo post mi induce a pensare che mi devo convincere ad usare il kernel 2.6. <BR> <BR>Ciao.<br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda useless » gio set 02, 2004 19:48

sì, lo sapevo, volevo solo darvi conferma che è tutto ok col 2.6. a parte che pensandoci ho reinstallato la 10 l´altro ieri, e non mi pare di aver visto errori simili, anche se non so se il modulo agpgart veniva caricato o meno (X l´ho avviato solo dopo aver messo il 2.6.7 e i driver nvidia). <BR> <BR>comunque xké mai hai paura di passare al 2.6? c´è molto da guadagnare! <BR> <BR>se proprio vuoi tenere il 2.4 prova con il driver agp nvidia. <BR> <BR><!-- BBCode Start --><A HREF="http://www.danasoft.com" TARGET="_blank"><!-- BBCode Start --><IMG SRC="http://www.danasoft.com/sig-ita.jpg"><!-- BBCode End --></A><!-- BBCode End --> <BR>Think free @ <!-- BBCode Start --><A HREF="http://www.nyft.org" TARGET="_blank">http://www.nyft.org</A><!-- BBCode End --> <BR><BR><BR>[ Questo Messaggio è stato Modificato da: useless il 02-09-2004 20:50 ]<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Non riesco a caricare l´agpgart

Messaggioda Steffino » ven set 03, 2004 18:08

Uso Linux da poco più di un anno e, ovviamente, mi sento ancora un novellino. Ho ricompilato il kernel una sola volta, era della serie 2.4. So che con il nuovo ci sono alcune differenze col file config. <BR> <BR>Scusa sto divagando, la paura di passare al 2.6 è generata dalla mia incompetenza.<br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda useless » ven set 03, 2004 18:57

do { <BR> fatto = prova (); <BR> if (!fatto) <BR> correggi (); <BR>} while (!fatto); <BR> <BR> <BR> <BR> 8-) 8-) :-] ;-) :-D <br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Non riesco a caricare l´agpgart

Messaggioda Steffino » ven set 03, 2004 18:59

Bell´algoritmo, perché non lo brevetti? :-D <br>
Steffino
Linux 1.0
Linux 1.0
 
Messaggi: 29
Iscritto il: gio lug 29, 2004 23:00

Non riesco a caricare l´agpgart

Messaggioda useless » ven set 03, 2004 20:25

perché preferisco rilasciarlo sotto GPL :-).<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 5 ospiti