Repository 32bit  Forum
Repository 64bit  Wiki

[CUPS] installazione stampante condivisa da windows

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[CUPS] installazione stampante condivisa da windows

Messaggioda nik600 » ven gen 12, 2007 10:33

Ciao
questo è il mio scenario:

- macchina windows con stampante condivisa in rete
- macchina linux (slackware 11.0)

Se installo la stampante sulla slackware seguendo la procedura guidata di Kde, (o anche direttamente a manina in cups) la stampante viene correttamente installata.

Il problema è che quando invio la stampa da linux sulla macchina windows il documento viene messo nella coda di stampa come: "Documento remoto a bassa priorità".

Questo, a volte viene stampato (dopo qualche minuto) a volte no, e resta li bloccando tutta la coda di stampa.

... suggerimenti?
grazie
nik600
Linux 2.4
Linux 2.4
 
Messaggi: 449
Iscritto il: lun mar 15, 2004 0:00

Messaggioda Luci0 » ven gen 12, 2007 16:51

Windows é così ... prendere o, lasciare...!! :-)

Con WXP e W2K spesso si hanno questi problemi ....

... is not a bug ... is a feature :-) !!!

E' più affidabile il contrario ma spesso il supporto per le stampanti sotto LINUX é inferiore,per contro stabilità del sistema é (... guarda caso :-) ) superiore...
Ovvero colleghi e configuri la stampante sotto Linux/ CUPS attivi la possibilità di stampa ai PC della sottorete e poi configuri sotto Windows la stampante come se fosse una stampante Postscript su porta Internet Printing http://192.168.0.X:631/printers/NomeStampante ... Se riesci a configurare tutto poi stamperai sempre ... non solo quando Windows ne ha voglia !!!
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda nik600 » ven gen 12, 2007 18:50

per favore niente guerre di religione.

Il fatto è che spesso ci si trova davanti a sistemi misti, e se si vuole fare contento il cliente (e contemporaneamente promuovere linux) bisongna farli funzionare e stop.

Grazie comunque
nik600
Linux 2.4
Linux 2.4
 
Messaggi: 449
Iscritto il: lun mar 15, 2004 0:00

Messaggioda Dani » ven gen 12, 2007 18:58

Luci0 ha scritto:Ovvero colleghi e configuri la stampante sotto Linux/ CUPS attivi la possibilità di stampa ai PC della sottorete e poi configuri sotto Windows la stampante come se fosse una stampante Postscript su porta Internet Printing http://192.168.0.X:631/printers/NomeStampante ... Se riesci a configurare tutto poi stamperai sempre ... non solo quando Windows ne ha voglia !!!


Ho un problema simile: sul windows che ho in lan ho installato una stampante e l'ho condivisa.
Dal mio windows riesco a stampare ma da linux niente.Ho configurato cups come dici tu, e come c'è scritto su s4d ma non riesco a stampare, i log di cups mi danno un timeout sul pc windows.

Inoltre su windows non risulta aperta la porta 631 ! Credo sia questa la causa del problema, anche se stranamente dal 'mio' win riesco a stampare...Forse tra windows si usa il protocollo netbios anzichè ipp ??
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Messaggioda Luci0 » ven gen 12, 2007 23:14

@Dani
Ciao ... se vuoi aiuto devi spiegare bene come hai fatto a configurare la stampante e come sono collegati i vari dispositivi ...
Altrimenti é un pasticcio ... :-)
Avatar utente
Luci0
Staff
Staff
 
Messaggi: 3591
Iscritto il: dom giu 26, 2005 23:00
Località: Forte dei Marmi
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce

Messaggioda Dani » sab gen 13, 2007 15:01

Si, in effetti non sono stato chiarissimo Immagine

La stampante è su 192.168.0.3, che ha installato windows xp sp2.
Io sono 192.168.0.2 ed ho installato sia windows che linux.

Aprendo il mio window (192.168.0.2), e andando su \\192.168.0.3 appare la stampante, ci clicco e mi fa installare i driver.La imposto come stampante predefinita, faccio una prova ed è tutto ok.

Su slackware invece ho seguito s4d: una volta installato cups, mi collego con il browser su localhost:631 e configuro la stampante, che ora è configurata così:

Description: HPDeskjet6540
Location: Nome_pc_windows
Device URI: http://192.168.0.3:631/printers/HPDeskjet

Sul pc windows, la roba condivisa è questa:

Codice: Seleziona tutto
Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC remoto
        D$              Disk      Condivisione predefinita
        print$          Disk      Driver della stampante
        HPDeskjet       Printer   HP Deskjet 6500 Series
        Documenti       Disk
        ADMIN$          Disk      Amministrazione remota
        C$              Disk      Condivisione predefinita


lpstat -p mi dà comunque un timeout, sarà dovuto al fatto che su windows (192.168.0.3) la porta 631 è chiusa ? Come la apro ?
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Messaggioda pino.giaquinto » dom gen 14, 2007 0:26

In passato ho avuto un problema simile al tuo ed ho risolto disabilitando la stampa bidirezionale su XP.
Avevo anch'io una stampante (hp deskjet) su XP condivisa e quando stampavo dal portatile (slackware) mi rimaneva il documento in coda e non riuscivo più a stampare neanche da XP!
Provaci e fammi sapere :)
Avatar utente
pino.giaquinto
Linux 2.4
Linux 2.4
 
Messaggi: 329
Iscritto il: mer gen 25, 2006 11:14

Messaggioda Dani » mar gen 16, 2007 2:14

pino.giaquinto ha scritto:In passato ho avuto un problema simile al tuo ed ho risolto disabilitando la stampa bidirezionale su XP.


Ehmm...Come si fa ? :oops:

Avevo anch'io una stampante (hp deskjet) su XP condivisa e quando stampavo dal portatile (slackware) mi rimaneva il documento in coda e non riuscivo più a stampare neanche da XP!
Provaci e fammi sapere :)


Ma su windows la porta 631 ce l'hai aperta (start,esegui,cmd,netstat -ano) ?
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Messaggioda skagway » mer gen 17, 2007 11:54

Stesso problema, ma con windows nt 4.

S4d.pdf indica che il server windows deve avere installato e configurato il protocollo IPP, che purtroppo su nt 4 non è supportato nativamente. Dove lo prendo?
Avatar utente
skagway
Linux 1.0
Linux 1.0
 
Messaggi: 73
Iscritto il: gio ago 10, 2006 7:45
Località: Pisa
Slackware: current 11/08/09
Kernel: 2.6.29.6-smp
Desktop: KDE 4.2.4


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: TurnitinBot [Bot] e 1 ospite