crash di amsn [RISOLTO]

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
goodchild
Linux 3.x
Linux 3.x
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

crash di amsn [RISOLTO]

Messaggioda goodchild » mer nov 21, 2007 17:19

Ciao, come da oggetto tutto d'un tratto amsn ha smesso di funzionare: appena faccio il login va in crash e appare la scritta

Codice: Seleziona tutto

*** glibc detected *** double free or corruption (!prev): 0x08964650 ***
Aborted


Che vuol dire il messaggio? E cosa posso fare per rifarlo funzionare? Ho gia' provato a rimuovere il pacchetto amsn e reinstallarlo [amsn-0.96-i486-1sl.tgz]
Ultima modifica di goodchild il mer nov 21, 2007 18:53, modificato 1 volta in totale.

goodchild
Linux 3.x
Linux 3.x
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

Messaggioda goodchild » mer nov 21, 2007 17:26

Ma soprattutto perche' se entro con un altra user mi fa entrare senza problemi?
Scusate la paranoia, ma e' possibile che qualcuno stia usando la mia username ed e' per quello che quando faccio il login mi crasha?

Avatar utente
JohnnyMnemonic
Staff
Staff
Messaggi: 2733
Iscritto il: dom set 05, 2004 0:00
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos
Località: Bologna
Contatta:

Messaggioda JohnnyMnemonic » mer nov 21, 2007 17:38

Assolutamente no, una breve ricerca sul forum e capirai qual è il tuo problema e come risolverlo velocemente

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Messaggioda conraid » mer nov 21, 2007 17:38

Più che reinstallare prova a cancellare, dopo aver fatto un backup, la director ~/.amsn e riavviare

Avatar utente
JohnnyMnemonic
Staff
Staff
Messaggi: 2733
Iscritto il: dom set 05, 2004 0:00
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos
Località: Bologna
Contatta:

Messaggioda JohnnyMnemonic » mer nov 21, 2007 17:39

Non è necessario cancellare la directory, il problema risiede nelle immagini degli utenti in cache e negli smileys salvati che portano al crash, basta modificare un file per risolvere tutto, come detto, basta cercare nel forum

Avatar utente
francogdn
Linux 2.x
Linux 2.x
Messaggi: 320
Iscritto il: ven mag 19, 2006 10:52
Distribuzione: Fedora
Località: Torino

Messaggioda francogdn » mer nov 21, 2007 17:41


Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Messaggioda conraid » mer nov 21, 2007 17:43

JohnnyMnemonic ha scritto:Non è necessario cancellare la directory, il problema risiede nelle immagini degli utenti in cache e negli smileys salvati che portano al crash, basta modificare un file per risolvere tutto, come detto, basta cercare nel forum


PNG per la precisione leggendo la list di amsn, ma era per velocizzare

Avatar utente
JohnnyMnemonic
Staff
Staff
Messaggi: 2733
Iscritto il: dom set 05, 2004 0:00
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos
Località: Bologna
Contatta:

Messaggioda JohnnyMnemonic » mer nov 21, 2007 17:46

conraid magari velocizzi però hai due spiacevoli inconvenienti, intanto il problema prima o poi si ripresenterà, inoltre perderesti tutte le impostazioni del programma, e nel mio caso sarebbe molto fastidioso

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Messaggioda conraid » mer nov 21, 2007 17:51

JohnnyMnemonic ha scritto:conraid magari velocizzi però hai due spiacevoli inconvenienti, intanto il problema prima o poi si ripresenterà, inoltre perderesti tutte le impostazioni del programma, e nel mio caso sarebbe molto fastidioso


Per questo avevo detto di fare un backup.
non sapevo del post del forum, non l'avevo visto.
Dare consigli ok, ma fare ricerche per altri è un po' troppo :-)

Solitamente vado a "fasi" per capire il problema, non era la "soluzione", però in effetti lui poteva non postare più e finiva li. Lo so, a volte do per scontato alcune cose :-(

Avatar utente
JohnnyMnemonic
Staff
Staff
Messaggi: 2733
Iscritto il: dom set 05, 2004 0:00
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos
Località: Bologna
Contatta:

Messaggioda JohnnyMnemonic » mer nov 21, 2007 18:29

Non avevo visto la parte del backup :oops:

conraid ha scritto:Dare consigli ok, ma fare ricerche per altri è un po' troppo


Non eri tu a doverla fare ;)

goodchild
Linux 3.x
Linux 3.x
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

Messaggioda goodchild » mer nov 21, 2007 18:31

avevo cercato nel forum ma anche inserendo il codice d'errore mi dava un centinaio di link e non ho visto quello giusto......
Grazie per avermi postato il link, ora mi metto al lavoro.

goodchild
Linux 3.x
Linux 3.x
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

Messaggioda goodchild » mer nov 21, 2007 18:53

Problema risolto, grazie di tutto

Avatar utente
wesbluemarine
Linux 0.x
Linux 0.x
Messaggi: 95
Iscritto il: mer set 12, 2007 8:57
Località: Lucca
Contatta:

Messaggioda wesbluemarine » gio nov 22, 2007 17:04

io ti consiglio di cambiare programma ;)

Avatar utente
JohnnyMnemonic
Staff
Staff
Messaggi: 2733
Iscritto il: dom set 05, 2004 0:00
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos
Località: Bologna
Contatta:

Messaggioda JohnnyMnemonic » gio nov 22, 2007 18:12

piccolo OT: in questi giorni sto provando emesene, sta crescendo rapidamente, merita almeno un'occhiata

Avatar utente
wesbluemarine
Linux 0.x
Linux 0.x
Messaggi: 95
Iscritto il: mer set 12, 2007 8:57
Località: Lucca
Contatta:

Messaggioda wesbluemarine » ven nov 23, 2007 13:30

emesene?ma guardate kmess che è integrato a kde,leggerissimo e a momenti uscirà la 1.5.....