Repository 32bit  Forum
Repository 64bit  Wiki

USB Mass Storage

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 19:26

ciao, <BR>dopo aver penato per mesi con un HD USB, l´altro giorno ho comprato un altro hd usb da 200 GB (che ci volete fare, con un portatile...). <BR>Sta di fatto che a causa dei limiti del FAT32, a quanto pare unico filesystem di interscambio con win (dato anche che non riesco a far funzionare il drive captive-ntfs), ho dovuto fare due partizioni FAT32 da 30 GB e una piu´ grande di NTFS. <BR>Nel momento in cui inserisco l´usb, la prima volta a tutto OK, il kernel crea sda1 sda2 sda3 per le tre partizioni. Dopo un po´ che accedo in scrittura ad entrambe (solo le fat32), compare qualcosa tipo: <BR> <BR>cp: cannot create regular file ´filedacopiare´: No such file or directory <BR> <BR>allora fasccio un list e non compare nulla.... <BR>riprovo la copia : cp: cannot create directory ´my´: Input/output error <BR> <BR>smonto e rimonto la partizione <BR> <BR>mount: special device /dev/sda1 does not exist <BR> <BR>e quesroto accade con tutte e tre le partizioni, spariscono da /dev. <BR>scollego e ricollego dalla usb...e non vengono ri-create... <BR> <BR>Al riavvio, ricompare parte di cio´ che avevo scritto sui filesystems fat32..... <BR> <BR>Salvatemi....<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda goodchild » ven nov 05, 2004 19:34

posta il tuo fstab. <BR>che kernel hai? <BR> <BR>fai partire senza il harddisk esterno e poi collegalo, controlla con lsmod che ci sia usb-storage e poi controlla il log se ha riconosciuto il harddisk esterno. prova lsusb o usbview per vedere cio´ che e´ attaccato alla porta usb. <BR> <BR>se ho capito bene <BR>200Gb (wow! ed io che vado avanti con il mio hd interno del laptop con 20Gb) <BR>--> 30Gb +30Gb + 140Gb<br>
goodchild
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 20:16

.. mess..cancellato... <BR> <BR>------ <BR> <BR>sorry, conteneva errori<BR><BR>[ Questo Messaggio è stato Modificato da: wally il 05-11-2004 20:19 ]<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 20:17

fstab: <BR>/dev/sda1 /mnt/ext1 vfat noauto,users,exec,rw 0 0 <BR>/dev/sda2 /mnt/ext2 vfat noauto,users,exec,rw 0 0 <BR>/dev/sda3 /mnt/ext3 ntfs noauto,users,exec,ro 0 0 <BR> <BR>kernel 2.6.7 <BR> <BR>usb_storage compare con lsmod <BR>------------------------------------------------------------------------------------------ <BR>se per log intendi syslog, allora le ultime righe sono: <BR> <BR>kernel: SCSI error : <2 0 0 0> return code = 0x50000 <BR>kernel: end_request: I/O error, dev sda, sector 322589 <BR>kernel: Bufer I/O error on device sda1m logical block 322526 <BR>kernel: lost page write due to I/O error on sda1 <BR>kernel: scsi2 (0:0): rejecting I/O to offline device <BR> <BR>questi mess si ripetono per una marea di settori, poi appare: <BR> <BR>kernel: FAT: unable to read inode block for updating (i_pos 481388) <BR>kernel: scsi2 (0:0) rejecting I/O to dead device <BR>kernel: FAT: Directory bread (block 30014) failed <BR> <BR>gli ultimi due si ripetono pressoche´ infinitamente....poi compare <BR> <BR>kernel: FAT bread failed in fat_cluster_flush <BR>kernel: slab error in kmem_cache_destroy(): cache ´scsi_smc_cache´ : Can´t free all objects <BR>kernel: [<c0135699>] kmem_cache_destroy+0x79/0xf0 <BR>kernel: [<c020ffbf>] scsi_destroy_comand_freelist+0x4f/0x90 <BR>kernel: [<c0210bc8>] scsi_host_dev_release+0x28/0x90 <BR>kernel: [<c01d08c3>] device_release+0x43/0x50 <BR>kernel: [<c0189103>] kobject_cleanup+0x83/0x90 <BR>kernel: [<c0217cf5>] scsi_sisk_put+0x25/0x40 <BR>kernel: [<c02181ff>] sd_release+0x2f/0x60 <BR>kernel: [<c014ea63>] blkdev_put+0x103/0x130 <BR>kernel: [<c014ea36>] blkdev_put+0xd6/0x130 <BR>kernel: [<c014cdbe>] deactivate_super+0x3e/0x50 <BR>kernel: [<c015f454>] sys_umount+0x34/0x80 <BR>kernel: [<c013db05>] do_munmap+0xd5/0x100 <BR>kernel: [<c015f4ac>] sys_oldumount+0xc/0x10 <BR>kernel: [<c0105d07>] syscall_call+0x7/0xb <BR>kernel: <BR>------------------------------------------------------------------------------------------- <BR>Credo che impallididresti se ti di cessi quanto l´ho pagato, mno di quanto tu possa pensare.....comunque, il multimedia chiede spazio :-) <BR> <BR>grazie <BR><br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda goodchild » ven nov 05, 2004 20:19

a parte che ora sono curioso di sapere quanto l´hai pagato! :p <BR> <BR>con kernel 2.6 ... non saprei in quanto non lo uso. pero´ non capisco come fanno a montarsi all´avvio se hai messo l´opzione noauto.<br>
goodchild
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 20:23

scusa, ho controllato bene, non monta all´avvio, comunque anche con diversi riavvii il problema persiste... <BR>--------------------------------------------------------------------------------------------------- <BR> <BR>OK, allora te lo dico.... <BR>HD Western Digital 200Gb + Rack esterno USB 2.0 (480 Mbit/s) <BR> 120 + 60 = 180 Euro <BR>--------------------------------------------------------------------------------------------------- <BR> <BR>:-P <BR>grazie ancora<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda goodchild » ven nov 05, 2004 20:29

bhe non e´ affatto tanto! visto e considerata anche la tassa antipirateria (motivo piu´ che legittimo per comprare mass storages all´estero se e´ possibile). <BR> <BR>riguardo all´errore te lo da´ anche quando avvii con harddisk staccato e poi lo attacchi quando il sistema e´ su? mmmh hai formattato con winxp?<br>
goodchild
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 20:33

collegato dopo l´avvio da: <BR> <BR>kernel: sda: assuming drive cache: write through <BR> <BR>non ho formattato con wnixp (solo la partizione NTFS). Per le FAT ho usato cfdisk<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 20:35

E´ giusto se come FAT ho scelto "W95 FAT32 (LBA)", vero?<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda wally » ven nov 05, 2004 20:52

Navigando su un forum ho risolto che per il mio hardware ho bisogno del kernel 2.6.9, sai mica dove posso trovare i tgz? <BR> <BR>grazie<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

USB Mass Storage

Messaggioda goodchild » ven nov 05, 2004 21:39

useless aveva detto di aver fatto i pacchetti ... credo circa un mese fa<br>
goodchild
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00

USB Mass Storage

Messaggioda useless » sab nov 06, 2004 12:19

be´, adesso ci sono quelli di PJV in /testing...<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

USB Mass Storage

Messaggioda goodchild » sab nov 06, 2004 18:07

bhe tanto meglio. <BR>ma nella 10.1 qualcuno sa se ci sara´ il 2.6 o ancora il 2.4 come kernel?<br>
goodchild
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: lun gen 12, 2004 0:00


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 4 ospiti