[Risolto]Kernel 2.6.26 e VIA K8T890: problemi

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
michelino
Staff
Staff
Messaggi: 871
Iscritto il: gio dic 21, 2006 11:59
Nome Cognome: Michelino Chionchio
Slackware: -current
Kernel: 2.6.29.6
Desktop: kde (current)
Località: Foggia

Re: Kernel 2.6.26 e VIA K8T890: problemi

Messaggioda michelino » sab dic 20, 2008 1:52

Io ho risolto semplicemente disabilitando pciexpress dal kernel....un po' brutale ma efficace

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: Kernel 2.6.26 e VIA K8T890: problemi

Messaggioda robbybby » sab dic 20, 2008 10:25

Ma le periferiche su bus pci express? Tipo la scheda video? Come fanno a funzionarti?

Oggi stavo provando la BW64 12.2. Ha dato i soliti messaggi di errore, e continuava a darli mentre funzionava, ma funzionava.
Poi ho dato un poweroff e... bummm! hanno cominciato a venire fuori i messaggi di errore e non si e' piu' ripreso :( . Per fortuna l'ho messa su una partizione di test :)

Avatar utente
manolo
Linux 2.x
Linux 2.x
Messaggi: 282
Iscritto il: gio mag 26, 2005 0:00
Desktop: kde

Re: Kernel 2.6.26 e VIA K8T890: problemi

Messaggioda manolo » sab dic 20, 2008 10:51

Compilato ora la 2.6.27.10. Disabilitando AER

Codice: Seleziona tutto

# CONFIG_PCIEAER is not set
non ho più i warning (ovviamente) e il sistema sembra andare...

Avatar utente
michelino
Staff
Staff
Messaggi: 871
Iscritto il: gio dic 21, 2006 11:59
Nome Cognome: Michelino Chionchio
Slackware: -current
Kernel: 2.6.29.6
Desktop: kde (current)
Località: Foggia

Re: Kernel 2.6.26 e VIA K8T890: problemi

Messaggioda michelino » sab dic 20, 2008 11:08

robbybby ha scritto:Ma le periferiche su bus pci express? Tipo la scheda video? Come fanno a funzionarti?

Bha, mi funziona tutto regolarmente (compresa la mia nvidia con driver proprietari va)...non capisco niente di hardware quindi la butto li....forse la vede come pci normale...

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: Kernel 2.6.26 e VIA K8T890: problemi

Messaggioda robbybby » sab dic 20, 2008 14:42

manolo ha scritto:Compilato ora la 2.6.27.10. Disabilitando AER

Codice: Seleziona tutto

# CONFIG_PCIEAER is not set
non ho più i warning (ovviamente) e il sistema sembra andare...


Funziona! :D :D :D
Grazie Manolo.

Per i kernel precompilati esiste l'opzione pci=noaer, per disabilitare l'AER.

Adesso devo decidere se installare la Slack 12.2, oppure la BW64 12.2.