Kernel-2.6.26.5 e alimentazione

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli
Contatta:

Kernel-2.6.26.5 e alimentazione

Messaggioda tigerwalk » mar ott 14, 2008 12:45

Ho compilato il kernel-2.6.26.5 usando il .config in uso (make oldconfig). Ho attivato alcune nuove feature tra cui il supporto per il led di iwl3945. Ho notato che se avvio il portatile con alimentazione a batteria, dopo la schermata di lilo... schermo nero e nessuna attività. Attaccando l'alimentazione di rete, riprende il boot e va normalmente a fine. Il tutto non accade col kernel precedente.
Nota: lo stesso fenomeno accade anche con Sabayon, col kernel 2.6.26.6-sabayon-r3. Peraltro, in questo caso l'aggiornamento è automatico (non ho dovuto ricompilare).
A questo punto mi pare di poter asserire che il problema è causato da qualche impostazione del kernel, ma non saprei dove guardare.
Se mi dite le parti di log che possono aiutare, ve le posto volentieri, come pure mi interesserebbe sapere se capita a qualcun'altro.

p.s.: La macchina è un toshiba satellite A/100 i686 Genuine Intel(R) CPU T2300 @ 1.66GHz GenuineIntel

Avatar utente
touchstyle
Linux 4.x
Linux 4.x
Messaggi: 1085
Iscritto il: gio mag 13, 2004 0:00
Slackware: 12.1
Kernel: 2.6.27
Desktop: KDE
Località: Portogruaro [VE]
Contatta:

Re: Kernel-2.6.26.5 e alimentazione

Messaggioda touchstyle » mar ott 14, 2008 14:07

Hai provato a ricompilare togliendo o utilizzando come modulo il ramo ACPI?

Ciao,
Touch.

Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli
Contatta:

Re: Kernel-2.6.26.5 e alimentazione

Messaggioda tigerwalk » mar ott 14, 2008 16:59

touchstyle ha scritto:Hai provato a ricompilare togliendo o utilizzando come modulo il ramo ACPI?

Ciao,
Touch.

Ho provato a mettere tutto come modulo e non va lo stesso. Ho anche provato a dare nelle opzioni di boot acpi=off ma, così facendo, non parte nemmeno attaccando successivamante l'alimentazione di rete.
Altre idee?

Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli
Contatta:

Re: Kernel-2.6.26.5 e alimentazione

Messaggioda tigerwalk » mer ott 15, 2008 10:41

Update
Nemmeno con un aggiornamento del bios sono riuscito a risolvere.
Praticamente col nuovo kernel o mi attacco all'alimentazione di rete oppure mi attacco.... :(

Avatar utente
conraid
Staff
Staff
Messaggi: 13048
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Kernel-2.6.26.5 e alimentazione

Messaggioda conraid » mer ott 15, 2008 10:45

tigerwalk ha scritto:Update
Nemmeno con un aggiornamento del bios sono riuscito a risolvere.
Praticamente col nuovo kernel o mi attacco all'alimentazione di rete oppure mi attacco.... :(


Prova il 2.6.27 per vedere se era qualche problema di quella release

Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun feb 25, 2008 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli
Contatta:

Re: Kernel-2.6.26.5 e alimentazione

Messaggioda tigerwalk » mer ott 15, 2008 14:13

il 2.6.27 pare andare bene!
Resta comunque irrisolto il motivo del perchè nel 2.6.26.5 faccia così...

Avatar utente
conraid
Staff
Staff
Messaggi: 13048
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Kernel-2.6.26.5 e alimentazione

Messaggioda conraid » mer ott 15, 2008 14:52

tigerwalk ha scritto:il 2.6.27 pare andare bene!
Resta comunque irrisolto il motivo del perchè nel 2.6.26.5 faccia così...


A me nel notebook il 2.6.26.* dava errori in fase di avvio appena riconosceva la scheda wifi, non sempre, ma spesso.
Ogni release ha le sue idiosincrasie :-)