gspca, pac207 e kernel 2.6.29.1

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
sardylan
Linux 3.x
Linux 3.x
Messaggi: 993
Iscritto il: mar apr 24, 2007 9:21
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.14
Distribuzione: Debian - CLFS
Località: Cagliari
Contatta:

Re: gspca, pac207 e kernel 2.6.29.1

Messaggioda sardylan » lun ott 12, 2009 9:58

Usi la Slackware, o la Slackware64 ??

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom feb 13, 2005 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: gspca, pac207 e kernel 2.6.29.1

Messaggioda corrado » lun ott 12, 2009 15:16

sardylan ha scritto:Usi la Slackware, o la Slackware64 ??


La slackware 32 bit, non la 64.
Il kernel è l'ultimo della current non ricompilato da me.

Saluti
corrado

Avatar utente
robbybby
Linux 4.x
Linux 4.x
Messaggi: 1223
Iscritto il: sab dic 16, 2006 10:48
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5
Località: Fra Trantor e Terminus

Re: gspca, pac207 e kernel 2.6.29.1

Messaggioda robbybby » dom nov 29, 2009 22:20

Un'aggiunta, anche se il thread e' vecchio, ma non e' stato detto in precedenza.
La mia webcam, che usa i driver UVC, funziona in tutti i programmi che ho provato (tranne kopete, vabbe', ma li' e' un noto bug di kopete stesso), tranne che in Skype. Mettendo l'LD_PRELOAD funziona anche con Skype.

Avatar utente
corrado
Linux 2.x
Linux 2.x
Messaggi: 218
Iscritto il: dom feb 13, 2005 0:00
Nome Cognome: corrado
Slackware: current
Kernel: 2.6.29.6-smp
Desktop: kde-4
Località: isola del liri
Contatta:

Re: gspca, pac207 e kernel 2.6.29.1

Messaggioda corrado » ven dic 11, 2009 21:15

Ciao a tutti,
sto ancora litigando con la webcam che viene così riconosciuta:

Codice: Seleziona tutto

BUS 002 Device 005: ID 046d:c8da Logitech, Inc. QuickCam Messanger


Nel file /etc/profile ho aggiunto la riga:

Codice: Seleziona tutto

export LD_PRELOAD="/usr/lib/libv4l/v4l1compat.so"


xawtv la rileva, ma quando lo lancio ottengo il seguente errore:

Codice: Seleziona tutto

corrado@darkstar:~$ xawtv -device /dev/video0
This is xawtv-3.95, running on Linux/i686 (2.6.29.6-smp)
xinerama 0: 1680x1050+0+0
WARNING: Your X-Server has no DGA support.
/dev/video0 [v4l2]: no overlay support
v4l-conf had some trouble, trying to continue anyway
libv4lcontrol: error creating shm segment failed: No such file or directory
libv4lcontrol: falling back to malloc-ed memory for controls
libv4lcontrol: error creating shm segment failed: No such file or directory
libv4lcontrol: falling back to malloc-ed memory for controls
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
libv4l2: error dequeuing buf: Invalid argument
ioctl: VIDIOC_DQBUF(index=0;type=VIDEO_CAPTURE;bytesused=0;flags=0x0 [];field=ANY;;timecode.type=0;timecode.flags=0;timecode.frames=0;timecode.seconds=0;timecode.minutes=0;timecode.hours=0;timecode.userbits="";sequence=0;memory=unknown): Invalid argument


Idee?

Saluti
corrado