E' uscito Google Earth 5.1 con le Qt4-4.5.2

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda phobos3576 » gio set 10, 2009 23:27

E' disponibile per il download la nuova beta di Google Earth versione 5.1.3506.3999; la novità è che la versione Linux adesso utilizza le Qt4-4.5.2. Lo ho scoperto aprendo la libreria /opt/google-earth/libQtCore.so.4 con un editor esadecimale come KHexEdit e facendo una ricerca all'interno del codice che mi ha permesso di trovare appunto la stringa "Qt4-4.5.2".

Ho provato GE 5.1 sulla Slackware 12.2 (con le Qt4-4.5.2 in /opt/qt4) e ho notato che purtroppo permane ancora il problema delle coordinate sbagliate; in pratica, i nomi delle località vengono visualizzati in posizioni errate per il fatto che viene troncata la parte decimale dei valori che rappresentano la longitudine e la latitudine.

Inoltre, non viene più preso in considerazione il file $HOME/.config/Trolltech.conf, per cui i font della GUI di GE non coincidono con quelli delle altre applicazioni Qt4.

C'è da notare poi che, anche in questa versione, i video YouTube non risultano funzionanti dall'interno di GE 5.1; tutto ciò nonostante le Qt4-4.5.2 siano in grado di usare il plugin FlashPlayer attraverso un wrapper (esempio pratico, Arora).

Magari, se qualcuno può provare GE 5.1 sulla Slackware 13, così si può vedere se in quel caso i problemi permangono.

zxzxasas
Linux 2.4
Linux 2.4
Messaggi: 397
Iscritto il: sab nov 15, 2008 2:28
Nome Cognome: Pasquale
Slackware: current
Kernel: 2.6.35.7
Desktop: KDE 4.5.2

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda zxzxasas » ven set 11, 2009 13:26

Codice: Seleziona tutto

root@darkstar:/home/pasquale/Downloads# sh GoogleEarthLinux.bin
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 5.1.3506.3999..............................................................
./setup.sh: line 216: setup.data/bin/Linux/amd64/setup.gtk2: No such file or directory
./setup.sh: line 216: setup.data/bin/Linux/amd64/setup.gtk: No such file or directory
The setup program seems to have failed on amd64

Fatal error, installer failed to run at all!

Avatar utente
teox99
Linux 2.6
Linux 2.6
Messaggi: 738
Iscritto il: ven lug 25, 2008 14:54
Slackware: 13.37
Desktop: KDE - Xfce
Località: Roma[Eur]
Contatta:

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda teox99 » ven set 11, 2009 15:41

Google Earth 5.1.3506.3999 (beta)
Build Date Sep 8, 2009
Build Time 10:06:25 am
Renderer OpenGL
Operating System Linux (2.6.29.6)
Video Driver NVIDIA Corporation
Max Texture Size 8192x8192
Server kh.google.com

Slackware 13.0
funziona perfettamente.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda phobos3576 » ven set 11, 2009 16:06

teox99 ha scritto:Google Earth 5.1.3506.3999 (beta)
Build Date Sep 8, 2009
Build Time 10:06:25 am
Renderer OpenGL
Operating System Linux (2.6.29.6)
Video Driver NVIDIA Corporation
Max Texture Size 8192x8192
Server kh.google.com

Slackware 13.0
funziona perfettamente.


Riesci a vedere anche i video YouTube dall'interno di GE 5.1?

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda phobos3576 » ven set 11, 2009 17:48

Girando in Rete ho trovato il perché di questo problema; si tratta di una di quelle cose che fanno veramente incavolare.

E' un po ciò che è successo al Mars Climate Orbiter, schiantatosi su Marte a causa della confusione fatta alla NASA tra i sistemi di unità di misura MKS e CGS.

Nel caso di GE 5.x, quando si imposta il proprio LOCALE a it_IT, viene usata la virgola come separatore decimale (al posto del punto); quella virgola non viene interpretata correttamente e la parte decimale delle coordinate viene troncata.

Probabilmente il bug risiede nelle Qt4-4.5.x in quanto non si verifica con le Qt4-4.4.x.

Chi riscontra questo problema, non deve fare altro che editare lo script /opt/google-earth/googleearth e cercare la riga:

Codice: Seleziona tutto

export LD_LIBRARY_PATH

Sotto quella riga basta aggiungere:

Codice: Seleziona tutto

export LC_ALL=us_US.UTF-8
export LANG=it_IT.UTF-8

Il primo export permette di usare il punto come separatore decimale; il secondo export permette di avere i menu in italiano.

Mi auguro che con l'imminente uscita delle Qt4-4.6 si provveda a correggere un problema così imbarazzante.

Avatar utente
teox99
Linux 2.6
Linux 2.6
Messaggi: 738
Iscritto il: ven lug 25, 2008 14:54
Slackware: 13.37
Desktop: KDE - Xfce
Località: Roma[Eur]
Contatta:

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda teox99 » ven set 11, 2009 20:20

@phobos3576 quando torno in ufficio ti faccio sapere

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda phobos3576 » ven set 11, 2009 21:04

teox99 ha scritto:@phobos3576 quando torno in ufficio ti faccio sapere

Magari controlla pure se a te viene visualizzata l'altitudine quando scorri il cursore del mouse sul terreno; nel mio caso, resta sempre a zero.

Avatar utente
teox99
Linux 2.6
Linux 2.6
Messaggi: 738
Iscritto il: ven lug 25, 2008 14:54
Slackware: 13.37
Desktop: KDE - Xfce
Località: Roma[Eur]
Contatta:

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda teox99 » dom set 13, 2009 11:27

@phobos3576 l'elevazione viene fuori solo se hai flaggato la voce 'Terrain' (o terreno?) nel menu di sx.

per il resto a domani

Avatar utente
teox99
Linux 2.6
Linux 2.6
Messaggi: 738
Iscritto il: ven lug 25, 2008 14:54
Slackware: 13.37
Desktop: KDE - Xfce
Località: Roma[Eur]
Contatta:

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda teox99 » lun set 14, 2009 9:43

allora i viedeo di youtube vengono aperti nel browser.

Avatar utente
nicolix
Linux 2.0
Linux 2.0
Messaggi: 163
Iscritto il: lun mar 09, 2009 6:07
Nome Cognome: nicolò
Slackware: 13
Kernel: 2.6.29.6-smp
Desktop: kde
Distribuzione: slackware
Contatta:

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda nicolix » mar set 15, 2009 13:56

Buono a sapersi!!!! vado subito a provarlo... :D

Avatar utente
Zapotech
Packager
Packager
Messaggi: 155
Iscritto il: gio set 07, 2006 22:58
Slackware: -current
Kernel: 2.6.32.5-smp
Desktop: kde 4.3.4
Località: Roma

Re: E' uscito Google Earth 5.1 con le Qt4-4.5.2

Messaggioda Zapotech » mer set 16, 2009 17:50

Ciao :)
phobos3576 ha scritto:Ho provato GE 5.1 sulla Slackware 12.2 (con le Qt4-4.5.2 in /opt/qt4) e ho notato che purtroppo permane ancora il problema delle coordinate sbagliate; in pratica, i nomi delle località vengono visualizzati in posizioni errate per il fatto che viene troncata la parte decimale dei valori che rappresentano la longitudine e la latitudine.
Impostando LANG=it_IT (oppure it_IT@euro), sulla slackware 13.0, la parte decimale delle coordinate viene visualizzata con la virgola.
Non ho riscontrato problemi per il posizionamento di [Località], [Strade] ed [Edifici 3D] ma ne ho riscontrati, invece, per la esatta localizzazione delle [Street View] e dei [filmati YouTube].


phobos3576 ha scritto:Nel caso di GE 5.x, quando si imposta il proprio LOCALE a it_IT, viene usata la virgola come separatore decimale (al posto del punto); quella virgola non viene interpretata correttamente e la parte decimale delle coordinate viene troncata
Grazie al tuo suggerimento ;) ho notato, infatti, che se faccio partire googleearth con

Codice: Seleziona tutto

LC_NUMERIC=en_US /usr/bin/googleearth
riesco ad ottenere la posizione corretta anche delle [Street View] e dei [filmati YouTube]. In questo caso la parte decimale delle coordinate viene espressa con il punto.


Torna a “Gnu/Linux in genere”

Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti