Firefox 61.0beta parliamone

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2912
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » lun giu 11, 2018 16:33

Volevo provare midori e nel lanciare sbopkg ho visto che dipende fra gli altri da webkitgtk.
Ho controllato e WebkitGTK non è presente sul mio sistema.
La sua assenza potrebbe essere anche la causa della mancata riproduzione del video usando firefox?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2447
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc2
Desktop: lxde
Località: Pisa
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda ponce » lun giu 11, 2018 18:34

joe ha scritto:Volevo provare midori e nel lanciare sbopkg ho visto che dipende fra gli altri da webkitgtk.
Ho controllato e WebkitGTK non è presente sul mio sistema.

occhio che dipende da webkit2gtk, non webkitgtk.
La sua assenza potrebbe essere anche la causa della mancata riproduzione del video usando firefox?

no, non lo riproduce nemmeno a me (e io ho installati sia webkitgtk, sia webkit2gtk).

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2912
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » lun giu 11, 2018 19:14

Ah facciamo un ricapitolo...

a me e a te (Ponce) firefox non riproduce il video.

A rik trotto lablinux conraid e gli altri intervenuti prima, invece funziona.

Quale diamine potrebbe essere il discrimine?


PS.
Ho provato midori, sì webkit2gtk, ho fatto tutto con sbopkg e la sua coda.
Provando però ad aprire il noto link con midori ottengo:
- aprendo la pagina del sito:
http://www.video.mediaset.it/video/stas ... 50100.html

parte la pubblicità, poi quando termina, il riquadro del video resta nero.

- Invece aprendo il link diretto al video ottenevo un messaggio d'errore:
"'No compatible source issue was found for this media"

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2447
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc2
Desktop: lxde
Località: Pisa
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda ponce » lun giu 11, 2018 19:45

joe ha scritto:Ah facciamo un ricapitolo...

a me e a te (Ponce) firefox non riproduce il video.

A rik trotto lablinux conraid e gli altri intervenuti prima, invece funziona.

Quale diamine potrebbe essere il discrimine?

non saprei.
se puo' esserti d'aiuto uso l'ultima beta e lo sto provando su macchine che usano i driver nvidia (non ho idea se faccia la differenza) ma, se mi permetti di essere franco, non e' che abbia tutto questo interesse ad approfondire (il fatto che si tratti di mediaset poi mi scoraggia del tutto :) ).

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2912
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » lun giu 11, 2018 20:23

Offtopic: No guarda, a me non me ne può importare di meno dei contenuti in generale. Capisco comunque lo scoraggiamento, a dirla tutta ero finito casualmente sul video del link solo perchè uno degli ospiti ospite di quel programma di quella sera aveva comunicato che sarebbe stato lì e mi interessava sentire cosa avrebbe detto.

Tornando in tema... se anche a te non funziona, probabilmente abbiamo qualche pezzo di sistema similmente mancante.
Almeno rispetto agli altri.
Di firefox ho provato varie beta, sia l'ultima che alcune altre precedenti, sia la vecchia stabile che l'attuale stabile.
Direi che quantomeno la versione di firefox non c'entra troppo, perchè non sono mai riuscito a riprodurre quel video con nessuna versione di firefox...
Firefoxo che ho installato usando i precompilati attraverso lo script di "ruario" che mi avevano consigliato qui... Mi pare fosse stato trotto, ma a lui il pacchetto installato così sembra funzioni.
Pertanto escluderei come imputato anche il pacchetto di firefox creato dai binari precompilati del loro sito.

Mi insospettisce invece di più qualche altra cosa che ho (o manca) sul sistema che per qualche santo interferisce con quel tipo di streaming. Che pare effettivamente un po' particolare nel modo in cui viene "servito".

Anche ffmpeg di sistema... non saprei se sia lui il probrema:
infatti disinstallandolo e aprendo un video di youtube lo vedo bene ugualmente, sempre via html5.... (nel dubibo per testare avevo rimosso anche il flashplayer plugin, che comunqu non dovrebbe c'entrare nulla).

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1079
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Firefox 61.0beta parliamone

Messaggioda lablinux » lun giu 11, 2018 22:37

Io l'ho provato in Windows, quindi precompilato

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1079
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Firefox 61.0beta parliamone

Messaggioda lablinux » lun giu 11, 2018 22:41

Non è che hai qualche impostazione che blocca il video o il link?

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2912
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » mar giu 12, 2018 0:02

Ma gli altri video li vedo regolarmente.
Ad esempio che impostazione avresti in mente?

Guarda le ho provate tutte (almeno penso...), se hai letto i messaggi precedenti avrai visto che ho rasato anche la directory ~/.mozilla in modo che se la ricreasse prendendo impostazioni di default...

Il fatto poi che non funzioni neanche a Ponce mi fa pensare a qualche altro pacchetto che possiamo entrambi aver compilato da SBo e che possa influenzare questo comportamento, non so tipo qualche libreria compilata con impostazioni diverse dalle vostre...

Te hai provato solo da windows? Su slackware ti funziona?

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1079
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Firefox 61.0beta parliamone

Messaggioda lablinux » mar giu 12, 2018 0:13

i drm? Vedi netflix?
PS ho provato con ff 60.0.1 da Ubuntu 18.04 e funziona e funziona anche netflix dopo aver approvato l'uso dei drm (o qualcosa del genere)

Avatar utente
conraid
Staff
Staff
Messaggi: 13152
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda conraid » mar giu 12, 2018 8:02

A me funziona con firefox standard della current e ffmpeg ricompilato da me.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2912
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » mar giu 12, 2018 10:04

Anzitutto grazie per le risposte e scusate se ho alzato tutto sto polverone. :D

@lablinux
drm... No no, non intendevo drm o netflix. Facevo solamente riferimento alla modalità di streaming di quel particolare video, che viene servito in modo un po' anomalo rispetto ad altri video in cui mi sono imbattuto solitamente.

@conraid
Io sono sulla 14.2, e non è più un sistema "pulito" nel senso che nel tempo ho aggiunto un sacco di roba, ricompilata e non.
Potrei provare a prendere il materiale di Pat e ccompilare il pacchetto per firefox, tanto per vedere se risolve.

Ad ogni modo mi viene il dubbio che ffmpeg non sia coinvolto per la riproduzione del video.
Dico questo perchè, se facciamo un altro esempio:

http://www.la7.it/meteola7/rivedila7/il ... 018-244062

Questo lo vedo senza problemi con firefox.
Di più:
lo vedo bene anche dopo aver disinstallato temporaneamente FFMpeg.
Ho provato anche con lo "streaming live", sempre di la7 e si vede bene anche quello.
L'altro video, quello di mediaset, non si vede ugualmente, con o senza ffmpeg.

Ti chiederei una cortesia conraid:
non è che potresti rimuovere temporaneamente FFMpeg, provare la pagina del video e verificare se te lo riproduce correttamente anche senza firefox?

Per come la vedo io, il mio firefox non ha sempre bisogno di ffmpeg, altrimenti non si spiegherebbe come farebbe a riprodurre i video di youtube oppure quello sopra di la7. E questo ripeto, senza ffmpeg installato.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1079
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Firefox 61.0beta parliamone

Messaggioda lablinux » mar giu 12, 2018 10:09

netflix era un esempio, senza drm non funziona. Fino alla versione di ff 58 (o 57) dovevo usare Chrome per usare il servizio di streeming.
Magari anche al video mediaset serve attivo il drm .

Avatar utente
conraid
Staff
Staff
Messaggi: 13152
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda conraid » mar giu 12, 2018 10:24

Allora, fatto prova.

Senza ffmpeg: non va nessun video tra mediaset, la7 e gazzetta
Con ffmpeg di default: va solo gazzetta
Con ffmpeg ricompilato: vanno tutti

p.s.
hai qualche adblock attivo?

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2912
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » mar giu 12, 2018 11:06

@lablinux

E scusa l'ignoranza, ma come si potrebbe attivare?

Ah ho visto... dalle preferenze di firefox. Era disabilitato in effetti.

Ora invece tra i plugins si è aggiunto "Widevine Content Decription ecc...".
Prima c'era solo "OpenH264 video codec provided by cisco system".

Ad ogni modo ho riprovato, ma il video non parte neanche così.


@conraid
Grazie della disponibilità!

Ecco, il mio sospetto era fondato...
Come è possibile che a me senza ffmpeg, usando firefox come browser funzionino tutti i video, sia la7, sia youtube ad esempio?
Mentre a te no?

Potrebbe essere che in qualche modo il mio firefox (installato via binari precompilati) non si appoggi al mio ffmpeg di sistema (ricompilato a mano), ma riesca a riprodurre i video sfruttando qualche "streamer" incluso nei binari messi a disposizione da mozilla?

Tanto per fare la prova del nove, poteresti provare a pacchettizzarti firefox senza ricompilazione con lo script di "ruario":
https://gist.github.com/ruario/9672798
Con questo in pratica ottieni un pacchetto slackware, da sostituire temporaneamente al tuo firefox.
una volta installato fai di nuovo la prova con e senza ffmpeg installato...
sempre se ne ahi voglia eh... e grazie in anticipo!

Avatar utente
conraid
Staff
Staff
Messaggi: 13152
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda conraid » mar giu 12, 2018 11:15

Di fare quella prova ora non ho modo, ma ricordo che a suo tempo con firefox-dev (che è la versione in binario di mozilla con qualche estensione) non avevo problemi, quindi sì, credo che le versioni prese da loro abbiano qualcosa di statico al loro interno.