Firefox 61.0beta parliamone

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
rik70
Master
Master
Messaggi: 1913
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 4.17
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: Firefox 61.0beta parliamone

Messaggioda rik70 » gio giu 07, 2018 11:53

@joe
Domanda: perché usi flashplayer?

Per riprodurre quel video non ce n'è alcun bisogno. Io ormai viaggio senza da tempo e finora non ho mai avuto problemi.

Testato con Firefox 61.0b11.

P.s.
Mi pare di capire che quel video viene caricato tramite uno o più javascript e sono abbastanza pesanti. Che CPU hai?

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2900
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » gio giu 07, 2018 11:55

Ah non serve flashplayer?
Allora come non detto...

No ma la CPU, sì è vecchiotta

Codice: Seleziona tutto

Intel(R) Core(TM)2 Duo CPU     E8200  @ 2.66GHz

Però non dovrebbe essere quello il problema...
Perchè con chromium il video mi parte tranquillamente...

Ho fatto la prova del nove:

Codice: Seleziona tutto

mv .mozilla .mozilla-bk
firefox --safe-mode

Anche così non funziona.


Offtopic: Ho anche fatto del casino dopo:

Codice: Seleziona tutto

mv .mozilla-bk .mozilla

E aquesto punto lanciando di nuovo firefox i miei segnalibri sono svaniti! #-o
Dovevo prima rimuovere la ".mozilla" e poi copiare quella di backup (mai rinominare, sempre copiare... ora lo vado a scrivere 100 volte)

rik70
Master
Master
Messaggi: 1913
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 4.17
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: Firefox 61.0beta parliamone

Messaggioda rik70 » gio giu 07, 2018 12:16

Uhm... ti bastava creare un nuovo profilo e.... vabbe ormai il "dato è tratto".

E se punti direttamente alla pagina del video cambia qualcosa?

Se non va il link, estrai l'url dal sorgente html, si trova in:

Codice: Seleziona tutto

 <div id="myVideoContainer" class="pf-container">
    <iframe id="player_mediasetplay" data-src="[....]"></iframe>
 .....

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3529
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda Trotto@81 » gio giu 07, 2018 13:23

Non installo il flash player da anni e non ne sento la mancanza. Uso Firefox 60beta8 su una Slackware current di febbraio 2016, sperando di aggiornare quanto prima.
Ultima modifica di Trotto@81 il gio giu 07, 2018 13:58, modificato 1 volta in totale.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1068
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Firefox 61.0beta parliamone

Messaggioda lablinux » gio giu 07, 2018 13:40

hai provato ad eseguire ff da shell? Magari recuperi altre informazioni

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2900
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » gio giu 07, 2018 13:58

No non funziona neanche così, vedo solo le solite palline viola che simulano il caricamento del video, ma in realtà non caricano nulla, infine viene giù la solita barra gialla.

Siccome ho diversi browser installati, ho notato un fatto curioso:
Il video non si carica con
- konqueror
- seamonkey
- palemoon
- firefox quantum (quello di cui stiamo parlando)
- otter

Un video differente da quello atteso (pubblicità), parte con
- opera

Il video parte coi browser
- Chromium
- QupZilla
- Brave

Siccome QupZilla e Chromium li ho compilati sul mio sistema via Slackbuild, mi è venuto anche il sospetto che possa dipendere da qualche libreria che i browser installati con binari precompilati potrebbero aspettarsi di trovare e invece ne trovano un'altra versione o qualcosa del genere.
Però ad esempio Brave l'avevo preso da qui:
http://www.lazytux.it/release/slackware ... wser_vari/

Non l'ho compilato sul mio sistema... Certo che è fatto per slackware-14.2, ma anche seamonkey e invece quello non funge.

Insomma ci sto capendo sempre meno...
Potrei fare una prova però tanto per togliermi il dubbio, compilando sul sistema firefox. Mi servirebbe però uno slackbuild funzionante per la versione attuale...
Se ne trovano?
Cosa ne dite? Può essere un'idea o non servirà a nulla?

EDIT:
Ferma tutto, ho detto una sciocchezza, anche chromium non l'ho compilato sul sistema, l'ho preso da AlienBob precompilato.



PS.
Sì ho provato ma non vedo altre info utili, gli unici mesaggi appaiono solo quando chiudo la finestra del browser, dopo che è apparsa la barra gialla in alto, come spiegato prima:

Codice: Seleziona tutto

firefox --safe-mode 'https://static3.mediasetplay.mediaset.it/player/index.html?appKey=5ad3966b1de1c4000d5cec48&programGuid=F309002901004901&id=850100&guid=F309002901004901&autoplay=true'

###!!! [Parent][MessageChannel] Error: (msgtype=0x15007F,name=PBrowser::Msg_Destroy) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x540026,name=PNecko::Msg_RequestContextAfterDOMContentLoaded) Channel closing: too late to send/recv, messages will be lost


###!!! [Child][MessageChannel] Error: (msgtype=0x2C00AF,name=PContent::Msg_ScriptError) Channel closing: too late to send/recv, messages will be lost


###!!! [Child][MessageChannel] Error: (msgtype=0x2E0003,name=PCookieService::Msg_SetCookieString) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x2E0003,name=PCookieService::Msg_SetCookieString) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x2E0003,name=PCookieService::Msg_SetCookieString) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x2E0003,name=PCookieService::Msg_SetCookieString) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x2E0003,name=PCookieService::Msg_SetCookieString) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x2E0003,name=PCookieService::Msg_SetCookieString) Closed channel: cannot send/recv


###!!! [Child][MessageChannel] Error: (msgtype=0x150001,name=PBrowser::Msg_AsyncMessage) Closed channel: cannot send/recv

Avatar utente
conraid
Staff
Staff
Messaggi: 13090
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda conraid » ven giu 08, 2018 0:41

Io avevo un problema simile. Video che si vedevano solo con chromium, ho dovuto ricompilarmi da solo ffmpeg. Prova quello di alien nel repo restricted.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2900
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » ven giu 08, 2018 12:14

FFMpeg, l'avevo ricompilato a mano, prendendo proprio lo slackbuild e il resto del materiale da AlienBob.
Inoltre avevo anche applicato una patch relativa al demux o qualcosa del genere. Spetta che metto il link alla discussione.. ovviamente avevo rotto le scatole anche qui:
viewtopic.php?f=2&t=40634&p=352115#p352108

Il fatto è che diversi browser presentano il problema, mentre altri, ne ho riportato almeno tre (chromium, brave, qupzilla) riproducono il video senza problemi.
E ffmpeg è sempre la stessa.

Avatar utente
conraid
Staff
Staff
Messaggi: 13090
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda conraid » sab giu 09, 2018 9:58

joe ha scritto:FFMpeg, l'avevo ricompilato a mano, prendendo proprio lo slackbuild e il resto del materiale da AlienBob.
Inoltre avevo anche applicato una patch relativa al demux o qualcosa del genere. Spetta che metto il link alla discussione.. ovviamente avevo rotto le scatole anche qui:
http://slacky.eu/forum/viewtopic.php?f= ... 15#p352108

Il fatto è che diversi browser presentano il problema, mentre altri, ne ho riportato almeno tre (chromium, brave, qupzilla) riproducono il video senza problemi.
E ffmpeg è sempre la stessa.


Anche a me chromium andava e firefox no.
viewtopic.php?f=51&t=39320

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2900
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » lun giu 11, 2018 12:37

Ciao, ho fatto una prova e mi pare che ci sia qualcosa che non torna.

Allora ho ricompilato FFMpeg, l'operazione non serviva immagino, in quanto lo avevo già ricompilato poco tempo fa e penso di non aver aggiornato pacchetti che servono ffmpeg come dipendenza. Tra l'altro mi pare che alien faccia un pacchetto statico di ffmpeg per cui anche se aggiorno una libreria di sistema ffmpeg se non sbaglio usa la sua linkata staticamente. Siccome però di questo non sono sicurissimissimo, ho ricompilato rimosso e reinstallato il nuovo pacchetto.
Purtroppo nessun miglioramento.

Ho poi provato sta cosa:
- rimozione ffmpeg
- rimozione sia di flashplayer plugin che di chromium-pepperflash-plugin

Quindi sono senza plugin flash e senza FFMpeg.

Mi collego alla pagina del video e
- in chromium
- in Qupzilla

Il video viene riprodotto senza problemi.
Direi e correggete se sbaglio che la corretta riproduzione del video a questo punto non dipenda ne da ffmpeg ne da flashplayer (quest'ultimo l'avevate già evidenziato voi).

Con firefox non viene riprodotto e la situazione è la stessa di prima...

Cosa ne pensate?

Avatar utente
conraid
Staff
Staff
Messaggi: 13090
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda conraid » lun giu 11, 2018 12:43

chromium di Alien è statico, quello di SBo mi sembra usi ffmpeg come libreria interna.

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1068
Iscritto il: gio nov 27, 2008 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Firefox 61.0beta parliamone

Messaggioda lablinux » lun giu 11, 2018 12:53

joe ha scritto:Cosa ne pensate?

Che stai perdendo troppo tempo per guardare canale 5 :D :D :D

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2394
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.17.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda ponce » lun giu 11, 2018 12:56

lablinux ha scritto:
joe ha scritto:Cosa ne pensate?

Che stai perdendo troppo tempo per guardare canale 5 :D :D :D

mi sembra che tu abbia colto il nocciolo della questione: praticamente mi hai levato le parole di bocca! ;)

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2900
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Firefox 61.0beta parliamone

Messaggioda joe » lun giu 11, 2018 13:42

:D :D
Ma non era su rete4 quel video? 8)
Poco cambia eh... ;)

Tornando a ffmpeg, sì io ho chromium preso da Alien che appunto come dicevate usa il suo ffmpeg statico.
Questo spiegherebbe, in parte come mai chromium funziona.

Però resta l'interrogativo riguardante Qupzilla, dallo slackbuild di SBo vedo che il pacchetto è creato compilando con qmake e direi proprio che usi librerie che trova sul sistema.
Nonostante questo, al momento riesce a far girare il video senza problemi.
E ripeto non ho ffmpeg installato al momento...

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2394
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.17.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Firefox 61.0beta parliamone

Messaggioda ponce » lun giu 11, 2018 15:27

qt5 (la cui webengine -un chromium embedded- e' usata da qupzilla), se configurato abilitando l'opzione "-proprietary-codecs", compila una sua versione di ffmpeg interna.

https://doc-snapshots.qt.io/qt5-5.9/qtw ... deo-codecs