Pagina 57 di 57

Re: Firefox 61.0beta parliamone

Inviato: mar giu 12, 2018 11:27
da joe
Ok, se ti capiterà l'occasione è una prova molto molto rapida... fai conto che io ho provato con almeno 6 o 7 beta diverse, tutte pacchettizzate con quello script: sempre se si ha una connessione ad internet abbastanza veloce.

Nel frattempo, vista anche la tua conferma, provo a compilare firefox di Pat.
Sul mio PC potrebbe essere un'operazione troppo dispendiosa...

Agli altri chiederei lo stesso test:
- installare temporaneamente firefox attraverso lo script di ruario linkato sopra
- verificare se il video funziona
- disinstallare ffmpeg e ri-verificare provando anche altri video (tipo la7, youtube ecc)

Re: Firefox 61.0beta parliamone

Inviato: mar giu 12, 2018 17:21
da joe
Ho provato ma dice:

Codice: Seleziona tutto

0:09.28 checking for llvm-config... /usr/bin/llvm-config
0:09.39 ERROR: llvm installation 3.8.0 is incompatible with Stylo bindgen.
0:09.39
0:09.39 To compile Stylo, please install version 3.9.0 or greater of
0:09.39 Clang + LLVM and ensure that the 'llvm-config' from that
0:09.39 installation is first on your path.
0:09.39
0:09.39 You can verify this by typing 'llvm-config --version'.
0:09.39
0:09.46 *** Fix above errors and then restart with\
0:09.46                "/usr/bin/gmake -f client.mk build"
0:09.46 client.mk:145: recipe for target 'configure' failed
0:09.47 gmake: *** [configure] Error 1

Pare che serva llvm >= 3.9.0

Ma non vorrei che aggiornando quello, poi debba ricompilare mezzo sistema... Visto che sono sulla 14.2.
Vedo che c'è anche una discussione su LQ in merito alla compilazione di firefox recenti su slackware stabile 14.2 .
https://www.linuxquestions.org/question ... 175615536/

Ma non l'ho ancora letto

Re: Firefox 61.0beta parliamone

Inviato: mar giu 12, 2018 18:23
da ponce
come hai intuito non vale la pena di provare a compilare i nuovi firefox sulla 14.2 (infatti Pat rimane alla precedente ESR per questo motivo), ma se proprio ti vuoi imbarcare in un'impresa del genere (che, ci tengo a sottolinearlo, invalida la garanzia ;) ) puoi provare a installare, come spiegato in quel topic (non e' detto che funzioni, eh, io qui non ho testato!), libedit, llvm (aggiornato) e rust prima di provare con firefox: al momento dovrebbero andare bene gli SlackBuild della current cosi' come sono per i software citati.

Re: Firefox 61.0beta parliamone

Inviato: mar giu 12, 2018 18:41
da joe
Prima di tentare ho provato ad installare firefox nella versione originale precompilata, parliamo della versione 45.2.0.

Anche così non si riesce a cavare un ragno dal buco: il video non parte e salta fuori invece della barra gialla a discesa, un pop up che informa che uno script sta rallentando il browser e richiede di stopparlo oppura aspettare...
Insomma niente di nuovo.

Invece di sconvolgere il sistema mettendo pacchetti "esotici", potrei anche provare a compilare firefox vecchio il 45.2 per capirci, l'operazione dovrebbe essere meno problematica sulla stabile.
Se la cosa risolve, poi magari proverò a compilare anche firefox attuale.
Già compilare rust e cargo è stato un parto, figuriamoci quanto impiegherà firefox.

Di llvm, sul mio sitema ne ho una versione liscia e una compat32 forse deriva dalle multilib di alien ma non sono sicuro.
Entrambe sono 3.8.0 però e quindi troppo vecchie.


Per chi volesse riportare il test, mettete qualche info sul vostro sistema:
- versione slackware
- versione firefox
- compilato oppure installato via binari, o via pacchetto precompilato o come...

Grazie ancora! ;)

Re: Firefox 61.0beta parliamone

Inviato: gio giu 14, 2018 22:26
da leocata
Scusate... ma perchè compilarlo se il binario è disponibile? Ho aggiornato adesso ed è semplicissimo, da root:
1- scarichi firefox
2- tar -xf firefox
3-cancelli i due file /usr/lib64/firefox (sia il link che la directory)
4- copi la directory decompressa in /usr/lib64/
5- fai il link simbolico... vado a mente ln -s /usr/lib64/firefox-60.2/firefox /usr/lib64/firefox
6 fai il link simbolico anche su /usr/bin
e va che è una vera meraviglia :)

Re: Firefox 61.0beta parliamone

Inviato: gio giu 14, 2018 22:38
da Trotto@81
Esiste uno script che lo fa in automatico nel caso non lo si voglia compilare.

Re: Firefox 61.0beta parliamone

Inviato: ven giu 15, 2018 0:30
da joe
Lo script era qua:
https://gist.github.com/ruario/9672798

E leo, hai mica provato anche se ti visualizza il video?
http://www.video.mediaset.it/video/stas ... 50100.html
oppure link diretto:
https://static3.mediasetplay.mediaset.i ... oplay=true

Se ti va di fare la prova...
Aggiungi anche:
- versione slackware in uso
- versione firefox / installato in che modo (se come descritto sopra, oppure magari avrai provato lo script di ruario che crea il pacchetto slackware da dar in parto a installpkg)

Ciao! :)

Re: Firefox 61.0beta parliamone

Inviato: ven giu 15, 2018 9:07
da Trotto@81
Ho aggiornato su un PC a current con l'ultima versione di Firefox stabile ed il video non lo riproduco.

Re: Firefox 61.0beta parliamone

Inviato: ven giu 15, 2018 10:44
da joe
Firefox sempre installato via ruario ?

EDIT
Ah però vedo che su current c'è la versione 60.0.2 che è la stabile di firefox...
Quindi probabilmente intendi quella.

Re: Firefox 61.0beta parliamone

Inviato: ven giu 15, 2018 11:07
da Trotto@81
Sì, sempre lo script di ruario.

Re: Firefox 61.0beta parliamone

Inviato: ven giu 15, 2018 11:21
da joe
E invece se provi con firefox di serie della current?
La versione dovrebbe essere la stessa.
Però non si sa mai, magari nel pacchetto di pat cambia qualcosa.. Alla fine è una prova rapida...

Re: Firefox 61.0beta parliamone

Inviato: sab giu 16, 2018 13:25
da Trotto@81
Su Windows nessun problema con Firefox. Sarà sicuramente una questione di licenze relative al codec usato da Mediaset.

Re: Firefox 61.0beta parliamone

Inviato: mer giu 20, 2018 14:06
da joe
Mah, non so se può c'entrare qualcosa, però anni fà dopo l'installazione della 14.2, per i driver proprietari della mia stampante brother (che sono rilasciati esclusivamente a 32 bit) avevo sostituito alcuni pacchetti tra cui anche "glibc-solibs" con i corrispettivi "multilib" mantenuti da AlienBob.

L'altro giorno avevo lanciato un bel:

Codice: Seleziona tutto

slackpkg upgrade-all


E tra gli aggiornamenti c'era parecchia roba tra cui anche glibc-solibs.
Uso "slackpkg+" che consente di pescare anche da repo non ufficiali...
Inavvertitamente però il pacchetto in questione veniva prioritariamente preso dal repo slackware64 ufficiale.
Così ho finito per sostituire la versione a 64 bit invece che quella multilib.

Per caso mi sono accorto che la stampante no funzionava.
E sempre per caso anche il video mediaset in questione, anche con chromium non funzionava più.
Funzionava esclusivamente con qupzilla.
Adesso ho sostituito glibc del repo uffciciale con la versione multilib e la stampante funziona. Anche il video con chromium si vede di nuovo.
Evidentemente sul mio sistema c'è qualche software necessario anche alla riproduzione di quel video, che si appoggia su glibc-solibs versione multilib. Sarà qualcosa di ricompilato contro quella versione di glibc immagino.