Repository 32bit  Forum
Repository 64bit  Wiki

avidemux 2.5.4 errore di segmentazione [RISOLTO]

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

avidemux 2.5.4 errore di segmentazione [RISOLTO]

Messaggioda red » sab giu 25, 2011 11:43

Ciao a tutti,
su una Slackware64 13.37 mi sono installato il pacchetto dal repository di avidemux e relative dipendenze.
Quando però avvio il programma (sia gtk, sia qt4, sia cli) ottengo:
Codice: Seleziona tutto
bash-4.1$ avidemux2_gtk
*************************
  Avidemux v2.5.4
*************************
 http://www.avidemux.org
 Code      : Mean, JSC, Grant Pedersen
 GFX       : Nestor Di, nestordi@augcyl.org
 Design    : Jakub Misak
 FreeBSD   : Anish Mistry, amistry@am-productions.biz
 Audio     : Mihail Zenkov
 Mac OS X  : Kuisathaverat, Harry van der Wolf
 Win32     : Grant Pedersen

Compiler: GCC 4.5.2
Build Target: Linux (x86-64)
User Interface: GTK+ (2.24.4)

Large file available: 1 offset

Initialising prefs
Directory /home/red/.avidemux exists.Good.
Using /home/red/.avidemux as base directory for prefs/jobs/...
[cpuCaps]Checking CPU capabilities
                MMX detected
                MMXEXT detected
                SSE detected
                SSE2 detected
                SSE3 detected
                SSSE3 detected
[cpuCaps]End of CPU capabilities check (cpuMask :ffffffff)

[SDL] Version: 1.2.14
[SDL] Initialisation succeeded
[SDL] Video Driver: x11


[Locale] setlocale LC_CTYPE=it_IT@euro;LC_NUMERIC=it_IT@euro;LC_TIME=it_IT@euro;LC_COLLATE=C;LC_MONETARY=it_IT@euro;LC_MESSAGES=it_IT@euro;LC_PAPER=it_IT@euro;LC_NAME=it_IT@euro;LC_ADDRESS=it_IT@euro;LC_TELEPHONE=it_IT@euro;LC_MEASUREMENT=it_IT@euro;LC_IDENTIFICATION=it_IT@euro
[Locale] Textdomain was messages
[Locale] Textdomain is now avidemux
[Locale] Files for avidemux appear to be in /usr/share/locale
[Locale] Test: _File

Initializing Dithering tables
[COREUI] Compiled with 01.00.01
[COREUI] Linked with   01.00.01
[CoreUI] Compiled with patch version 1, using 1
Initializing postproc
Deleting post proc
updating post proc
Enabled type:3 strength:3

 Registering Internal Filters
******************************

[ADM_ad_plugin] Scanning directory /usr/lib64/ADM_plugins/audioDecoder/
[ADM_ad_plugin] Plugin loaded version 0.0.1, name libADM_ad_vorbis.so, desc: libVorbis decoder plugin for avidemux (c) Mean

[ADM_ad_plugin] Plugin loaded version 1.0.0, name libADM_ad_opencore_amrwb.so, desc: opencore-amrwb decoder plugin for Avidemux (c) Mean/Gruntster

[ADM_ad_plugin] Plugin loaded version 0.0.1, name libADM_ad_faad.so, desc: Faad2 decoder plugin for avidemux (c) Mean

[ADM_ad_plugin] Plugin loaded version 0.0.1, name libADM_ad_a52.so, desc: LibAC3 decoder plugin for avidemux (c) Mean

[ADM_ad_plugin] Plugin loaded version 1.0.0, name libADM_ad_opencore_amrnb.so, desc: opencore-amrnb decoder plugin for Avidemux (c) Mean/Gruntster

[ADM_ad_plugin] Plugin loaded version 0.0.1, name libADM_ad_Mad.so, desc: LibMad decoder plugin for avidemux (c) Mean

[ADM_ad_plugin] Scanning done, found 6 codec
[ADM_vf_plugin] Scanning directory /usr/lib64/ADM_plugins/videoFilter/
[Filters] Registered filter /usr/lib64/ADM_plugins/videoFilter//libADM_vf_denoise3d.so as MPlayer denoise3d
[Filters] Registered filter /usr/lib64/ADM_plugins/videoFilter//libADM_vf_denoise3dhq.so as MPlayer hqdn3d
/usr/lib64/ADM_plugins/videoFilter//libADM_vf_asharp_qt4.so:WrongUI
[Filters] Registered filter /usr/lib64/ADM_plugins/videoFilter//libADM_vf_decimate.so as Decimazione Decomb
[Filters] Registered filter /usr/lib64/ADM_plugins/videoFilter//libADM_vf_unstackField.so as Disimpilamento semiquadri
[Filters] Registered filter /usr/lib64/ADM_plugins/videoFilter//libADM_vf_addborders.so as Aggiunta bordi neri

*********** BACKTRACK **************
/usr/lib64/libADM_core.so(ADM_backTrack+0x59) [0x7f186db18af9]:0:<ADM_backTrack>:-2
/lib64/libc.so.6(+0x340b0) [0x7f1868a700b0]:1:<>:-2
/lib64/libc.so.6(cfree+0x1d) [0x7f1868ab8d3d]:2:<cfree>:-2
/lib64/libdl.so.2(+0x1535) [0x7f18692fc535]:3:<>:-2
/lib64/libdl.so.2(dlopen+0x31) [0x7f18692fbf91]:4:<dlopen>:-2
/usr/lib64/libGL.so.1(+0x986dd) [0x7f186116c6dd]:5:<>:-2
*********** BACKTRACK **************
Cleaning up
Deleting post proc
Waiting for Spidermonkey to finish...
Cleaning up Spidermonkey.
Errore di segmentazione

Ho provato a fare qualche ricerca in merito, ma non ne ho cavato un ragno dal buco.

Idee in merito?

Grazie!
Ultima modifica di red il ven ott 14, 2011 19:24, modificato 1 volta in totale.
Avatar utente
red
Linux 2.6
Linux 2.6
 
Messaggi: 783
Iscritto il: gio gen 20, 2005 0:00
Località: Verona
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox

Re: avidemux 2.5.4 errore di segmentazione

Messaggioda red » gio ott 13, 2011 19:01

Vorrei riportare a galla questo mio vecchio post.
Non ero più riuscito a risolvere la cosa... nessuno si è scontrato con questo problema o ha idea del perché ci sia l'errore di segmentazione?

Grazie mille!
Avatar utente
red
Linux 2.6
Linux 2.6
 
Messaggi: 783
Iscritto il: gio gen 20, 2005 0:00
Località: Verona
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox

Re: avidemux 2.5.4 errore di segmentazione

Messaggioda miklos » gio ott 13, 2011 19:45

assicurati che le dipendenze siano tutte correttamente installate.
controlla che la libreria indicata nell'ultima riga abbia tutto cio' che le serve per funzionare
Codice: Seleziona tutto
ldd /usr/lib64/ADM_plugins/videoFilter/{filtro_che_non_funziona}


per sicurezza ho testato il pacchetto(con slapt-get) e non mi da questo problema.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1276
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: avidemux 2.5.4 errore di segmentazione

Messaggioda red » gio ott 13, 2011 23:38

Mi sembra che le dipendenze ci siano tutte.
Il problema è secondo me questa cavolo di libADM... solo non trovo a che pacchetto appartiene per provare a disinstallarla e/o aggiornarla e/o ricompilarla.

Anche provando con i pacchetti di slackbuilds.org a compilare ottengo errore:
Codice: Seleziona tutto
[omissis]
Scanning dependencies of target ADM_av_alsa
[  6%] Building CXX object ADM_audioDevices/Alsa/CMakeFiles/ADM_av_alsa.dir/ADM_                                                       deviceALSA.cpp.o
Linking CXX shared library libADM_av_alsa.so
[  6%] Built target ADM_av_alsa
Scanning dependencies of target ADM_av_esd
[  6%] Building CXX object ADM_audioDevices/Esd/CMakeFiles/ADM_av_esd.dir/ADM_de                                                       viceEsd.cpp.o
Linking CXX shared library libADM_av_esd.so
[  6%] Built target ADM_av_esd
Scanning dependencies of target ADM_av_sdl
[  6%] Building CXX object ADM_audioDevices/Sdl/CMakeFiles/ADM_av_sdl.dir/ADM_de                                                       viceSDL.cpp.o
In file included from /usr/include/SDL/SDL_stdinc.h:30:0,
                 from /usr/include/SDL/SDL_main.h:26,
                 from /usr/include/SDL/SDL.h:30,
                 from /tmp/SBo/avidemux-2.5.2/plugins/ADM_audioDevices/Sdl/ADM_d                                                       eviceSDL.cpp:15:
/usr/include/SDL/SDL_config.h:64:0: warning: "HAVE_SYS_TYPES_H" redefined
/tmp/SBo/avidemux-2.5.2/build/config/ADM_coreConfig.h:29:0: note: this is the lo                                                       cation of the previous definition
/usr/include/SDL/SDL_config.h:69:0: warning: "HAVE_MALLOC_H" redefined
/tmp/SBo/avidemux-2.5.2/build/config/ADM_coreConfig.h:27:0: note: this is the lo                                                       cation of the previous definition
/usr/include/SDL/SDL_config.h:73:0: warning: "HAVE_INTTYPES_H" redefined
/tmp/SBo/avidemux-2.5.2/build/config/ADM_coreConfig.h:26:0: note: this is the lo                                                       cation of the previous definition
/usr/include/SDL/SDL_config.h:74:0: warning: "HAVE_STDINT_H" redefined
/tmp/SBo/avidemux-2.5.2/build/config/ADM_coreConfig.h:28:0: note: this is the lo                                                       cation of the previous definition
Linking CXX shared library libADM_av_sdl.so
[  6%] Built target ADM_av_sdl
Scanning dependencies of target ADM_av_oss
[  7%] Building CXX object ADM_audioDevices/Oss/CMakeFiles/ADM_av_oss.dir/ADM_de                                                       viceoss.cpp.o
Linking CXX shared library libADM_av_oss.so
[  7%] Built target ADM_av_oss
Scanning dependencies of target ADM_av_jack
[  7%] Building CXX object ADM_audioDevices/Jack/CMakeFiles/ADM_av_jack.dir/ADM_                                                       deviceJack.cpp.o
Linking CXX shared library libADM_av_jack.so
[  7%] Built target ADM_av_jack
Scanning dependencies of target ADM_vidEnc_avcodec
[  7%] Building C object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vidE                                                       nc_avcodec.dir/interface.c.o
[  7%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/encoder.cpp.o
[  7%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/huffyuvEncoder.cpp.o
[  8%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/ffvhuffEncoder.cpp.o
[  8%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/ffv1Encoder.cpp.o
[  8%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/dvEncoder.cpp.o
[  9%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/mpeg1Encoder.cpp.o
[  9%] Building CXX object ADM_videoEncoder/ADM_vidEnc_avcodec/CMakeFiles/ADM_vi                                                       dEnc_avcodec.dir/mpeg1EncoderOptions.cpp.o
Linking CXX shared library libADM_vidEnc_avcodec.so
[  9%] Built target ADM_vidEnc_avcodec
Scanning dependencies of target ADM_vidEnc_x264
[  9%] Building C object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_                                                       x264.dir/interface.c.o
[ 10%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEn                                                       c_x264.dir/configGuiLoader.cpp.o
[ 10%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEn                                                       c_x264.dir/encoder.cpp.o
[ 10%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEn                                                       c_x264.dir/guiHelper.cpp.o
[ 10%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEn                                                       c_x264.dir/zoneOptions.cpp.o
[ 11%] Building CXX object ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEn                                                       c_x264.dir/x264Options.cpp.o
/tmp/SBo/avidemux-2.5.2/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp                                                       : In member function 'virtual void x264Options::addOptionsToXml(xmlNode*)':
/tmp/SBo/avidemux-2.5.2/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp                                                       :1267:8: error: 'X264_WEIGHTP_BLIND' was not declared in this scope
/tmp/SBo/avidemux-2.5.2/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp                                                       : In member function 'void x264Options::parseAnalyseOptions(xmlNode*)':
/tmp/SBo/avidemux-2.5.2/plugins/ADM_videoEncoder/ADM_vidEnc_x264/x264Options.cpp                                                       :1732:28: error: 'X264_WEIGHTP_BLIND' was not declared in this scope
make[2]: *** [ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/x2                                                       64Options.cpp.o] Error 1
make[1]: *** [ADM_videoEncoder/ADM_vidEnc_x264/CMakeFiles/ADM_vidEnc_x264.dir/al                                                       l] Error 2
make: *** [all] Error 2

Non ho proprio idea di dove sbattere la testa e quel poco che Google ha suggerito (almeno a me) è che forse dipende da Avidemux.
Ma se così fosse, perché ad altri come a te va?
Avatar utente
red
Linux 2.6
Linux 2.6
 
Messaggi: 783
Iscritto il: gio gen 20, 2005 0:00
Località: Verona
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox

Re: avidemux 2.5.4 errore di segmentazione

Messaggioda miklos » ven ott 14, 2011 0:46

il fatto che le dipendenze ci siano tutte, purtroppo non vuol dire essere esenti da incompatibilità.
per esempio, l'errore che ricevi tu in fase di compilazione sembra proprio dovuto ad una versione, probabilmente troppo recente, del codec video x264.
infatti se vedi qui'
http://avidemux.sourceforge.net/news.html#2011-06-04
nel changelog dell'ultima versione ci stanno aggiustamenti ad una versione x264 piu' nuova.

red ha scritto:Il problema è secondo me questa cavolo di libADM... solo non trovo a che pacchetto appartiene per provare a disinstallarla e/o aggiornarla e/o ricompilarla.

fa parte di avidemux, sono una serie di plugin che vengono compilati e che si legano alle dipendenze.

il consiglio che ti do' io è provare a compilare la nuova (mantenendo le stesse dipendenze) e vedere come va.
se risolvi e il pacchetto originale l'hai preso da qui.. segnalalo sul pkgreports a 64bit.. io ultimamente sto dando una mano a tenere quel repository aggiornato e le segnalazioni sono molto utili per porre rimedio a questo tipo di situazioni :D

ciauu

p.s: quando usi gli script di slackbuilds.org devi tenere presente che sono garantiti se compili esclusivamente le versioni che trovi in quel repository. nel caso di slacky meglio usare gli slackbuild che trovi in allegato al pacchetto :D
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1276
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: avidemux 2.5.4 errore di segmentazione

Messaggioda red » ven ott 14, 2011 18:42

miklos ha scritto:il fatto che le dipendenze ci siano tutte, purtroppo non vuol dire essere esenti da incompatibilità.
per esempio, l'errore che ricevi tu in fase di compilazione sembra proprio dovuto ad una versione, probabilmente troppo recente, del codec video x264.
infatti se vedi qui'
http://avidemux.sourceforge.net/news.html#2011-06-04
nel changelog dell'ultima versione ci stanno aggiustamenti ad una versione x264 piu' nuova.

A dirti la verità ne avevo avuto il sospetto. Così ho provato qualche versione più vecchia del codec in questione, ma i miei tentativi comunque non avevano risolto il problema.

miklos ha scritto:
red ha scritto:Il problema è secondo me questa cavolo di libADM... solo non trovo a che pacchetto appartiene per provare a disinstallarla e/o aggiornarla e/o ricompilarla.

fa parte di avidemux, sono una serie di plugin che vengono compilati e che si legano alle dipendenze.

Dopo qualche smanettamento me n'ero convinto ed ora ho anche da te la conferma che le libADM sono di Avidemux... anche per questo ho successivamente provato sia un'altra versione, sia quella di slackbuilds.org, anche qui senza risultati.

miklos ha scritto:il consiglio che ti do' io è provare a compilare la nuova (mantenendo le stesse dipendenze) e vedere come va.
se risolvi e il pacchetto originale l'hai preso da qui.. segnalalo sul pkgreports a 64bit.. io ultimamente sto dando una mano a tenere quel repository aggiornato e le segnalazioni sono molto utili per porre rimedio a questo tipo di situazioni :D

Mi manca la prova di usare lo slackbuild di Slacky con altre versioni di Avidemux... in questi giorni provo e vediamo.
Per il resto tutti i pacchetti, da Avidemux alle sue dipendenze, li ho tutti scaricati dal repository a 64 bit della 13.37 qui sul Slacky. Però vedendo che sul forum non ci sono altri post come il mio e nessuno lamenta il problema (sembra sia il solo), tra gli utilizzatori di Avidemux, o gli altri hanno altre versioni si Slackware (tipo current o precedenti) o il problema è solo mio e quindi ancora più misterioso.

miklos ha scritto:p.s: quando usi gli script di slackbuilds.org devi tenere presente che sono garantiti se compili esclusivamente le versioni che trovi in quel repository. nel caso di slacky meglio usare gli slackbuild che trovi in allegato al pacchetto :D

Sì sì... infatti ho fatto così. Questo getta ancora più sospetti sul codec x264.

Beh, intanto grazie.
Ti aggiorno su eventuali sviluppi! :)
Avatar utente
red
Linux 2.6
Linux 2.6
 
Messaggi: 783
Iscritto il: gio gen 20, 2005 0:00
Località: Verona
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox

Re: avidemux 2.5.4 errore di segmentazione

Messaggioda red » ven ott 14, 2011 19:23

AGGIORNAMENTO:
non so cosa sia successo, tuttavia tanto per provare ho disinstallato il codec x264 e avidemux e poi li ho reinstallati, sempre con i pacchetti di Slacky e ora tutto, magicamente, funziona.

Questa antica e arcana pratica winzozziana, questa volta, ha dato i suoi frutti anche sul pinguino :D.

Chiudo qui e grazie ancora!
Avatar utente
red
Linux 2.6
Linux 2.6
 
Messaggi: 783
Iscritto il: gio gen 20, 2005 0:00
Località: Verona
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: boh e 2 ospiti