Pagina 1 di 1

Man page in UTF8 e man

Inviato: lun ago 15, 2011 18:31
da targzeta
Salve a tutti. Non avendo ancora fatto il passaggio a UTF8 (ammetto di avere un po' di timore) ho un fastidioso problema con le pagine man codificate in UTF8. Una per tutte è la pagina italiana di mplayer, quando la visualizzo mi vengono fuori dei caratteri errati, ad esempio:

Codice: Seleziona tutto

mplayer Ú un visualizzatore
Il mio locale è impostato come it_IT@euro.

Su internet ho trovato questo link dove spiega che bisognerebbe modificare il file man.conf (che nella Slackware è sotto /usr/lib e non sotto /etc) inserendo al posto della riga:

Codice: Seleziona tutto

NROFF      /usr/bin/nroff -c --legacy NROFF_OLD_CHARSET -mandoc 2>/dev/null
la riga:

Codice: Seleziona tutto

NROFF      /usr/bin/groff -Tascii -mandoc
peccato però che la riga in questione del file, sotto Slackware sembra sia stata già settata più o meno opportunamente:

Codice: Seleziona tutto

NROFF           /usr/bin/nroff -mandoc
proprio come indicato nello stesso file...anche se lasciando qualche dubbio:

Codice: Seleziona tutto

# For use with utf-8, NROFF should be "nroff -mandoc" without -T option.
# (Maybe - but today I need -Tlatin1 to prevent double conversion to utf8.)

Emanuele

P.S. Se volete possiamo anche discutere su come passare a UTF8 e se ci sono problemi.

Re: Man page in UTF8 e man

Inviato: dom set 23, 2012 22:52
da targzeta
Aggiorno il thread perché ora succede qualcosa di strano. Se lancio:

Codice: Seleziona tutto

man mplayer
noto che alcune lettere sono corrette, tipo la 'è', la 'ù' e la 'ò', mentre altre no, come la 'à'. Io ci capisco veramente poco. Il manuale è in utf8...boh.

Qualsiasi consiglio è ben accetto.
Emanuele