Problema refresh grafico Wine

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
rik70
Master
Master
Messaggi: 1701
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: Problema refresh grafico Wine

Messaggioda rik70 » lun ott 17, 2011 11:59

NightWolf ha scritto:lo imposto da lilo.conf


Ok, sicuro di averlo messo nel "posto giusto"? Provalo anche dal prompt di lilo al boot., e incolla qui quel cat | grep che ti ho detto, altrimenti non capiamo.

P.s.
Può darsi che il KMS non c'entri nulla e sia un problema delle mesa o di altro, ma da quello che hai incollato prima si evince che il KMS non è disattivato.

Avatar utente
NightWolf
Linux 1.0
Linux 1.0
Messaggi: 9
Iscritto il: lun set 26, 2011 11:58
Slackware: 13.37
Kernel: 3.5.3-smp
Desktop: KDE 4.8.5

Re: Problema refresh grafico Wine

Messaggioda NightWolf » lun ott 17, 2011 15:34

Ho provato il backing store ma senza successo, ho gli stessi problemi.

Per quanto riguarda la disabilitazione del KMS, su lilo.conf ho aggiunto all'append nomodeset, ho dato il comando lilo -v (nessun errore) e fatto il reboot.

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2893
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Problema refresh grafico Wine

Messaggioda 414N » lun ott 17, 2011 17:36

Crea un file /etc/modprobe.d/kms.conf ed inseriscici

Codice: Seleziona tutto

options radeon modeset=0

Dopodiché puoi togliere l'altra opzione da lilo.
Se hai il modulo radeon builtin nel kernel, invece, aggiungi l'opzione

Codice: Seleziona tutto

radeon.modeset=0

all'append del kernel in lilo.conf.

rik70
Master
Master
Messaggi: 1701
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: 4.0.x-smp
Desktop: Xfce 4.12

Re: Problema refresh grafico Wine

Messaggioda rik70 » mar ott 18, 2011 11:37

p.s.

Hai detto che su Knoppix 6.4.* la grafica funziona perfettamente?

Prova a dare su Knoppix

Codice: Seleziona tutto

glxinfo | grep render
glxinfo | grep version
e confrontalo con quanto restituito su Slackware.

Avatar utente
NightWolf
Linux 1.0
Linux 1.0
Messaggi: 9
Iscritto il: lun set 26, 2011 11:58
Slackware: 13.37
Kernel: 3.5.3-smp
Desktop: KDE 4.8.5

Re: Problema refresh grafico Wine

Messaggioda NightWolf » sab nov 05, 2011 19:48

Chiedo scusa se non mi sono più fatto sentire però gli impegni lavorativi mi hanno tenuto un po' distante dal mio fisso

Allora ho provato ad aggiungere la stringa radeon.modeset=0 all'append di lilo.conf ed in effetti questa volta l'output dei comandi glxinfo | grep render e glxinfo | grep version sono diversi rispetto all'altra volta:

glxinfo | grep render

Codice: Seleziona tutto

direct rendering: Yes
OpenGL renderer string: Mesa DRI R200 (RV250 4966) 20090101 AGP 4x x86/MMX/SSE2 TCL


glxinfo | grep version:

Codice: Seleziona tutto

server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 1.3 Mesa 7.9.2


Però il problema di refresh si ripresenta lo stesso...

Inoltre come suggerito ho provato a dare gli stessi comandi sulla Knoppix 6.4.* ottenendo:

glxinfo | grep render:

Codice: Seleziona tutto

direct rendering: Yes
OpenGL renderer string: Mesa DRI R200 (RV250 4966) 20090101 x86/MMX/SSE2 TCL DRI2


glxinfo | grep version:

Codice: Seleziona tutto

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version String 1.3 Mesa 7.9


Confrontando i due output (quello di knoppix ed quello di Slackware con KMS abilitato) l'unica differenza che ho trovato è la versione di Mesa che su slackware è più recente (7.9 Knoppix 7.9.2 Slackware)


Torna a “Gnu/Linux in genere”

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti