Repository 32bit  Forum
Repository 64bit  Wiki

crash visitando ebay

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

crash visitando ebay

Messaggioda matzu » mar nov 01, 2011 11:19

Ciao, uso un link alla pagina di ebay classico ( http://www.ebay.it/classico ). In più d'una occasione, recentemente, ho avuto dei crash di firefox, che si ripetono poi cada volta che lo riavvio, almeno finché non riavvio proprio il computer. In altri casi dei freeze del sistema grafico (funziona solo la console con CTL-ALT-Fx), necessitando ovviamente il suo riavvio. E in altri casi degli artefatti sulla barra di kde, che possono comparire mentre navigo (non ho fatto attenzione a quali portali), ma anche qui sicuramente con ebay; tant'è che a volte è bastato chiudere il tab relativo perché gli artefatti sparissero. Il freeze del sistema l'ho avuto anche con fluxbox, benché usando alcune applicazioni kde. Ho disabilitato temporaneamente il fiashplayer di adobe, ma non cambia (le animazioni su ebay non ne risentono). Ho anche fatto caso a che se vado a cliccare su "accedi" prima che abbia finito di caricare le animazioni e le abbia avviate, il rischio di crash è maggiore. Con Seamonkey e Konqueror nessun problema, ma ho provato troppo poche volte per dire che siano fail-proof.

Qualcuno ha avuto problemi analoghi, o ha idea di cosa si possa fare per evitarli?
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: crash visitando ebay

Messaggioda slux » mar nov 01, 2011 12:00

Se usi una versione di firefox recente(6 o 7),prova a disabilitare l'accelerazione hardware da preferenze-avanzate-generale.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: crash visitando ebay

Messaggioda matzu » mar nov 01, 2011 14:40

Grazie, dev'essere proprio quello.
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: crash visitando ebay

Messaggioda matzu » sab nov 05, 2011 10:14

Dopo qualche giorno senza quasi alcuna stranezza, oggi apro un tab su uno dei siti ebay e mi si annerisce lo schermo. Solo il puntatore dà segni di vita sotto forma di un rettangolino bianco che segue i movimenti del mouse. Avevo una sessione aperta da root in tty1, per cui vi accedo. Lancio un 'ps -ef' e invece di eseguirlo, mi "sputa" fuori come avessi dato 'exit' o equivalente. Ho riavviato con CTL-ALT-DEL.

Nota1: mi connetto a internet con chiavetta usb e sim 3, usando kppp.
Nota2: dico senza quasi alcuna stranezza perché questo fenomeno di annerimento dello schermo già si è verificato almeno una volta, dopo aver disabilitato l'accelerazione di firefox, ma era durato un attimo e poi tutto era rientrato nei ranghi.
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: crash visitando ebay

Messaggioda slux » sab nov 05, 2011 14:05

ci puoi dire che scheda grafica e quali driver usi?
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: crash visitando ebay

Messaggioda matzu » sab nov 05, 2011 15:25

Codice: Seleziona tutto
lspci -s 01:00.0 -v
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01) (prog-if 00 [VGA controller])
        Subsystem: PC Partner Limited Device 7c13
        Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 16
        Memory at c0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at c800 [size=256]
        Memory at cfef0000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at cfec0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 3.0
        Capabilities: [50] Power Management version 2
        Kernel driver in use: radeon
        Kernel modules: radeon, radeonfb

Se ricordo giusto, non ho mai avuto di questi problemi con Slackware 13.1

Avevo anche creato /etc/X11/xorg.conf.d/disable-composite.conf con questo contenuto:
Codice: Seleziona tutto
Section "Extensions"
Option "Composite" "Disable"
EndSection

prima ancora di disabilitare l'accelerazione di firefox, perché kde aveva un comportamento anomalo.
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: crash visitando ebay

Messaggioda slux » sab nov 05, 2011 17:18

Un chiarimento,hai attivo anche il driver radeonfb insieme al driver radeon?
Prova a metterlo in blacklist ed ad utilizzare il driver vesa standard per la console ,o meglio ancora la modalità testo pura.
I driver nvidia,per esempio,non vanno d'accordo con il driver framebuffer nvidiafb e credo che valga anche per i driver radeon,ma non ne sono sicuro.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: crash visitando ebay

Messaggioda matzu » sab nov 05, 2011 18:07

Non ho messo "vga=" nel menu.lst di grub, perché non confligga con KMS. Peraltro lsmod non mi dà radeonfb in alcuna riga.

Edit
Al terzo crash odierno, un messaggio dal monitor: fuori frequenza V:30Hz O:24.9kHz
Dunque ho creato anche /etc/X11/xorg.conf.d/A0-monitor.conf:
Codice: Seleziona tutto
Section "Monitor"
Identifier "m0"
DisplaySize 304.1 228.1
HorizSync   48.4 , 56.5 , 60.0
VertRefresh 60.0 , 70.0 , 75.0
Option      "DPMS"
EndSection
Ovviamente le frequenze le ho prese dal manuale del monitor. Spero sia la volta buona.

Edit ulteriore
Successo di nuovo. Stavolta dopo un attimo di annerimento, il monitor mi mostra un tty (forse 1), bloccato anche quello. Ho disabilitato KMS con nomodesetting, e impostato il framebuffer all'avvio (con vga=normal la console è "inutilizzabile").
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Trotto@81 e 2 ospiti