Repository 32bit  Forum
Repository 64bit  Wiki

Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3520

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3520

Messaggioda giberg » mer nov 09, 2011 17:51

Ciao
cercando di far funzionare la regolazione della luminosità
del mio portatile Samsung RV520 ho visto che dal kernel 2.6.39
c'è un modulo dal nome samsung-laptop.
Ho compilato il 3.0.8 e ho visto che il modulo non veniva
caricato perché mi diceva che non c'era un device di quel tipo
ovvero il mio portatile non era incluso nel driver.

Ho provato quindi ad osservare il sorgente
linux-3.0.8/drivers/platform/x86/samsung-laptop.c
e ho visto come erano indicati i modelli dei vari samsung.
Mancando il mio ho provato ad aggiungere delle righe identiche alle altre
con la stringa con cui viene identificato il modello, ricavandola
da questo comando:
Codice: Seleziona tutto
dmidecode -s system-product-name

risultando
RV420/RV520/RV720/E3530/S3530/E3420/E3520

Ho compilato il modulo modificato (ho preso il makefile
presente nella directory commentando le righe degli altri moduli)
e ho sostituito il file samsung-laptop.ko in
/lib/modules/3.0.8/kernel/drivers/platform/x86/

dopo aver dato
Codice: Seleziona tutto
# depmod -a
# modprobe samsung-laptop


il modulo è stato caricato correttamente.

Seguendo varie guide in rete avevo già in precedenza
tentato di far funzionare la regolazione della luminosità
e quindi le modifiche che avevo già fatto sono:
- l'aggiunta dell'opzione acpi_backlight=vendor in lilo.conf da passare
al kernel
- usando il driver proprietario nvidia (nouveau non mi supportava la
GeForce GT520M), l'aggiunta di
Option "RegistryDwords" "EnableBrightnessControl=1"
in xorg.conf nelle righe di configurazione della scheda.
Non ho ancora controllato se queste modifiche sono ancora necessarie
ma credo di sì.
Ora sicuramente posso regolare da tastiera la luminosità.

La patch da provare è la seguente:

Codice: Seleziona tutto
--- linux-3.0.8/drivers/platform/x86/samsung-laptop.c.orig   2011-11-08 14:42:27.569274081 +0100
+++ linux-3.0.8/drivers/platform/x86/samsung-laptop.c   2011-11-08 20:28:46.283532854 +0100
@@ -676,6 +676,15 @@ static struct dmi_system_id __initdata s
       },
       .callback = dmi_check_cb,
    },
+   {
+                .ident = "RV420/RV520/RV720/E3530/S3530/E3420/E3520",
+                .matches = {
+                         DMI_MATCH(DMI_SYS_VENDOR, "SAMSUNG ELECTRONICS CO., LTD."),
+                         DMI_MATCH(DMI_PRODUCT_NAME, "RV420/RV520/RV720/E3530/S3530/E3420/E3520"),
+                         DMI_MATCH(DMI_BOARD_NAME, "RV420/RV520/RV720/E3530/S3530/E3420/E3520"),
+                },
+                .callback = dmi_check_cb,
+        },
    { },
 };
 MODULE_DEVICE_TABLE(dmi, samsung_dmi_table);


Ho già inviato la patch al disponibilissimo Greg Kroah-Hartman perché possa essere inserita nel kernel.
Quindi se volete fare la modifica da voi
(che è una stupidaggine perché ci sono riuscito io
che non sono esperto) inserite le righe qui sopra
al file samsung-laptop.c e compilatelo,
altrimenti prossimamente potrebbe essere aggiunta
la modifica ufficilamente.
Dovrebbe funzionare anche con le versioni successive
al 3.0.8 (e credo anche con il 2.6.39).

Se avete modelli di samsung non presenti nel file
samsung-laptop.c
provate a verificare come viene riconosciuto il vostro
portatile, modificate il sorgente, compilatelo e se funziona
potete inviare la patch (seguendo alcune regole).

Sono contento ora di aver speso 449 euro per il portatile in offerta :D
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda brainvision » mer nov 09, 2011 20:53

ciao!!

allora abbiamo lo stesso portatile!!! :D :D :D :D :D

grazie della dritta, seguirò subito il tuo esempio! ;)
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda targzeta » mer nov 09, 2011 21:02

Sono contento che funzioni, però è meglio se sentite gli sviluppatori del modulo prima, non si sa mai che faccia del danno. Tanto dovrebbero risponderti relativamente presto.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » mer nov 09, 2011 22:14

Ho già inviato la patch Greg K-H che è lo sviluppatore
e ce l'ha in lista. Non mi ha detto niente di particolare,
ha ringraziato spiegandomi il formato in cui dovevo mandarla.

Quello che ho ottenuto è che il driver per i laptop samsung
riconoscesse il modello. Quel driver è per tutti i samsung,
non ne vedo altri in quella directory.
Quello che fa è permettere l'uso dei vari tasti Fn quali
accensione-spegnimento wireless, luminosità. In genere funzionano
allo stesso modo (si spera) per lo stesso produttore, si tratta
di far riconoscere il proprio portatile al driver in modo da poterlo
caricare.

Le righe sono le stesse presenti nel driver, le ho solamente copiate e inserito la stringa
che identifica il mio portatile, non ancora presente perché
ovviamente deve esserci qualcuno che deve avere uno di quei modelli
e segnalarli.

Mi è andata bene, funziona, quindi non direi che possano
esserci danni. Tutti gli altri compresi nella stringa sono modelli
diversi ma che rientrano nella stessa famiglia per il produttore e
infatti il comando che ho dato mi ha resituito proprio tutta quella lista.

Edit: NON EFFETTUARE LA SEGUENTE MODIFICA, chiedo scusa per l'errore./Edit


NO Dimenticavo una cosa: applicando la patch la luminosità
funziona, però per far riconoscere altri tasti (quale quello per il wireless)
bisogna modificare il file

NO /lib/udev/rules.d/95-keyboard-force-release.rules

NO meglio però copiandolo in /etc/udev/rules.d/ (come consigliato nel file changes_and_hints di Slackware)

NO La riga da modificare è quella relativa a "samsung-others"
e deve essere più o meno così (io ho aggiunto solo la stringa
del mio modello. In rete ho visto delle versioni più complete, può
essere che dipenda dalla versione di udev):
Codice: Seleziona tutto
ENV{DMI_VENDOR}=="[sS][aA][mM][sS][uU][nN][gG]*", ATTR{[dmi/id]product_name}=="*RV420/RV520/RV720/E3530/S3530/E3420/E3520*", RUN+="keyboard-force-release.sh $devpath samsung-other"


NO Se riesco a capire dove andare a beccare
il sito con il codice di udev (non c'è più sotto a kernel.org) controllo se
hanno modificato qualcosa ed eventualmente faccio aggiungere.
Ultima modifica di giberg il ven nov 11, 2011 13:59, modificato 5 volte in totale.
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » mer nov 09, 2011 22:36

giberg ha scritto:Se riesco a capire dove andare a beccare
il sito con il codice di udev (non c'è più sotto a kernel.org) controllo se
hanno modificato qualcosa ed eventualmente faccio aggiungere.

Uhm... In realtà da come la riga è stata scritta nelle ultime versioni
(già presente in udev-165 di slackware) dovrebbe riconoscere
qualsiasi samsung, senza dover indicare il tipo.
Eppure a me funziona solo se modifico la riga. :-k
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda brainvision » gio nov 10, 2011 22:00

ciao giberg..

come ho detto, anche io ho comprato un Samsung RV520 a metà settembre e volevo dunque seguire le tue istruzioni per usare anche io i tasti FN.. ho scaricato il kernel 3.0.8 e ricompilato con il config del kernel huge-smp default di Slackware, perché non ho ancora tempo per mettermi a fare una conf veramente su misura del portatile e dell'hardware che uso.. Prima di compilare ho modificato il file samsung-laptop.c aggiungendo questa parte:
Codice: Seleziona tutto
   {
                .ident = "RV420/RV520/RV720/E3530/S3530/E3420/E3520",
                .matches = {
                         DMI_MATCH(DMI_SYS_VENDOR, "SAMSUNG ELECTRONICS CO., LTD."),
                         DMI_MATCH(DMI_PRODUCT_NAME, "RV420/RV520/RV720/E3530/S3530/E3420/E3520"),
                         DMI_MATCH(DMI_BOARD_NAME, "RV420/RV520/RV720/E3530/S3530/E3420/E3520"),
                },
                .callback = dmi_check_cb,
        },

prima delle ultime 2 parentesi graffe.. Ho fatto così perché comunque dovevo compilare il kernel visto che usavo quello di default di Slackware che ancora non ha il driver per il samsung e poi perché non si capisce bene il procedimento che hai seguito tu.. o meglio non ho capito io, perché per te che lo hai fatto sarà sicuramente chiarissimo.. :)
Dunque ho compilato il kernel, installato i moduli.. ho modificato lilo in questo modo:
Codice: Seleziona tutto
append="acpi_backlight=samsung vt.default_utf8=0"

e fatto poi le altre modiche che dicevi..

Ho riavviato.. ma niente, non funzionava la regolazione della luminosità.. Inoltre non mi caricava il driver ath9k per il wireless, ma anche caricandolo a mano non vedeva wlan0 e quindi non potevo usare la wireless. Il led però era acceso ed ho anche provato a ricaricare il modulo e tirar su wlan0' dopo aver pigiato fn + F9, ma niente di niente..

Non sono sicuro che sia quella la riga da aggiungere a lilo e che vada lì, anche.. ma avevo provato con vendor al posto di samsung e mi dava errore..

Cosa ho sbagliato?? Cosa mi manca??
Grazie mille!!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » gio nov 10, 2011 23:18

Eccomi. Sicuramente non sono stato chiaro io.

Io sono partito dal config del kernel huge.s della current,
kernel 2.6.38.7 (vedo che non c'è più huge.smp.).
Per quanto riguarda ath9k non ho fatto nulla,
già funzionava prima. Ricordo solo che mi chiedeva
durante la configurazione se compilare un altro modulo
della serie ath9k e nell'incertezza l'ho fatto ma funzionava
anche prima. Mi pare fosse ath9k_hw ma non sono sicuro.
Quelli che ho io sono:
Codice: Seleziona tutto
gianni@darkstar:~/Downloads$ lsmod |grep ath9k                                                                                                                         
ath9k                  85025  0                                                                                                                                         
mac80211              216771  1 ath9k                                                                                                                                   
ath9k_common            1762  1 ath9k
ath9k_hw              282564  2 ath9k,ath9k_common
ath                    14597  2 ath9k,ath9k_hw
cfg80211              158959  3 ath9k,mac80211,ath


Il modulo l'hai compilato semplicemente con make e il makefile presente
nella directory /usr/src/linux-3.0.8/drivers/platform/x86 e quindi va bene,
giusto?
Quindi:
make samsung-laptop.c

Hai copiato il file samsung-laptop.ko nella directory
/lib/modules/3.0.8/kernel/drivers/platform/x86/
giusto?

Al riavvio risulta caricato il modulo?
Se non lo trovi caricato, ho dato per scontato
l'inserimento della riga
Codice: Seleziona tutto
modprobe samsung-laptop

in /etc/rc.d/rc.local

Veniamo a Lilo.
L'opzione è esattamente
Codice: Seleziona tutto
acpi_backlight=vendor

non devi scrivere samsung.

Quale driver usi per la scheda video?
Se nvidia proprietario aggiungi a xorg.conf
creato dall'installer l'opzione
Option "RegistryDwords" "EnableBrightnessControl=1"

Dovrebbe risultare una cosa così:
Codice: Seleziona tutto
Section "Device"
    Identifier     "Device0"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection


Io poi non ho tenuto xorg.conf nel modo classico. L'ho spostato in
/etc/X11/xorg.conf.d/
e rinominato come
20-nvidia.conf
Questo però non dovrebbe essere necessario per il corretto funzionamento.
Era una delle tante prove fatte seguendo suggerimenti
presi dalla rete.


Edit: NON EFFETTUARE LA SEGUENTE MODIFICA, chiedo scusa per l'errore./Edit

NO Udev
La modifica al file 95-keyboard-force-release.rules
l'ho scritta sopra.
In teoria non è necessario per l'illuminazione ma
solo con quella modifica funziona il tasto di accensione
e spegnimento della scheda wifi.
Ancora in teoria, non dovrebbe nemmeno essere necessario
indicare quella stringa perché ho letto nel git di udev
che quella riga è stata aggiunta in modo che supporti qualsiasi
samsung. Però io ho provato e devo per forza farlo.
Questa modifica l'avevo fatta prima del provare a compilare
il modulo. Avevo notato che con un vecchio modulo (samsung-backlight),
permetteva il riconoscimento dei tasti, vedevo sul display comparire
la barra di aumento/diminuzione della luminosità ma non funzionava.
Ecco perché poi ho tentato con il nuovo samsung-laptop degli ultimi kernel.
Ultima modifica di giberg il ven nov 11, 2011 13:56, modificato 2 volte in totale.
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » gio nov 10, 2011 23:27

giberg ha scritto:Il modulo l'hai compilato semplicemente con make e il makefile presente
nella directory /usr/src/linux-3.0.8/drivers/platform/x86 e quindi va bene,
giusto?
Quindi:
make samsung-laptop.c

Ah no, pardon #-o
Hai detto che l'hai compilato direttamente con il kernel.
L'hai incluso quando hai fatto il make menuconfig?

Per il resto invece non ho fatto modifiche rispetto
al vecchio config, tranne per quell'incertezza su
ath9k, tanto non cambiava aggiungere qualcosa.
Non sono esperto in compilazione di kernel, se mi chiedeva
cosa fare con i nuovi moduli rispetto alla vecchia versione
ho sempre dato invio lasciando l'opzione di default. In pratica
era sempre NO.
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda brainvision » ven nov 11, 2011 8:40

allora.. tu non hai il kernel huge-smp perché usi una 64bit, immagino.. o perché non hai installato i pacchetti relativi, ma come kernel esiste ancora, lo uso io di default..
detto ciò.. ho cambiato la riga dell'acpi in lilo.conf ed ora funziona la gestione della luminosità con il plugin di xfce ma non con i tasti FN.. e la wireless continua a non andare.. ho controllato ed i driver ci sono.. non vengono tirati su ma la scheda viene riconosciuta.. quando poi tiro su i moduli e provo a dare
Codice: Seleziona tutto
ifconfig wlan0 up

mi dioce che wlan0 non esiste.. ma che diavolo?? Ho controllato e quando carico il modulo ath9k si porta dietro sia common che ath, quindi i driver ci sono tutti..

ma a te funzionano anche i tasti Fn con F9? ed il led della wireless si spegne?
che kernel usi?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » ven nov 11, 2011 10:08

Ti allego il mio config (ovviamente da modificare se vuoi aggiungere
cose nuove dell'ultimo kernel, io non so cosa ci fosse di nuovo)
così puoi controllare le differenze. Ho usato il 3.0.8.

La combinazione Fn+F9 mi funziona solo dopo il reboot.
Che sia qualcosa riguardante il bios?
Me ne sono accorto dopo che mi hai fatto notare che a te
non funziona. Ho inviato questa osservazione.

Hai provato a vedere se ti funziona il tasto di sospensione?
Fn+Esc. A me sì.
Allegati
giberg-config.txt
(113.5 KiB) Scaricato 63 volte
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » ven nov 11, 2011 10:18

Fn+F9 ora non mi funziona manco al reboot.
Sembra che funzioni quando gli pare.
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda brainvision » ven nov 11, 2011 11:23

scusa ma tu intendi.. o meglio intendevi: avvi il notebook, FN+F9 non va.. fai un reboot e dopo funziona.. questo intendevi prima di dirmi che non andava più nenache al reboot?

altra domanda: non funziona i tasti per la wireless, ma la wireless ti funziona? a me la spia è accesa ma niente e niente e niente.. e prima, quando funzionava, la spia ti si spegneva, giusto?

P.S.: visto che sto usando 2 kernel per fare prove e nello stesso tempo poter accedere ad internet, mi spieghi come fare ad usare i driver nVidia per ogni kernel? io quando lo installo e poi avvio l'altro kernel mi da problemi e devo disinstallare ed installare nuovamente (disinstallo solo perché sono maniaco, altrimenti potrei direttamente fare una nuova installazione e sovrascrivere la vecchia). Sai come fare?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » ven nov 11, 2011 11:36

brainvision ha scritto:scusa ma tu intendi.. o meglio intendevi: avvi il notebook, FN+F9 non va.. fai un reboot e dopo funziona.. questo intendevi prima di dirmi che non andava più nenache al reboot?


Sì, al primo avvio non va. Al riavvio andava. Ora non va più.
Boh. È successo tutto stamattina.

brainvision ha scritto:altra domanda: non funziona i tasti per la wireless, ma la wireless ti funziona? a me la spia è accesa ma niente e niente e niente.. e prima, quando funzionava, la spia ti si spegneva, giusto?

Non ho fatto caso alla spia. Mi pare si spegnesse ma
vado a memoria. Sicuramente vedevo il wireless disattivato
dall'icona di networkmanager.

brainvision ha scritto:P.S.: visto che sto usando 2 kernel per fare prove e nello stesso tempo poter accedere ad internet, mi spieghi come fare ad usare i driver nVidia per ogni kernel? io quando lo installo e poi avvio l'altro kernel mi da problemi e devo disinstallare ed installare nuovamente (disinstallo solo perché sono maniaco, altrimenti potrei direttamente fare una nuova installazione e sovrascrivere la vecchia). Sai come fare?

Purtroppo non so aiutarti, non ho approfondito l'argomento.
Per farla breve reinstallavo il driver al volo durante le prove.

Hai provato a vedere la differenza del tuo config con il mio
se manca qualcosa?

Se può servirti ecco anche il mio lsmod:
Codice: Seleziona tutto
gianni@darkstar:~$ lsmod
Module                  Size  Used by
ipv6                  279679  24
snd_seq_dummy           1455  0
snd_seq_oss            29188  0
snd_seq_midi_event      5588  1 snd_seq_oss
snd_seq                51494  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          5257  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            38937  0
snd_mixer_oss          15177  1 snd_pcm_oss
usb_storage            44044  0
lp                      9653  0
ppdev                   5933  0
parport_pc             20926  0
parport                28911  3 lp,ppdev,parport_pc
pcspkr                  1811  0
fuse                   66863  5
snd_hda_codec_hdmi     22335  1
nvidia              11691472  43
snd_hda_codec_realtek   289881  1
snd_hda_intel          21915  6
snd_hda_codec          72721  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
uvcvideo               63612  0
videodev               73088  1 uvcvideo
v4l2_compat_ioctl32     8608  1 videodev
snd_hwdep               6134  1 snd_hda_codec
snd_pcm                73009  5 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
sg                     25631  0
intel_agp              10896  0
intel_gtt              14697  1 intel_agp
fan                     2450  0
snd_timer              18969  3 snd_seq,snd_pcm
snd                    56998  22 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
ath9k                  85025  0
mac80211              216771  1 ath9k
thermal                 7994  0
video                  11379  0
processor              24322  0
agpgart                27280  3 nvidia,intel_agp,intel_gtt
ath9k_common            1762  1 ath9k                                                                                                                                   
psmouse                56258  0                                                                                                                                         
r8169                  42911  0                                                                                                                                         
thermal_sys            14205  4 fan,thermal,video,processor                                                                                                             
mii                     3923  1 r8169
ehci_hcd               39400  0
soundcore               5553  1 snd
snd_page_alloc          7081  2 snd_hda_intel,snd_pcm
battery                11003  0
i2c_i801                8238  0
button                  4490  0
i2c_core               19874  3 nvidia,videodev,i2c_i801
hwmon                   1441  1 thermal_sys
ath9k_hw              282564  2 ath9k,ath9k_common
ath                    14597  2 ath9k,ath9k_hw
ac                      3257  0
samsung_laptop          4572  0
cfg80211              158959  3 ath9k,mac80211,ath
rfkill                 15570  3 samsung_laptop,cfg80211
evdev                   9950  16
serio_raw               4286  0
loop                   16489  0
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda giberg » ven nov 11, 2011 13:42

Chiedo scusa, è stato un mio errore. :oops:
La regola di udev funzionante è quella originale già presente in Slackware.
Non va modificata.

Ora lo segnalo sopra.

Fn+F9 senza quella modifica funziona perfettamente.
Avatar utente
giberg
Linux 3.x
Linux 3.x
 
Messaggi: 1282
Iscritto il: mer set 21, 2005 16:28
Località: S. Biagio di Callalta (TV)
Nome Cognome: Gianni
Slackware: current64
Kernel: 3.7.1
Desktop: 4.8.5

Re: Patch per Samsung RV420/RV520/RV720/E3530/S3530/E3420/E3

Messaggioda brainvision » ven nov 11, 2011 14:08

com'era la parte originale? ho fatto l'errore di sostituire quella stringa invece di commentare ed aggiungere la tua modifica.. mi riporti la riga giusta per favore?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Prossimo

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite