Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Problema con conky e xfce4.8

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Problema con conky e xfce4.8

Messaggioda Eberoth » ven dic 09, 2011 19:38

Ieri ho installato i pacchetti di rworkman, aggiornando il mio xfce4.6 alla versione 4.8.
Funziona tutto benissimo tranne un piccolo problema con conky. All'inizio ho dovuto aggiungere delle opzioni al mio .conkyrc per far sparire il rettangolo nero che era comparso al posto della trasparenza. Purtroppo ora mi ritrovo con un conky trasparente ma che sembra non riesca ad aggiornare bene le varie scritte.
Faccio un esempio per spiegarmi, quando ad esempio aggiorna i secondi dell'orologio, per un attimo la cifra precedente si sovrappone alla nuova, e così per tutto il resto dell'output.
Il problema si risolve se imposto "own_window_type" su override (come era prima dell'aggiornamento di xfce) ma a quel punto riappare il rettangolone nero.
Qualche idea?

Ecco il mio conkyrc
Codice: Seleziona tutto
#conkyrc

alignment top_right
background no
border_width 0
cpu_avg_samples 2
default_color white
default_outline_color white
default_shade_color lightgrey
color0 yellow                   #colore nomi
draw_borders no
draw_graph_borders no
draw_outline no
draw_shades no
use_xft yes
xftfont Droid Sans Mono Bold:size=8
minimum_size 1 1
maximum_width 130
net_avg_samples 2
no_buffers no
out_to_console no
out_to_stderr no
extra_newline no
own_window yes
own_window_transparent yes
own_window_argb_visual yes
own_window_type normal
own_window_class conky-semi
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
stippled_borders 0
update_interval 1.0
uppercase no
use_spacer none
show_graph_scale no
show_graph_range no
double_buffer yes
gap_x 5
gap_y 26

TEXT
${execpi 900 DJS=`date +%_d`; cal -m | sed s/"\(^\|[^0-9]\)$DJS"'\b'/'\1${color0}'"$DJS"'$color'/}
$color $alignc ${time  %H.%M.%S}
$hr
${color0}Mailbox:
${color} ${execi 60 python /home/wiseman/.scripts/gmail.py} New Messages
$hr
${color0}Kernel: $color $kernel
#${color0}Time: $color ${time %H.%M.%S}
${color0}Uptime:$color $uptime
${color0}Load: $color $loadavg
${color0}Processes: $color $processes
${color0}Running:   $color $running_processes
$hr
${color0}Networking:
${color0}ESSID:$color ${wireless_essid wlan0}
${color0}IP:$color ${addr wlan0}
${color0}Quality:$color ${wireless_link_qual_perc wlan0}%
${color0}Up:$color ${upspeed wlan0}
${color0}Down:$color ${downspeed wlan0}
$hr
${color0}File systems:
/ $color${fs_free /}/${fs_size /}
${color0}/home $color${fs_free /home}/${fs_size /home}
$hr
${color0}System load:
${color0}RAM Usage:$color $memperc%
${color0}Swap Usage:$color $swapperc%
${color0}CPU0 Usage:$color ${cpu cpu1}%
${color0}CPU1 Usage:$color ${cpu cpu2}%
${color0}Frequency0:$color ${freq_g 1}GHz
${color0}Frequency1:$color ${freq_g 2}GHz
$hr
${color0}Temperatures:
${color0}HDD Sensor:$color ${exec sudo /usr/sbin/hddtemp /dev/sda | cut -c6-8,40,55-59}
${color0}MB Sensor:$color ${exec sensors | grep "temp1" | cut -c15-21}
${color0}Core0:$color ${exec sensors | grep "Core 0" | cut -c15-21}
${color0}Core1:$color ${exec sensors | grep "Core 1" | cut -c15-21}
$hr
${color0}Power:
${color0}AC adapter:$color $acpiacadapter
${color0}Battery:
${color0}Status:$color $battery
${color0}Charge:$color $battery_percent%
#${color0}Time:$color ${battery_time 0}
$hr
${color0}Highest CPU:
$color ${top name 1}
$color ${top name 2}
$color ${top name 3}
#$color ${top name 4}
#$color ${top name 5}
$hr
${color0}Highest MEM:
${color} ${top_mem name 1}
${color} ${top_mem name 2}
${color} ${top_mem name 3}
#${color} ${top_mem name 4}
#${color} ${top_mem name 5}


Chiedo scusa se non è proprio un capolavoro di chiarezza, ma l'ho buttao giù di fretta e, fino ad oggi, non avevo mai avuto motivo di rimetterci mano.
Ultima modifica di Eberoth il sab dic 10, 2011 16:49, modificato 1 volta in totale.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Problema con conky e xfce4.8

Messaggioda miklos » sab dic 10, 2011 7:40

pezzo preso dalla documentazione di conky
Codice: Seleziona tutto
own_window_argb_visual    Boolean, use ARGB visual? ARGB can be used for real transparency, note that a composite manager is required for real transparency. This option will not work as desired (in most cases) in conjunction with 'own_window_type override'.

quindi forse hai qualche problema con questa opzione che hai attivato.
inoltre io nel mio .conkyrc ho questa configurazione
Codice: Seleziona tutto
own_window no

e ottengo una sessione conky che sembra parte integrante del desktop. il resto è piu' o meno uguale al tuo

spero di essere stato utile :D
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Problema con conky e xfce4.8

Messaggioda Eberoth » sab dic 10, 2011 16:49

Ok, ho risolto mettendo uno "sleep 20 &&" all'inizio del comando nel mio ~/.config/autostart/conky.conf..
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron