Repository 32bit  Forum
Repository 64bit  Wiki

Webcam e schermo nero

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Webcam e schermo nero

Messaggioda relay » mar giu 05, 2012 23:27

Utilizzo un Ubuntu 10.04.4 32 bit Lucid Lynx Logitech Quickcam E35000 .Il problema si verifica nella visualizzazione video della webcam con skype.
Con lsusb e lsmod | grep videodev vedo che la webcam è riconosciuta e i driver uvcvideo sono installati.
Quando però vado nelle impostazioni skype e provo la webcam, i paramtri uvc camera con il relativo id son giusti, la webcam si accende ma lo schermo è nero.
Incollo un po di output per darvi un idea:
lsusb:
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 03f0:002a Hewlett-Packard
Bus 002 Device 002: ID 046d:09a4 Logitech, Inc. QuickCam E 3500
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
mario@mario-desktop:~$ lsmod | grep videodev
videodev 34457 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
Cercando ho trovato questa soluzione (e sembra anche l'unicaper skype):
precaricare questa libreria con LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype da terminale.Purtroppo nel caso mio non funziona.
La libreria è presente come si puo notare:
locate v4l1compat.so:
/usr/lib/libv4l/v4l1compat.so
Ottenendo schermo nero in tutte le applicazione credo che sia un problema di driver.
Suggerimenti?
Ultima modifica di relay il mer giu 06, 2012 22:12, modificato 2 volte in totale.
relay
Linux 2.4
Linux 2.4
 
Messaggi: 291
Iscritto il: mar ago 28, 2007 15:36

Re: Webcam e schermo nero con Skype

Messaggioda joseph » mar giu 05, 2012 23:32

Prova in questo modo e vedi se si vede
Codice: Seleziona tutto
mplayer tv:// -tv  driver=v4l2:device=video0

Ovviamente al posto di "video0" metti il device della tua webcam
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: Webcam e schermo nero con Skype

Messaggioda conraid » mer giu 06, 2012 8:08

Codice: Seleziona tutto
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Webcam e schermo nero con Skype

Messaggioda sixjan » mer giu 06, 2012 11:21

Ciao. Domanda super stupida: con le altre applicazioni funziona correttamente? Per esempio, wxcam, cheese etc etc.

Saluti
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 409
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: Webcam e schermo nero con Skype

Messaggioda relay » mer giu 06, 2012 20:27

@joseph: con il comando mplayer che mi hai consigliato mi da schermo nero,sembra quindi che nonostante i diver uvc ci siano non engono utilizzati.
@conraid:Mi sembra che non hai letto tutto il post,il problema non e solo con skype.
@sixjan:no con cheese stesso risultato schermo nero incollo l'output:
Codice: Seleziona tutto
 mplayer tv:// -tv  driver=v4l2:device=/dev/video0
MPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
TV file format detected.
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
v4l2: your device driver does not support VIDIOC_G_STD ioctl, VIDIOC_G_PARM was used instead.
Selected device: UVC Camera (046d:09a4)
 Capabilites:  video capture  streaming
 supported norms:
 inputs: 0 = Camera 1;
 Current input: 0
 Current format: MJPEG
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
v4l2: ioctl set format failed: Invalid argument
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Invalid argument
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
v4l2: ioctl query control failed: Invalid argument
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: Permission denied.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [raw] RAW Uncompressed Video
VDec: vo config request - 640 x 480 (preferred colorspace: Packed YUY2)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using Packed YUY2 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler: reducing / aligning filtersize 1 -> 4
    Last message repeated 1 times
SwScaler: reducing / aligning filtersize 1 -> 1
SwScaler: reducing / aligning filtersize 9 -> 8
[swscaler @ 0x8abfdc0]BICUBIC scaler, from yuyv422 to yuv420p using MMX2
[swscaler @ 0x8abfdc0]using 4-tap MMX scaler for horizontal luminance scaling
[swscaler @ 0x8abfdc0]using 4-tap MMX scaler for horizontal chrominance scaling
[swscaler @ 0x8abfdc0]using 1-tap MMX "scaler" for vertical scaling (YV12 like)
[swscaler @ 0x8abfdc0]640x480 -> 640x480
VO: [xv] 640x480 => 640x480 Planar YV12
Selected video codec: [rawyuy2] vfm: raw (RAW YUY2)
==========================================================================
Audio: no sound
Starting playback...
v4l2: ioctl set mute failed: Invalid argument
v4l2: 2112 frames successfully processed, 2109 frames dropped.

Exiting... (Quit)

Ho provato a installarare Camorama, ma quando lo loncio mi da questo errore:
Could not connect with video device /dev/video0
please check connection
Il device video è giusto:
ls /dev/video*
/dev/video0
Consigli?
relay
Linux 2.4
Linux 2.4
 
Messaggi: 291
Iscritto il: mar ago 28, 2007 15:36

Re: Webcam e schermo nero con Skype

Messaggioda sixjan » mer giu 06, 2012 22:07

Ciao. Un'altra banalità: sei sicuro che la webcam non sia rotta? L'hai testata, sigh, su qualche sistema Windows? Ti dico questa cosa perché recentemente avevo acquistato una webcam data per funzionante sotto gnu/linux con UVC e dopo giorni di sbattimento mi sono arreso e l'ho testata dalla sorella ancora utente Microsoft. Non andava manco lì. Riportata al venditore e rimborsato. La tua webcam usa il driver uvc. Questo driver in passato ha avuto problemi e regressioni tra un rilascio e l'altro. Quindi, ti consiglierei di provare con una distribuzione live di gnu/linux per vedere se con un driver più recente funziona e di assicurarti con qualche macchina windows che la webcam sia 'sana'.

P.S. per provarle tutte: prova il comando mplayer preceduto da sudo così verifichiamo che
non sia un problema di permessi.
sixjan
Linux 2.4
Linux 2.4
 
Messaggi: 409
Iscritto il: dom gen 06, 2008 11:46
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: Xfce 4.10

Re: Webcam e schermo nero

Messaggioda relay » mer giu 06, 2012 23:01

Prima sullo stesso pc avevo installato slackware e tutto funzionava, da quando ho installato ubuntu ho questi problemi.Lo proverò in altri pc con windows, ma sembra una strana coincidenza.
relay
Linux 2.4
Linux 2.4
 
Messaggi: 291
Iscritto il: mar ago 28, 2007 15:36


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti