Repository 32bit  Forum
Repository 64bit  Wiki

Dual boot Windows/Linux

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Dual boot Windows/Linux

Messaggioda DarkNeo » dom lug 22, 2012 22:24

Ciao a tutti questo è l'output del mio cfdisk:
cfdisk (util-linux 2.19)

Disk Drive: /dev/sda
Size: 500107862016 bytes, 500.1 GB
Heads: cfdisk (util-linux 2.19)

Disk Drive: /dev/sda
Size: 500107862016 bytes, 500.1 GB
Heads: 255 Sectors per Track: 63 Cylinders: 60801

Name Flags Part Type FS Type [Label] Size (MB)
------------------------------------------------------------------------------
Unusable 1.05*
sda1 Primary ntfs [PQSERVICE] 12582.92*
sda2 Primary ntfs [SYSTEM RESERVED] 104.86*
sda3 Boot Primary ntfs [ACER] 434989.20*
sda4 Primary ext4 52429.85*
255 Sectors per Track: 63 Cylinders: 60801

Name Flags Part Type FS Type [Label] Size (MB)
------------------------------------------------------------------------------
Unusable 1.05*
sda1 Primary ntfs [PQSERVICE] 12582.92*
sda2 Primary ntfs [SYSTEM RESERVED] 104.86*
sda3 Boot Primary ntfs [ACER] 434989.20*
sda4 Primary ext4 52429.85*

sda1 non so cosa sia
sda2 è la partizione di recovery di windows
sda3 è la partizione di windows
sda4 è la partizione slackware
questo invece è il mio lilo.conf relativa al boot
other = /dev/sda
label = Windows
table = /dev/sda3
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda4
label = Linux
read-only

Perchè se all'avvio del pc scelgo di partire con windows mi fa partire la partizione di recovery? e una volta riavviato e ripartito con linux il boot si sposta su sda2?
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Dual boot Windows/Linux

Messaggioda darkstaring » mar lug 24, 2012 10:48

Hai risolto??
Sda1 dovrebbe essere la partizione che ti fà avviare windows che sta su sda3..
windows :doubt:

Prova a modificare così
Codice: Seleziona tutto
#windows
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends

e poi lancia lilo
darkstaring
Linux 2.4
Linux 2.4
 
Messaggi: 364
Iscritto il: mer ott 13, 2010 12:55
Slackware: Current
Desktop: xfce

Re: Dual boot Windows/Linux

Messaggioda DarkNeo » mar lug 24, 2012 12:08

si alla fine ho risolto formattando windows, ho provato tutti i tipi di combinazioni ma partiva sempre l'acer recovery inspiegabilmente.
grazie!
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Dual boot Windows/Linux

Messaggioda aschenaz » sab ott 06, 2012 13:46

È successa la stessa cosa a me. Ho dovuto, ahimè, installare w7 sul notebook di mia figlia (sì è iscritta a Grafica all'Accademia delle Belle Arti e sicuramente avrà bisogno anche di Photoshop & co.). Poi ho installato Slackware64 14 di sana pianta (prima c'era la 13.37 a 32bit), configurando lilo in automatico. Windz non partiva, per la semplice ragione che il boot-loader andava a pescarlo su sda1, mentre su sda1 c'è la partizione di ripristino. Corretto lilo.conf a sda2 ed è ok... :)

Magari può servire...
pensieriemotivi.aschenaz.eu - music-blog
Avatar utente
aschenaz
Staff
Staff
 
Messaggi: 4420
Iscritto il: mar lug 27, 2004 23:00
Località: Reggio Calabria
Nome Cognome: Nino
Slackware: current 64bit
Kernel: 3.14.16
Desktop: KDE 4.10.5


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite