Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]couldn't find RGB GLX visual or fbconfig

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]couldn't find RGB GLX visual or fbconfig

Messaggioda Eberoth » gio nov 22, 2012 19:41

Salve a tutti, di nuovo.

Ho un piccolo problema col mio nuvo portatile e, nonostante una lunga ricerca su internet e alcuni tentativi, non sono riuscito a risolverlo. Il problema è il seguente: non riesco a far funzionare l'accelerazione grafica sulla mia scheda intel integrata.

Premetto che ho (mio malgrado) un sistema con nvidia optimus, e che ho installato i drivers proprietari nvidia usando i pacchetti reperibili su questo forum. Subito dopo ho installato e configurato bumplebee seguendo la guida su docs.slackware.com.

Ora, in effetti lanciando qualcosa con optirun funziona tutto alla perfezione, ma se invece provo ad attivare gli effetti di KDE o a lanciare glxinfo SENZA optirun, non funziona.

La scheda intel è la seguente:
Codice: Seleziona tutto
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)


Mentre l'errore di glxinfo è:
Codice: Seleziona tutto
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".


ho provato a reinstallare xfb86-video-intel e ad eliminare tutti gli altri pacchetti xf86-video... ma non ho risolto niente.
Ultima modifica di Eberoth il sab nov 24, 2012 15:49, modificato 1 volta in totale.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 375
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: couldn't find RGB GLX visual or fbconfig

Messaggioda rik70 » sab nov 24, 2012 12:50

Eberoth ha scritto:ho installato i drivers proprietari nvidia usando i pacchetti reperibili su questo forum. Subito dopo ho installato e configurato bumplebee seguendo la guida su docs.slackware.com.


Premesso che non ho mai usato bumblebee, credo che l'errore sia proprio l'aver installato i driver nvidia già pacchettizzati. Avresti dovuto fare fare tutto tramite gli slackbuild di jgeboski, compresa l'installazione dei driver proprietari.

L'errore che ottieni è proprio il caso tipico di sovrascrittura delle librerie mesa - che servono nel caso specifico al corretto funzionamento della vga Intel - con altre di terze parti.

A questo punto devi disinstallare i driver proprietari nvidia, reinstallare le mesa e procedere daccapo con l'installazione/complilazione di bumblebee.

Ciao
rik70
Linux 2.6
Linux 2.6
 
Messaggi: 971
Iscritto il: gio mar 10, 2011 9:21
Slackware: 13.1
Kernel: 3.11.9-smp
Desktop: LXDE

Re: couldn't find RGB GLX visual or fbconfig

Messaggioda Eberoth » sab nov 24, 2012 15:49

ok, MAI approciarsi a nuove tecnologie dopo le 3 di notte... non avevo letto un pezzo della guida e quindi credevo di dover comunque installare i drivers proprietari.

Grazie rik70!
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 375
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Exabot [Bot], Google [Bot] e 1 ospite