Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]Impossibile utilizzare Adobe Plugins

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Impossibile utilizzare Adobe Plugins

Messaggioda pino_otto » dom dic 09, 2012 7:26

Potresti dettaggliare il link simbolico?

Io ho firefox installato sotto /opt/firefox

Ho fatto il seguente link simbolico dentro la directory /opt/firefox

plugins -> /usr/lib64/mozilla/plugins/

ma continua a non funzionare.

Tu esattamente che link simbolico hai fatto?
pino_otto
Linux 2.4
Linux 2.4
 
Messaggi: 326
Iscritto il: dom lug 09, 2006 10:57
Località: Torino - Changchun (China)
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5

Re: Impossibile utilizzare Adobe Plugins

Messaggioda brainvision » lun dic 10, 2012 1:11

Ma come lo hai fatto il link con un gestore file? O quello è i comando via terminale? perché così sarebbe sbagliato, ovviamente..

Io ho dato, semplicemente

Codice: Seleziona tutto
ln -s /usr/lib64/mozilla/plugins/ /home/UTENTE/.local/.software/.binaries/firefox-17.0.1_it/plugins


la prima volta la dir va scritta come tale, quindi con lo slash finale, la seconda volta perché è ovviamente un file..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Impossibile utilizzare Adobe Plugins

Messaggioda pino_otto » lun dic 10, 2012 1:40

Il link l'ho fatto da terminale col comando:

# ln -s /usr/lib64/mozilla/plugins/ /opt/firefox/plugins

puo' essere un problema perche' firefox e' installato sotto /opt?
pino_otto
Linux 2.4
Linux 2.4
 
Messaggi: 326
Iscritto il: dom lug 09, 2006 10:57
Località: Torino - Changchun (China)
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5

Re: Impossibile utilizzare Adobe Plugins

Messaggioda relay » lun dic 10, 2012 18:44

@zoros:
lanciando firefox e andando in console errori ottengo:
Codice: Seleziona tutto
Failed to load native module at path '/usr/lib/firefox/components/libmozgnome.so': (80004005) libgnomevfs-2.so.0: cannot open shared object file: No such file or directory
Failed to load native module at path '/usr/lib/firefox/components/libnkgnomevfs.so': (80004005) libgnomevfs-2.so.0: cannot open shared object file: No such file or directory
Could not read chrome manifest 'file:///usr/lib/firefox/extensions/%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D/chrome.manifest'.
Timestamp: 10/12/12 17:37:50
Error: mismatched tag. Expected: </a>.
Source File:
Line: 666, Column: 141
Source Code:
        <p> Stand up for privacy, user choice and freedom on the Web.  <a href="http://mzl.la/R8SjXf">Support Mozilla with a year-end gift</link> and get your official Firefox T-shirt</a>.</p>

@brainvision:ho creato un link simbolico così ma continua a non funzionare:
root@debby:/usr/lib64/mozilla/plugins# ls -la
total 24
drwxr-xr-x 3 root root 4096 Dec 10 18:53 .
drwxr-xr-x 3 root root 4096 Dec 5 17:27 ..
lrwxrwxrwx 1 root root 38 Dec 10 18:53 libflashplayer.so -> /opt/firefox/plugins/libflashplayer.so
-rw-r--r-- 1 root root 5400 Dec 31 2010 librhythmbox-itms-detection-plugin.so
-rw-rw-r-- 1 501 501 4009 Oct 29 23:22 readme.txt
drwxrwxr-x 6 501 501 4096 Oct 29 23:22 usr
Consigli?
relay
Linux 2.4
Linux 2.4
 
Messaggi: 291
Iscritto il: mar ago 28, 2007 15:36

Re: Impossibile utilizzare Adobe Plugins

Messaggioda zoros » lun dic 10, 2012 20:21

quei messaggi di errore non sembrano collegarsi al problema in topic ... quelle mancanti sono le librerie di gnome, se firefox le trova allora usa l'interfaccia gnome come finestra per aprire/salvare i file ... nessun feedback utile purtroppo ...

ah, un tempo, con firefox installato in /opt, si doveva fare un link simbolico da /opt/firefox/plugins a /usr/lib/mozilla/plugins, nelle recenti versioni di firefox non serve più, è tutto automatico ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impossibile utilizzare Adobe Plugins

Messaggioda brainvision » lun dic 10, 2012 21:03

giusto per curiosità, prova a lanciare firefox da root e vedere se riconosce le librerie linkate in /opt..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Impossibile utilizzare Adobe Plugins

Messaggioda pino_otto » mar dic 11, 2012 2:14

Lanciando firefox da root da terminale, ho ottenuto i seguenti errori:
root@slack:~# firefox
LoadPlugin: failed to initialize shared library /usr/lib64/mozilla/plugins/libflashplayer.so [/usr/lib64/mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib64/java/jre/lib/amd64/libnpjp2.so [/usr/lib64/java/jre/lib/amd64/libnpjp2.so: wrong ELF class: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib64/mozilla/plugins/skypebuttons.so [/usr/lib64/mozilla/plugins/skypebuttons.so: wrong ELF class: ELFCLASS64]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/libflashplayer.so [/usr/lib/mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS64]
Running global cleanup code from study base classes.

Se guardo il tipo di file, ottengo:
root@slack:~# file /usr/lib64/mozilla/plugins/libflashplayer.so
/usr/lib64/mozilla/plugins/libflashplayer.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped

Il mio sistema e' 64 bit:
root@slack:~# uname -a
Linux slack 2.6.37.6 #3 SMP Sat Apr 9 22:49:32 CDT 2011 x86_64 Intel(R) Xeon(R) CPU X5650 @ 2.67GHz GenuineIntel GNU/Linux

Forse ho capito. Ho installato firefox a 32 bit. Se guardo il tipo di file per firefox, ottengo:
root@slack:~# file /opt/firefox/firefox
/opt/firefox/firefox: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), stripped

Forse devo installare firefox a 64 bit!
pino_otto
Linux 2.4
Linux 2.4
 
Messaggi: 326
Iscritto il: dom lug 09, 2006 10:57
Località: Torino - Changchun (China)
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5

Re: Impossibile utilizzare Adobe Plugins

Messaggioda pino_otto » mar dic 11, 2012 2:55

Ho trovato la versione beta di firefox a 64 bit qui:
ftp://ftp.mozilla.org/pub/firefox/relea ... _64/en-US/

Adesso firefox vede il plugin di flash. :)

Ho scoperto che le versioni a 64 bit di firefox beta non sono accessibili dalla pagina web (che presenta solo quelle a 32 bit), ma bisogna andarle a cercare nel sito ftp di mozilla.
pino_otto
Linux 2.4
Linux 2.4
 
Messaggi: 326
Iscritto il: dom lug 09, 2006 10:57
Località: Torino - Changchun (China)
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5

Re: Impossibile utilizzare Adobe Plugins

Messaggioda relay » mar dic 11, 2012 12:50

@brainvision:ho notato di aver lo stesso problema di pino.
@zoros:Se non serve piu fare il link alla libreria.Quando si scarica libflashplayer in che dir bisogna metterlo, per poi far si che venga caricato?
Grazie!
relay
Linux 2.4
Linux 2.4
 
Messaggi: 291
Iscritto il: mar ago 28, 2007 15:36

Re: Impossibile utilizzare Adobe Plugins

Messaggioda zoros » mar dic 11, 2012 15:35

relay ha scritto:@brainvision:ho notato di aver lo stesso problema di pino.
@zoros:Se non serve piu fare il link alla libreria.Quando si scarica libflashplayer in che dir bisogna metterlo, per poi far si che venga caricato?
Grazie!

eh, in effetti si poteva intuire:
Codice: Seleziona tutto
Failed to load native module at path '/usr/lib/firefox/components/libmozgnome.so': (80004005) libgnomevfs-2.so.0: cannot open shared object file: No such file or directory
...

cercava in /usr/lib/... e non in /usr/lib64/... quindi binario a 32 bit #-o ...

per i plugins, mi sembra evidente dai log di cui sopra che ff64 li cerca in /usr/lib64/mozilla/plugins/
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: [RISOLTO]Impossibile utilizzare Adobe Plugins

Messaggioda kshitigharba » mar dic 11, 2012 18:57

io ho la 14 e mi funziona sia su firefox che su chromium. la plugin l'ho inserita anche io come collegamento in /usr/lib64/mozilla/plugins.
kshitigharba
 

Precedente

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 4 ospiti