Repository 32bit  Forum
Repository 64bit  Wiki

Stranezza in rete: per esperti

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Stranezza in rete: per esperti

Messaggioda Meskalamdug » gio mag 02, 2013 8:54

Ho creato a scopo di test un cluster lvs su Linux centos.
4 macchine,2 fanno da bilanciatori,2 server reali con postfix
,ogni macchina ha 4 schede di rete,le interfacce sono in bond(modalità 1)
1a interfaccia 192.168.0.0/24 bond0
2a "" 192.168.3.0/23 bond1
I client che accedono a postfix hanno una route
statica sulla rete 192.168.3.0/24.
Ho configurato il cluster a dovere,messo l'interfaccia di loopback
192.168.3.252/32 e configurato iptables e annunci arp come da manuale.

Codice: Seleziona tutto
 iptables -t nat -A PREROUTING -p  tcp  -d 192.168.3.252 --dport 25 -j REDIRECT


su sysctl.conf

Codice: Seleziona tutto
net.ipv4.conf.lo.arp_ignore = 1
net.ipv4.conf.lo.arp_announce = 2

Tutto a posto su lato linux(testato client)... ma i client windows non si connette :(
Arp mi da il corretto mac address e ping funziona,ma se telnetto
sulla porta 25 rimane in attesa..come se bloccasse i pacchetti.
Contate che stiamo parlando di macchine virtuali,che mi suggerite?
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3583
Iscritto il: gio mag 13, 2004 23:00

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti