Repository 32bit  Forum
Repository 64bit  Wiki

Montare il NAS [RISOLTO]

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Montare il NAS [RISOLTO]

Messaggioda sunreal » mer lug 09, 2014 16:02

Ciao, come da titolo vorrei avere la possibilità di montare il nas sul filesystem di slack 14.1. Ho provato con google e più o meno in tutti i post che ho vagliato la procedura è la stessa. Creare una directory poi con un comando che inizia più o meno così:
mount -t smbfs -o username= .......
creare il punto di mount per poi accedere al nas tramite riga di comando, perchè il mio scopo finale è quello. Non ho problemi a collegarmoi al nas tramite krusader svrivendo nella barra dell' indirizzo smb:/192.168.1.177 quindi samba è in funzione...
Come si fa?
Grazie.

PS Ovviamente ho fatto alcune prove, tutte miseramente fallite...
Ultima modifica di sunreal il mar lug 22, 2014 7:51, modificato 1 volta in totale.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda Ansa89 » gio lug 10, 2014 9:18

Codice: Seleziona tutto
# mount //nas_ip/nome_share /punto/di/mount -o user=nome_utente_remoto,uid=nome_utente_locale,sec=ntlmv2

Legenda:
- "nas_ip" è l'indirizzo ip del nas
- "nome_share" è il nome della directory condivisa sul nas
- "/punto/di/mount" è la directory locale che usi per montare la condivisione samba
- "nome_utente_remoto" è il nome dell'utente che possiede lo share sul nas (quello che serve per il login per accedere alla condivisione)
- "nome_utente_locale" è il nome del tuo utente locale non privilegiato (leggi: "non root") che avrà accesso in lettura/scrittura alla condivisione montata in locale

PS: "sec=ntlmv2" forse può essere omesso.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2626
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.18.0-ck1
Desktop: XFCE 4.6.1

Re: Montare il NAS

Messaggioda sunreal » gio lug 10, 2014 10:00

Ho provato ma ho questo errore:
Password:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

ho inserito la password che uso per accedere al nas, ed ho provato anche con quella di root.
Dov'è che sbaglio?
Ciao

PS: questo è il comando inserito:
mount//192.168.1.170/Dati_recuperati /mnt/NEWnas -o user=nascasa,uid=slck14_01-14,sec=ntlmv2
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda Ansa89 » gio lug 10, 2014 15:56

Prova con "sec=ntlm" (ed eventualmente senza paramatro "sec").
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2626
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.18.0-ck1
Desktop: XFCE 4.6.1

Re: Montare il NAS

Messaggioda sunreal » gio lug 10, 2014 18:42

Senza l' ultima parte avevo già provato... Con la correzione consigliata ho provato ma il risultato è lo stesso.
Per fugare ogni dubbio vi dico cosa ho fatto:
ho creato la directory in /mnt
poi da konsole digito su e password di root
poi inserisco il comando mount//192.168.1.170/......
e a quel punto viene fuori l' errore....
La password che io inserisco è quella per accedere al nas, non so se la directory /Dati_recuperati possa avere un' altra password.... ???
Non saprei.
Ciao.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda robbybby » gio lug 10, 2014 23:21

Sei sicuro di avere impostato il NAS in modo che esporti anche nfs, e non solo samba?
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1183
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Montare il NAS

Messaggioda Ansa89 » ven lug 11, 2014 7:24

La directory "Dati_recuperati" è una semplice directory del nas o è proprio uno share samba?
Hai per caso impostato qualche dominio di lavoro (workgroup)?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2626
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.18.0-ck1
Desktop: XFCE 4.6.1

Re: Montare il NAS

Messaggioda Naitso » ven lug 11, 2014 15:53

Verifica le condivisioni attive sul NAS con il comando seguente

Codice: Seleziona tutto
# smbclient -L 192.168.1.177
Enter root's password: (premi enter)


se "Dati_recuperati" è condivisa apparirà nell'output del precedente comando.

assicurati che nel NAS ci sia un utente che può accedere a questa condivisione e solitamente va gestito dalla console del NAS, toglimi una curiosità accedendo con
krusader svrivendo nella barra dell' indirizzo smb:/192.168.1.177
ti appare una maschera dove inserire nome utente e password? o appare direttamente la directory?

per montare lo share solitamente faccio così:
Codice: Seleziona tutto
mount.cifs //[NAS-IP]/[directory-condivisa]/ /mnt/NAS/ -o uid=1000,gid=100,user=[utente-su-nas],file_mode=0755,dir_mode=0755


dove:
uid=1000 (user id che voglio assegnare ai file del NAS una volta montato)
gid=100 (come sopra ma relativo al gruppo)
file_mode, dir_mode i permessi su file e directory del NAS una volta montat.,( fai attenzione uno share cifs ed ai permessi unix)

una volta premuto invio ti verrà chiesta una password, devi digitare quella dell'utente "[utente-su-nas]" .

P.S. l'operazione di mount va fatta da root o da utente con privilegi analoghi
Avatar utente
Naitso
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: lun nov 10, 2008 15:09

Re: Montare il NAS

Messaggioda sunreal » sab lug 12, 2014 7:52

Ciao e grazie per l' aiuto. Ho iniziato da ciò che mi dice Naitso ed ho inserito:
bash-4.2$ smbclient -L 192.168.1.170

questo è l' output:
params.c:OpenConfFile() - Unable to open configuration file "/etc/samba/smb.conf":
File o directory non esistente
smbclient: Can't load /etc/samba/smb.conf - run testparm to debug it
Enter slck14_01-14's password:
INSERISCO LA PASSWORD UTENTE...
session setup failed: NT_STATUS_LOGON_FAILURE

PROBLEMI? Beh direi di si...


Naitso ha scritto:assicurati che nel NAS ci sia un utente che può accedere a questa condivisione e solitamente va gestito dalla console del NAS, toglimi una curiosità accedendo con
krusader svrivendo nella barra dell' indirizzo smb:/192.168.1.177
ti appare una maschera dove inserire nome utente e password? o appare direttamente la directory?

Mi appare la finestrella per inserire nome utente e password.

robbybby ha scritto:Sei sicuro di avere impostato il NAS in modo che esporti anche nfs, e non solo samba?

Direi di si. Allego lo screenshot del pannello di controllo del nas.
NFS-suNAS.jpg
NFS-suNAS.jpg (78.92 KiB) Osservato 1038 volte


Ansa89 ha scritto:La directory "Dati_recuperati" è una semplice directory del nas o è proprio uno share samba?
Hai per caso impostato qualche dominio di lavoro (workgroup)?

È una directory del nas.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda sunreal » dom lug 13, 2014 8:32

Sto ancora tentando di venirne a capo.... Allora ho rinominato il file smb.conf-sample in smb.conf ed ho ripetuto il comando:
smbclient -L 192.168.1.170
alla richiesta di password utente inserendo quella dell' utente slack ho questo output:

session setup failed: NT_STATUS_LOGON_FAILURE

Se invece inserisco la password che uso per accedere al nas la risposta è questa:

Conversion error: Incomplete multibyte sequence(£P)
session setup failed: NT_STATUS_LOGON_FAILURE

???????

PS Non è che per caso bisogna intervenire in qualche modo sul file /etc/fstab? Non l' ho troavato scritto da nessuna parte ma essendo come una nuova partizione da montare....
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda Naitso » dom lug 13, 2014 15:18

Andiamo con ordine, che IP ha il NAS? perché prima vedo 177 finale, poi 170...
Avatar utente
Naitso
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: lun nov 10, 2008 15:09

Re: Montare il NAS

Messaggioda sunreal » dom lug 13, 2014 15:49

Naitso ha scritto:Andiamo con ordine, che IP ha il NAS? perché prima vedo 177 finale, poi 170...

Avevo scritto male nel post, l'IP corretto è 192.168.1.170
...
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda Naitso » lun lug 14, 2014 10:22

sunreal ha scritto:
Naitso ha scritto:Andiamo con ordine, che IP ha il NAS? perché prima vedo 177 finale, poi 170...

Avevo scritto male nel post, l'IP corretto è 192.168.1.170
...


Ok, ora modello del NAS?

poi da root:
Codice: Seleziona tutto
# smbclient -L 192.168.1.170


e posti l'intero output comando compreso! e gentilmente utilizza il tag "Code"
Avatar utente
Naitso
Linux 2.4
Linux 2.4
 
Messaggi: 206
Iscritto il: lun nov 10, 2008 15:09

Re: Montare il NAS

Messaggioda sunreal » lun lug 14, 2014 13:52

Allora il nas è un synology ds212j.
L' output del comando: smbclient -L 192.168.1.170
è questo:
Codice: Seleziona tutto
bash-4.2$ smbclient -L 192.168.1.170
Enter slck14_01-14's password:
session setup failed: NT_STATUS_LOGON_FAILURE
bash-4.2$

L' ho fatto anche da root ..... così per vedere se camobia qualcosa ma il risultato è uguale. In entrambe i casi ho inserito la password dell' utente slackware non quella del nas...
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Montare il NAS

Messaggioda rik70 » lun lug 14, 2014 19:49

Per curiosità:
ma se gli passi anche il flag -N cosa succede?

Es:
Codice: Seleziona tutto
smbclient -N -L //192.168.1.170
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1323
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Prossimo

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron