Repository 32bit  Forum
Repository 64bit  Wiki

huawei e353 tim su slackware 14.1 [RISOLTO]

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

huawei e353 tim su slackware 14.1 [RISOLTO]

Messaggioda plinius » mar ago 05, 2014 12:45

Non riesco a collegarmi con la chiavetta in oggetto, network management e kppp non la rilevano mentre questo è il risultato se do lsusb
bash-4.2# lsusb
Bus 001 Device 002: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 006: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


ho provato di modificare il file
/etc/usb_modeswitch.d/12d1:1446
ma non esiste nella directory
Ultima modifica di plinius il mar ago 05, 2014 18:31, modificato 1 volta in totale.
plinius
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: mar lug 15, 2014 15:40
Nome Cognome: giavit
Slackware: 14.1
Kernel: 3.10.17
Desktop: kde

Re: huawei e353 tim slackware 14.1

Messaggioda fgcl2k » mar ago 05, 2014 16:27

Ho la stessa chiavetta (con TIM) e funziona perfettamente con Slackware 14.1.
Dmesg:
Codice: Seleziona tutto
[ 5052.459281] usb 4-3: USB disconnect, device number 3
[ 5058.647097] usb 4-3: new high-speed USB device number 4 using ehci-pci
[ 5058.763468] usb 4-3: New USB device found, idVendor=12d1, idProduct=1506
[ 5058.763481] usb 4-3: New USB device strings: Mfr=3, Product=2, SerialNumber=0
[ 5058.763489] usb 4-3: Product: HUAWEI Mobile
[ 5058.763495] usb 4-3: Manufacturer: HUAWEI
[ 5058.765757] usb-storage 4-3:1.4: USB Mass Storage device detected
[ 5058.765869] scsi10 : usb-storage 4-3:1.4
[ 5058.766183] usb-storage 4-3:1.5: USB Mass Storage device detected
[ 5058.766255] scsi11 : usb-storage 4-3:1.5
[ 5058.778297] usbcore: registered new interface driver usbserial
[ 5058.778312] usbcore: registered new interface driver usbserial_generic
[ 5058.778320] usbserial: USB Serial support registered for generic
[ 5058.780643] usbcore: registered new interface driver option
[ 5058.780657] usbserial: USB Serial support registered for GSM modem (1-port)
[ 5058.781835] usb 4-3: MAC-Address: 58:2c:80:13:92:63
[ 5058.782034] cdc_ncm 4-3:1.1 wwan0: register 'cdc_ncm' at usb-0000:00:1d.7-3, Mobile Broadband Network Device, 58:2c:80:13:92:63
[ 5058.782063] usbcore: registered new interface driver cdc_ncm
[ 5058.782835] option 4-3:1.0: GSM modem (1-port) converter detected
[ 5058.782941] usb 4-3: GSM modem (1-port) converter now attached to ttyUSB0
[ 5058.782965] option 4-3:1.2: GSM modem (1-port) converter detected
[ 5058.783020] usb 4-3: GSM modem (1-port) converter now attached to ttyUSB1
[ 5058.783034] option 4-3:1.3: GSM modem (1-port) converter detected
[ 5058.783356] usb 4-3: GSM modem (1-port) converter now attached to ttyUSB2
[ 5059.769101] scsi 11:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[ 5059.769497] scsi 10:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2

Dopo qualche secondo dall'inserimento la luce sulla chiavetta diventa blu ed è pronta per l'uso.
Io uso pppd per collegarmi.
Non sono mai riuscito ad usare ModemManager per cui lo elimino subito dalle mie installazioni.
La directory /etc/usb_modeswitch.d/ da me è vuota. Lsusb è come il tuo.
Hai provato a usare un'altra porta USB?
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 129
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: huawei e353 tim slackware 14.1

Messaggioda plinius » mar ago 05, 2014 17:23

intendevi kppp per collegarti??
e mi faresti vedere come configuri nel qual caso kppp
plinius
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: mar lug 15, 2014 15:40
Nome Cognome: giavit
Slackware: 14.1
Kernel: 3.10.17
Desktop: kde

Re: huawei e353 tim slackware 14.1

Messaggioda plinius » mar ago 05, 2014 18:30

non ho capito come ma adesso network management lo vede e si connette tranquillamente, con una procedura che provavo da giorni cioè questa
1) collego la pennina
2) aspettavo che su network management in basso a destra comparisse l 'icona del cellulare
Ma qui mi bloccavo perchè non lo riconoscevo
Oggi lo ha riconosciuto (sempre la stessa porta usb stesso cavo e stessa chiavetta)
adesso sto pensando non è che installando wvdial e poi disinstallato per paura di conflietti abbia questo passato informazioni a network management per il riconoscimento della chiavetta?
comunque ho ripreso dal punto 2
3) cliccato su manage connection
4) adesso la scheda mobile broadband era selezionabile (cosa che non succedeva prima in quanto non lo riconosceva)
5) ho seguito il wizard della connessione con italia tim etc etc
e adesso funziona

ripeto questa procedura l'ho fatta un milione di volte ma non funzionava
sembra che sia riuscito a riconoscere la chiavetta solo dopo aver installato wvdial
cosa che se non ricordo male succedeva anche con la 13.37
ma li avevo installato wvdial e spesso mi collegavo con questo

PS se qualcuno mi sa dare una spiegazione a scopo didattico gliene sarei grato
plinius
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: mar lug 15, 2014 15:40
Nome Cognome: giavit
Slackware: 14.1
Kernel: 3.10.17
Desktop: kde


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite

cron