APACHE Error Forbidden 403

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
darkstaring
Linux 3.x
Linux 3.x
Messaggi: 639
Iscritto il: mer ott 13, 2010 13:55
Nome Cognome: Francesco Achenza
Desktop: KDE
Distribuzione: Arch Linux
Contatta:

APACHE Error Forbidden 403

Messaggioda darkstaring » mer nov 05, 2014 16:24

Sera a tutti,
Ho un problemino con apache su un server ubuntu 8.10
Dopo aver risettato i repository ho installato apache2, php5, php5-cgi, php5-cli.

Ho messo la "webdir" nella directory /media/ufficio/WEB/
questi sono i permessi:

Codice: Seleziona tutto

root@Server:/etc/apache2# ls -alt /media/ufficio/WEB/
total 28
-rwxrwxrwx   1 www-data www-data  2705 2014-11-05 14:33 index.php
drwxrwxrwx   4 www-data www-data  4096 2014-11-05 14:12 .
drwxrwxrwx   3 www-data www-data  4096 2014-11-05 14:12 img
drwxrwxrwx   2 www-data www-data  4096 2014-11-05 14:12 images
drwxrwx--- 119 ufficio  ufficio  12288 2014-11-05 14:09 ..


Quindi ho impostato apache2 in /etc/apache2/sites-enabled/000-default

Codice: Seleziona tutto

root@Server:/etc/apache2# cat /etc/apache2/sites-enabled/000-default
<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /media/ufficio/WEB/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /media/ufficio/WEB/>
                    Order allow,deny
                    Allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Ma se vado nell'ip del server mi viene restituito l'errore Forbidden 403;

Così ho guardato il log per cercare errori e ho trovato questo:

Codice: Seleziona tutto

[Wed Nov 05 15:04:04 2014] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.6 with Suhosin-Patch configured -- resuming normal operations
[Wed Nov 05 15:04:08 2014] [error] [client 192.168.1.10] (13)Permission denied: access to / denied

Sembrerebbe che il mio ip (host '192.168.1.10'), non abbia accesso... :(

Sapete darmi una mano?
Grazie 1000
Francesco

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6538
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: 64-current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Re: APACHE Error Forbidden 403

Messaggioda targzeta » mer nov 05, 2014 18:58

Tieni conto che:
  • l'utente con cui gira il server web (www-data) deve poter accedere a tutto il percorso /media/ufficio/WEB/
  • la direttiva

    Codice: Seleziona tutto

    <Directory />
    non ti serve
  • ai file non serve il diritto di esecuzione ed è buona norma togliere i diritti di scrittura anche al gruppo e, soprattutto a tutti gli altri (chmod go-w)
  • siamo utenti Slackware :)
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà 

miklos
Master
Master
Messaggi: 1506
Iscritto il: lun lug 16, 2007 17:39
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2
Località: Roma

Re: APACHE Error Forbidden 403

Messaggioda miklos » gio nov 06, 2014 8:05

se non risolvi con i permessi, come suggerito da targzeta, controlla pure di aver correttamente configurato l'apache per usare il php.
ho visto cose che voi astemi non potete immaginare
https://github.com/ilmich

Avatar utente
Naitso
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: lun nov 10, 2008 15:09

Re: APACHE Error Forbidden 403

Messaggioda Naitso » gio nov 06, 2014 21:37

Codice: Seleziona tutto

      <Directory /media/ufficio/WEB/>
                    Order allow,deny
                    Allow from all
        </Directory>


cambiala in

Codice: Seleziona tutto

      <Directory /media/ufficio/WEB/>
                    Order deny,allow
                    Allow from all
        </Directory>


se non specificato diversamente le regole di default sono:

Codice: Seleziona tutto

Allow from all
Deny from all


nel tuo caso apache è configurato per eseguire prima le direttive allow (from all) e poi quella di deny (from all) essendo una regola di default anche se non l'hai specificata nella conf viene eseguita comunque, per questo motivo ti blocca, inverti l'order e vedrai che funziona.
Facci sapere
Ciao

Avatar utente
darkstaring
Linux 3.x
Linux 3.x
Messaggi: 639
Iscritto il: mer ott 13, 2010 13:55
Nome Cognome: Francesco Achenza
Desktop: KDE
Distribuzione: Arch Linux
Contatta:

Re: APACHE Error Forbidden 403

Messaggioda darkstaring » sab nov 08, 2014 12:09

Grazie,
Ho provato a modificare le direttive come mi hai detto:

Questo è tutto il file /etc/apache2/sites-enabled/000-default

Codice: Seleziona tutto

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /media/ufficio/WEB/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /media/ufficio/WEB/>
                    Order deny,allow
                    Allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>


Ho eseguito un force-reload
ma andando all'indirizzo mi compare sempre l'errore 403.

Questo è il log

Codice: Seleziona tutto

[Sat Nov 08 11:08:33 2014] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4.6 with Suhosin-Patch configured -- resuming normal operations
[Sat Nov 08 11:08:44 2014] [error] [client 192.168.1.10] (13)Permission denied: access to / denied

Stranissimo...

Avatar utente
Naitso
Linux 2.x
Linux 2.x
Messaggi: 208
Iscritto il: lun nov 10, 2008 15:09

Re: APACHE Error Forbidden 403

Messaggioda Naitso » lun nov 10, 2014 19:40

gentilmente puoi postare il contenuto completo del file

Codice: Seleziona tutto

/etc/httpd/httpd.conf

grazie
EDIT
ahaha dimenticavo che non è slackware....
guarda qui http://httpd.apache.org/docs/2.2/vhosts/name-based.html e controlla la voce Server Alias