Mpv - Option fmt: unknown format name: '444p'

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2886
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Mpv - Option fmt: unknown format name: '444p'

Messaggioda joe » lun dic 18, 2017 11:16

Ciao a tutti,
mi capita una cosa piuttosto strana:
fino a ieri il player MPV funzionava senza problemi.
Poco fà ho aperto l'applicazione dal menù di KDE e non si apriva, con la piccola icona di "avvio applicazione" che continuava a saltellare all'infinito.
Allora l'ho lanciato da terminale liscio "mpv + INVIO".
E qua salta fuori il seguente errore:

Codice: Seleziona tutto

$ mpv
Option fmt: unknown format name: '444p'
Error parsing option fmt (option parameter could not be parsed)
Option vf-add: Error while parsing noformat parameter fmt (444p)
Error parsing option vf-add (option parameter could not be parsed)
/etc/mpv/encoding-profiles.conf:78: setting option vf-add='noformat=444p,noformat=444p9,noformat=444p10,noformat=422p,noformat=422p9,noformat=422p10' failed.
Passing multiple arguments to ofopts-add is deprecated!
Passing multiple arguments to ovcopts-add is deprecated!
Passing multiple arguments to ofopts-add is deprecated!
Passing multiple arguments to ovcopts-add is deprecated!
Passing multiple arguments to ovcopts-add is deprecated!


Il fatto è che da ieri ad oggi non ho toccato nulla nella configurazione e non ho neanche aggiornato niente.
Perchè dall'oggi al domani, così di punto in bianco secondo voi non funziona più?

Non me lo spiego.
E non saprei neanche come fare a risolvere per di più... :roll:

Dettagli sulla versione.
Pacchetto installato da SBo:

Codice: Seleziona tutto

$ mpv --version
Option fmt: unknown format name: '444p'
Error parsing option fmt (option parameter could not be parsed)
Option vf-add: Error while parsing noformat parameter fmt (444p)
Error parsing option vf-add (option parameter could not be parsed)
/etc/mpv/encoding-profiles.conf:78: setting option vf-add='noformat=444p,noformat=444p9,noformat=444p10,noformat=422p,noformat=422p9,noformat=422p10' failed.
Passing multiple arguments to ofopts-add is deprecated!
Passing multiple arguments to ovcopts-add is deprecated!
Passing multiple arguments to ofopts-add is deprecated!
Passing multiple arguments to ovcopts-add is deprecated!
Passing multiple arguments to ovcopts-add is deprecated!
mpv 0.27.0 (C) 2000-2017 mpv/MPlayer/mplayer2 projects
 built on Thu Nov  9 15:39:43 CET 2017
ffmpeg library versions:
   libavutil       55.58.100
   libavcodec      57.89.100
   libavformat     57.71.100
   libswscale      4.6.100
   libavfilter     6.82.100
   libswresample   2.7.100
ffmpeg version: 3.3.4


Avete qualche consiglio?
Grazie mille in anticipo! :D

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2368
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.16.2
Desktop: lxde
Località: Pisa
Contatta:

Re: Mpv - Option fmt: unknown format name: '444p'

Messaggioda ponce » lun dic 18, 2017 11:20

hai provato a rinominare il file ~/.config/mpv/mpv.conf e a rilanciarlo?

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2886
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Mpv - Option fmt: unknown format name: '444p'

Messaggioda joe » lun dic 18, 2017 11:52

Si, così funziona!!!
L'ho lanciato dal menù di KDE...
Grazie davvero! :)

Ma cosa diavolo può essergli preso?
Non me lo spiego... Ieri funzionava...

Lanciandolo a mano da shell senza argomenti giustamente non parte nulla...
Anche adesso.. Ero io che facevo confusione.
Mettendgli un argomento "qualcosa.mkv" ad esempio ora si apre la finestrella e riproduce.

Però gli errori di prima ci sono sempre... Quindi forse non erano loro ad indicare il fatto che l'applicazione non si aprisse...

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2886
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Mpv - Option fmt: unknown format name: '444p'

Messaggioda joe » lun dic 18, 2017 11:59

Anzi ho ripristinato il vecchio file di configurazione , tale e quale a poco fa e funziona sempre tutto...
Quindi non era quello il problema...

Probabilmente se lanciavo "mpv nome file" invece che "mpv" e basta, sarebbe partito normalmente.
Dev'essere stato qualche inghippo a livello di finestre di KDE e probabilmente mpv non c'entrava nulla...
Difficile dire perchè accadono questi inceppamenti (fortunatamente sporadicissimi).