Repository 32bit  Forum
Repository 64bit  Wiki

Slackyd - Slacky downloader [DEAD]

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Slackyd - Slacky downloader

Messaggioda Dani » gio lug 23, 2009 3:03

anycolouryoulike ha scritto:Questo però non dovrebbe succedere vero?
Codice: Seleziona tutto
Upgrade slackyd-0.1.13.2beta-i486-1mch to:
        slackyd-0.1.13beta-i486-1mch.tgz [from slacky] ? [y/N]

Non dovrebbe accadere ma purtroppo ogni tanto strverscmp() da i numeri quando deve confrontare versioni "beta", "pre" o simili. :roll:
Dunque ora che il packages.txt di slacky è stato aggiornato, l'ultima versione dovrà essere scaricata a mano perchè non comparirà nella lista dei pacchetti da upgradare #-o
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda Dani » ven lug 31, 2009 3:33

Scoperto un piccolo bug sulla risoluzione delle dipendenze :| Di seguito il fix.
Allegati
slackyd-0.1.13.2-ordepfix.txt
(1.51 KiB) Scaricato 30 volte
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda anycolouryoulike » lun ago 24, 2009 20:12

Che versione sarebbe (per il pacchetto)?
Avatar utente
anycolouryoulike
Packager
Packager
 
Messaggi: 1158
Iscritto il: gio ago 09, 2007 23:00
Slackware: 12.2
Kernel: 2.6.34.8
Desktop: KDE 3.5.10

Re: Slackyd - Slacky downloader

Messaggioda Dani » ven ago 28, 2009 0:08

La versione rimane 0.1.13.2. Per il pacchetto conviene incrementare solo $build :)
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda Dani » sab ott 24, 2009 5:16

Rilasciata la versione 0.1.13.3 che include le due patch precedenti piu' quella di zerouno per il supporto a wget.
Nel file di configurazione ci sono due nuove keyword: "wget" e "slackware64".
Allego il tar
Allegati
slackyd-0.1.13.3beta.tar.gz
(62.03 KiB) Scaricato 13 volte
Ultima modifica di Dani il mar ott 27, 2009 23:12, modificato 2 volte in totale.
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda ZeroUno » mar ott 27, 2009 10:38

non lo metti in asche?

Ciao
01
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4384
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Slackyd - Slacky downloader

Messaggioda Dani » mar ott 27, 2009 23:17

ZeroUno ha scritto:non lo metti in asche?

Ciao
01

Ho dovuto fare un'ulteriore modifica perchè c'erano problemi a scaricare i file con wget da mirror con porte non standard tipo "xyz.com:8080/slackware/etc/.."
Ora è in upload ;)
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda ZeroUno » gio nov 05, 2009 21:59

Scaricare pacchetti già installati.

Se ho un programma installato ed io lo voglio riscaricare, slackyd -g non me lo fa fare, nemmeno con il -f; mi dice "already installed"


Ciao
01
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4384
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Slackyd - Slacky downloader

Messaggioda danix » gio nov 05, 2009 22:26

ZeroUno ha scritto:Scaricare pacchetti già installati.

Se ho un programma installato ed io lo voglio riscaricare, slackyd -g non me lo fa fare, nemmeno con il -f; mi dice "already installed"


Ciao
01

quoto...

mi tornerebbe utile anche la possibilità di scegliere una diversa versione di slackware da linea di comando... ad esempio, se imposto i mirror della 13, mi farebbe comodo dire a slackyd di scaricarmi i sorgenti di un pacchetto dal repo della 12.2 (su slacky) per poterlo ripacchettizzare per il repository...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Slackyd - Slacky downloader

Messaggioda ZeroUno » gio nov 05, 2009 22:53

danix ha scritto:mi tornerebbe utile anche la possibilità di scegliere una diversa versione di slackware da linea di comando...

per quello esiste il -c

io ho /etc/slackyd/slackyd-12.2.conf e /etc/slackyd/slackyd-13.0.conf e uso l'uno o l'altro a seconda di quale mi serve; poi ho messo un link
slackyd.conf -> slackyd-12.2.conf
per scegliere per default i pacchetti da ripacchettizzare.

ma il problema di scaricare anche se è già installato (che sia 12.2 o 13.0) rimane.

Ciao
01
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4384
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Slackyd - Slacky downloader

Messaggioda Dani » ven nov 06, 2009 1:16

@zerouno:
Aggiungi l'opzione -I ;)
@danix:
Anch'io suggerisco di usare un file di configurazione a parte e magari anche un alias per evitare di specificare ogni volta il percorso del file !
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda danix » ven nov 06, 2009 9:12

grazie ragazzi, non avevo pensato a nessuna delle 2 soluzioni... :D


PS (voglio fare il rompip***e :badgrin: )
in questi casi tornerebbe utile il man...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Slackyd - Slacky downloader

Messaggioda ulisse89 » ven dic 11, 2009 9:26

A me succede una cosa strana. Se cerco gdal, che non è ancora stato compilato per la 13.0 mi segnala che ha trovato la versione della 12.2.
Ho provato con altri che non sono ancora stati compilati e non lo fa.
Come mai?
Codice: Seleziona tutto
bash-3.1# slackyd -u

Repository: slackware [ftp.nluug.nl]
`- Downloading FILELIST.TXT [100 % @ 324.1 KB/s]         
`- Downloading CHECKSUMS.md5 [100 % @ 219.9 KB/s]         
`- Downloading PACKAGES.TXT [Already update]             
`- Downloading patches PACKAGES.TXT [100 % @ 48.6 KB/s]         
`- Downloading patches MANIFEST.bz2 [100 % @ 279.2 KB/s]         
>> Uncompressing patches MANIFEST.bz2: done.
`- Downloading extra PACKAGES.TXT [Already update]             
Repository: slacky [darkstar.ist.utl.pt]
`- Downloading FILELIST.TXT [100 % @ 469.8 KB/s]   
`- Downloading PACKAGES.TXT [100 % @ 372.3 KB/s]   
`- Downloading CHECKSUMS.md5 [100 % @ 355.2 KB/s]   
`- Downloading MANIFEST.bz2 [100 % @ 493.5 KB/s]   
>> Uncompressing MANIFEST.bz2: done.

bash-3.1# slackyd -s gdal

Searching gdal: found 1 package.

gdal-1.6.2-i486-1sl.tgz [from slacky]



PS: Il file di configurazione è correttamente settato per la 13.0.

EDIT: Lo fa anche con geos. La cosa in comune tra i due è che sono entrambi in fase di ricompilazione dallo stesso utente.
Avatar utente
ulisse89
Packager
Packager
 
Messaggi: 644
Iscritto il: sab gen 17, 2009 12:53
Località: Bologna
Nome Cognome: Riccardo
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Xfce

Re: Slackyd - Slacky downloader

Messaggioda Dani » ven dic 11, 2009 11:24

ulisse89 ha scritto:A me succede una cosa strana. Se cerco gdal, che non è ancora stato compilato per la 13.0 mi segnala che ha trovato la versione della 12.2.

Nella lista dei pacchetti di slacky ci sono entrambi:
Codice: Seleziona tutto
root[~]# egrep "(geos|gdal)-.*t[gx]z" /var/slackyd/slacky/PACKAGES.TXT
PACKAGE NAME:  gdal-1.6.2-i486-1sl.tgz
PACKAGE NAME:  geos-3.1.1-i486-1sl.tgz
root[~]#

Forse sono stati già compilati e uppati in un primo momento per slackware13 ma a causa dell'estenzione stanno venendo nuovamente ricompilati :-k
Dani
Linux 3.x
Linux 3.x
 
Messaggi: 1447
Iscritto il: mer apr 26, 2006 0:52
Desktop: gnome
Distribuzione: arch

Re: Slackyd - Slacky downloader

Messaggioda ulisse89 » ven dic 11, 2009 15:27

Dani ha scritto:
ulisse89 ha scritto:A me succede una cosa strana. Se cerco gdal, che non è ancora stato compilato per la 13.0 mi segnala che ha trovato la versione della 12.2.

Nella lista dei pacchetti di slacky ci sono entrambi:
Codice: Seleziona tutto
root[~]# egrep "(geos|gdal)-.*t[gx]z" /var/slackyd/slacky/PACKAGES.TXT
PACKAGE NAME:  gdal-1.6.2-i486-1sl.tgz
PACKAGE NAME:  geos-3.1.1-i486-1sl.tgz
root[~]#

Forse sono stati già compilati e uppati in un primo momento per slackware13 ma a causa dell'estenzione stanno venendo nuovamente ricompilati :-k

Ok. Allora tutto a posto. Mi fregava l'estensione. Per questo credevo che non fossero stati ancora compilati per la 13.0.
Grazie. ;)
Avatar utente
ulisse89
Packager
Packager
 
Messaggi: 644
Iscritto il: sab gen 17, 2009 12:53
Località: Bologna
Nome Cognome: Riccardo
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Xfce

PrecedenteProssimo

Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite