[RISOLTO] Tag SELECT e onChange non funziona con Konqueror

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

[RISOLTO] Tag SELECT e onChange non funziona con Konqueror

Messaggioda phobos3576 » sab set 20, 2008 17:04

Ho creato una banalissima ListBox con questo codice:

Codice: Seleziona tutto

<SELECT name="yearData" size="10"
              onChange="window.alert(this.options[this.selectedIndex].value);"
              style="font-family: arial, helvetica;
              font-size: 12px;
              font-weight: bold;
              background: silver;
              color: blue;
              height: 180; width: 110;">
   <OPTION value="2008" selected="true">2008</OPTION>
   <OPTION value="2009">2009</OPTION>
   <OPTION value="2010">2010</OPTION>
   <OPTION value="2011">2011</OPTION>
</SELECT>

Su Firefox e Opera tutto funziona correttamente, anche mettendo un onClick direttamente nei tag OPTION.
Con Konqueror non succede nulla.

Pensandoci bene, Konqueror usa il motore KHTML, proprio come Safari, Chrome e (credo) anche Explorer; guarda caso, tutti questi browser richiedono onChange nel tag SELECT, mentre onClick nei tag OPTION non funziona!

Avete qualche soluzione per Konqueror?

EDIT: Scusate, era un mio errore!

Resta il fatto però che Explorer, Safari, Chrome e Konqueror non funzionano con onClick nel tag OPTION; è un problema che si portano appresso da parecchio tempo nonostante lo standard dica che quel codice è perfettamente valido (e, infatti, funziona su Firefox e Opera).

Torna a “Programmazione”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti