Repository 32bit  Forum
Repository 64bit  Wiki

Python 3.0!!!

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Python 3.0!!!

Messaggioda sir_alex » gio dic 04, 2008 15:04

sir_alex
Linux 2.6
Linux 2.6
 
Messaggi: 735
Iscritto il: lun mar 21, 2005 0:00
Località: Milano - Corbola (RO)
Kernel: 2.6.35-22
Desktop: KDE4
Distribuzione: Ubuntu

Re: Python 3.0!!!

Messaggioda metrofox » gio dic 04, 2008 15:48

Ottimo! ;) Congratulazioni!
Avatar utente
metrofox
Linux 2.6
Linux 2.6
 
Messaggi: 758
Iscritto il: gio ago 07, 2008 11:29
Slackware: slackware64-current
Kernel: 3.4.4-ck3
Desktop: FluxBox-1.3.1
Distribuzione: FreeBSD-8.1(amd64)

Re: Python 3.0!!!

Messaggioda m0rdr3d » gio dic 04, 2008 15:50

Yeppa!!!
Chissà di toglierci in fretta di mezzo gli esami così da poterci giocare...
Avatar utente
m0rdr3d
Linux 2.4
Linux 2.4
 
Messaggi: 404
Iscritto il: dom dic 24, 2006 13:40
Slackware: Slackware64-current
Kernel: 3.4.*
Desktop: KDE 4.8.2

Re: Python 3.0!!!

Messaggioda lamarozzo » gio dic 04, 2008 16:13

finalmente non dovremo più fare

Codice: Seleziona tutto
import __future__


\:D/
Avatar utente
lamarozzo
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: mer lug 13, 2005 23:00
Località: Roma
Desktop: xfce
Distribuzione: archlinux

Re: Python 3.0!!!

Messaggioda shark1500 » gio dic 04, 2008 17:23

Chissa' se pat la includera' in slackware 12.2 o non si fida :-)
Avatar utente
shark1500
Linux 2.6
Linux 2.6
 
Messaggi: 785
Iscritto il: gio apr 03, 2008 13:33
Località: Modna
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde

Re: Python 3.0!!!

Messaggioda lamarozzo » gio dic 04, 2008 17:28

shark1500 ha scritto:Chissa' se pat la includera' in slackware 12.2 o non si fida :-)


se la includerà sarà comunque a fianco della vecchia versione. A quel che ho sentito Python 3 rompe abbastanza la compatibilità col passato.
Avatar utente
lamarozzo
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: mer lug 13, 2005 23:00
Località: Roma
Desktop: xfce
Distribuzione: archlinux

Re: Python 3.0!!!

Messaggioda sir_alex » gio dic 04, 2008 17:36

shark1500 ha scritto:Chissa' se pat la includera' in slackware 12.2 o non si fida :-)


Non credo: è incompatibile (non del tutto ma parecchio) con la 2.x, quindi non penso la vedremo quantomeno prima della 13, specie se vogliamo che i programmi scritti in Python si compilino ancora... :)
sir_alex
Linux 2.6
Linux 2.6
 
Messaggi: 735
Iscritto il: lun mar 21, 2005 0:00
Località: Milano - Corbola (RO)
Kernel: 2.6.35-22
Desktop: KDE4
Distribuzione: Ubuntu

Re: Python 3.0!!!

Messaggioda metrofox » gio dic 04, 2008 17:45

shark1500 ha scritto:Chissa' se pat la includera' in slackware 12.2 o non si fida :-)


Non credo lo possa più fare, ormai siamo alle RC1, i pacchetti sono congedati, ci sta solo la fase di bugfixing(a quanto ne ho capito...). Comunque credo che pat riserverà tutto per la prossima versione di slackware, o meglio la 13.0, credo che sarà una mega versione...
Avatar utente
metrofox
Linux 2.6
Linux 2.6
 
Messaggi: 758
Iscritto il: gio ago 07, 2008 11:29
Slackware: slackware64-current
Kernel: 3.4.4-ck3
Desktop: FluxBox-1.3.1
Distribuzione: FreeBSD-8.1(amd64)


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron