apashe e puntamento a directory in home

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 201
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

apashe e puntamento a directory in home

Messaggioda Linpassion » mer set 23, 2015 18:12

dopo diversi tentativi posto qui il problema: cioè puntare apache ad una directory nella mia home, senza dover sempre andare in www.
Le discussioni in rete indicano di modificare il file httpd.con e riavviare apache; e cosi ho fatto. ma quando da browser digito http:localhost://nomefile.php restituisce l'errore 404 not fund.

Il codice è:

Codice: Seleziona tutto

<Directory /home/pluto/downloads/tmpsviluppo/php/>
Allowoverride None
Options None
Order allow,deny
Allow from All
</Downloads


Anche aggiungendo la direttiva Alias prima non funziona.

Avatar utente
conraid
Staff
Staff
Messaggi: 13221
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: apashe e puntamento a directory in home

Messaggioda conraid » gio set 24, 2015 7:34

Non so se hai scritto male, ma deve essere
http://localhost/nomefile.php

Poi modifica anche la direttiva DocumentRoot, se non hai virtualhost configurati.

Io nella parte relativa alla document root ho questa configuzione

Codice: Seleziona tutto

DocumentRoot "/opt/dati/html/htdocs"
<Directory "/opt/dati/html/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>


Inoltre guarda se sta in ascolto su localhost

Codice: Seleziona tutto

Listen 127.0.0.1:80

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 201
Iscritto il: mar ott 30, 2012 11:17
Slackware: 14.0
Kernel: 3.2.9-smp
Desktop: fluxbox

Re: apashe e puntamento a directory in home

Messaggioda Linpassion » gio set 24, 2015 10:48

Bene ora tutto funziona! Non funzionava perche non avevo modificato il Documentroot di default, il mio codice lo precedeva. Ho detto una fesseria?