ATI proprietary drivers. Ecco uno SlackBuild !!!

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
submax82
Staff
Staff
Messaggi: 3202
Iscritto il: mer ago 31, 2005 0:00
Desktop: xfce
Distribuzione: SalixOS
Contatta:

Messaggioda submax82 » mer giu 20, 2007 14:06

Leddolo ha scritto:Salve a tutti!Prima di tutto voglio fare i miei complimenti a spina per l'ottimo lavoro che sta svolgendo ;)
Adesso passiamo alla mia situazione :D
Posseggo un ati xpress 200M, e il kernel precompilato 2.6.17.13. Avevo intenzione di installare i driver 8.32.5, poichè con le altre versioni in Ubuntu avevo avuto dei piccoli problemini, ma non so se è la stessa cosa...
C'è la possibilità di installare i driver fglrx con kernel 2.6.17.13?Grazie anticipamente e ciao!


certo che puoi installarli devi avere i sorgenti del kernel installati

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6469
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » mer giu 20, 2007 23:02

Leddolo ha scritto:...C'è la possibilità di installare i driver fglrx con kernel 2.6.17.13?Grazie anticipamente e ciao!


Provare non ti costa nulla, al più non ti compila. Se così fosse notificamelo che vedo di risolvere il problema ;).
Penso che tu abbia letto già la procedura per creare i pacchetti slackware dei driver ATI usando il mio build. Se non ti crea i pacchetti fammi sapere, se te li crea, molto probabilmente funzioneranno.

Spina

P.S. In ogni caso, posta la versione del server X che usi ok?

Avatar utente
Leddolo
Linux 1.0
Linux 1.0
Messaggi: 87
Iscritto il: mer gen 24, 2007 18:23
Località: Palermo
Contatta:

Messaggioda Leddolo » gio giu 21, 2007 20:25

Ho scaricato i driver 8.37.6 per la mia ati xpress 200M da questo link:
https://a248.e.akamai.net/f/674/9206/0/ ... x86_64.run
Ho scelto la versione 32, e non quella 64, dato che posseggo Slackware. Fin qui è giusto vero?Poi ho installato l'ultima versione del tuo tool e ho digitato da terminale:

Codice: Seleziona tutto

sh ati-driver-installer-8.37.6-x86.x86_64.run --buildpkg custom-package/Slackware

E l'output è il seguente:

Codice: Seleziona tutto

Created directory fglrx-install.wym71V
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.37.6..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: custom-package/Slackware
SlackBuild Ver. 1.1.0
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
 Assuming default VMAP API
 Assuming default munmap API
doing Makefile based build for kernel 2.6.x and higher
make -C /lib/modules/2.6.17.13/build SUBDIRS=/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.17.13'
  CC [M]  /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
In file included from /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:41,
                 from /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:334:
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/drmP.h:126:1: warning: "DRM_DEBUG_CODE" redefined
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:178:1: warning: this is the location of the previous definition
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:452: warning: initialization from incompatible pointer type
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `firegl_stub_open':
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:575: warning: assignment discards qualifiers from pointer target type
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `__ke_do_mmap':
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1885: warning: assignment makes pointer from integer without a cast
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function `KAS_ExecuteAtLevel':
/root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4756: warning: 'flags' might be used uninitialized in this function
  LD [M]  /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST
  CC      /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-2.6.17.13'
build succeeded with return value 0
duplicating results into driver repository...
done.
==============================
You must change your working directory to /root/Desktop/fglrx-install.wym71V/common/lib/modules/fglrx
and then call ./make_install.sh in order to install the built module.
==============================

Slackware package maker, version 2.1.

Searching for symbolic links:

No symbolic links were found, so we won't make an installation script.
You can make your own later in ./install/doinst.sh and rebuild the
package if you like.

This next step is optional - you can set the directories in your package
to some sane permissions. If any of the directories in your package have
special permissions, then DO NOT reset them here!

Would you like to reset all directory permissions to 755 (drwxr-xr-x) and
directory ownerships to root.root ([y]es, [n]o)? n


Creating tar file fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tar...

./
install/
install/doinst.sh
install/slack-desc
lib/
lib/modules/
lib/modules/2.6.17.13/
lib/modules/2.6.17.13/external/
lib/modules/2.6.17.13/external/fglrx.ko.gz
tar-1.13: fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tar is the archive; not dumped

Gzipping fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tar...

Renaming fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tar.gz to fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tgz...

Package creation complete.


Slackware package maker, version 2.1.

Searching for symbolic links:
usr/X11R6/lib/libGL.so.1 -> libGL.so.1.2
usr/X11R6/lib/libfglrx_dm.so.1 -> libfglrx_dm.so.1.0
usr/X11R6/lib/libfglrx_gamma.so.1 -> libfglrx_gamma.so.1.0
usr/X11R6/lib/libfglrx_pp.so.1 -> libfglrx_pp.so.1.0
usr/X11R6/lib/libfglrx_tvout.so.1 -> libfglrx_tvout.so.1.0

Making symbolic link creation script:
( cd usr/X11R6/lib ; rm -rf libGL.so.1 )
( cd usr/X11R6/lib ; ln -sf libGL.so.1.2 libGL.so.1 )
( cd usr/X11R6/lib ; rm -rf libfglrx_dm.so.1 )
( cd usr/X11R6/lib ; ln -sf libfglrx_dm.so.1.0 libfglrx_dm.so.1 )
( cd usr/X11R6/lib ; rm -rf libfglrx_gamma.so.1 )
( cd usr/X11R6/lib ; ln -sf libfglrx_gamma.so.1.0 libfglrx_gamma.so.1 )
( cd usr/X11R6/lib ; rm -rf libfglrx_pp.so.1 )
( cd usr/X11R6/lib ; ln -sf libfglrx_pp.so.1.0 libfglrx_pp.so.1 )
( cd usr/X11R6/lib ; rm -rf libfglrx_tvout.so.1 )
( cd usr/X11R6/lib ; ln -sf libfglrx_tvout.so.1.0 libfglrx_tvout.so.1 )

Unless your existing installation script already contains the code
to create these links, you should append these lines to your existing
install script. Now's your chance. :^)

Would you like to add this stuff to the existing install script and
remove the symbolic links ([y]es, [n]o)? y


Removing symbolic links:
removed `./usr/X11R6/lib/libGL.so.1'
removed `./usr/X11R6/lib/libfglrx_dm.so.1'
removed `./usr/X11R6/lib/libfglrx_gamma.so.1'
removed `./usr/X11R6/lib/libfglrx_pp.so.1'
removed `./usr/X11R6/lib/libfglrx_tvout.so.1'

Updating your ./install/doinst.sh...

This next step is optional - you can set the directories in your package
to some sane permissions. If any of the directories in your package have
special permissions, then DO NOT reset them here!

Would you like to reset all directory permissions to 755 (drwxr-xr-x) and
directory ownerships to root.root ([y]es, [n]o)? n


Creating tar file fglrx-x690-8.37.6-x86-1.tar...

./
install/
install/doinst.sh
install/slack-desc
usr/
usr/X11R6/
usr/X11R6/bin/
usr/X11R6/bin/fglrxinfo
usr/X11R6/bin/fglrx_xgamma
usr/X11R6/bin/aticonfig
usr/X11R6/bin/fgl_glxgears
usr/X11R6/bin/amdcccle
usr/X11R6/bin/fireglcontrolpanel
usr/X11R6/lib/
usr/X11R6/lib/libfglrx_tvout.a
usr/X11R6/lib/libGL.so.1.2
usr/X11R6/lib/modules/
usr/X11R6/lib/modules/dri/
usr/X11R6/lib/modules/dri/fglrx_dri.so
usr/X11R6/lib/modules/linux/
usr/X11R6/lib/modules/linux/libfglrxdrm.so
usr/X11R6/lib/modules/drivers/
usr/X11R6/lib/modules/drivers/fglrx_drv.so
usr/X11R6/lib/modules/glesx.so
usr/X11R6/lib/modules/esut.a
usr/X11R6/lib/libfglrx_tvout.so.1.0
usr/X11R6/lib/libfglrx_pp.so.1.0
usr/X11R6/lib/libfglrx_dm.a
usr/X11R6/lib/libfglrx_pp.a
usr/X11R6/lib/libfglrx_gamma.so.1.0
usr/X11R6/lib/libfglrx_dm.so.1.0
usr/X11R6/lib/libfglrx_gamma.a
usr/X11R6/include/
usr/X11R6/include/X11/
usr/X11R6/include/X11/extensions/
usr/X11R6/include/X11/extensions/fglrx_gamma.h
usr/sbin/
usr/sbin/atieventsd
usr/sbin/atigetsysteminfo.sh
usr/include/
usr/include/GL/
usr/include/GL/glxATI.h
usr/include/GL/glATI.h
usr/share/
usr/share/ati/
usr/share/ati/amdcccle/
usr/share/ati/amdcccle/amdcccle_nl_NL.qm
usr/share/ati/amdcccle/amdcccle_fr_FR.qm
usr/share/ati/amdcccle/amdcccle_ar_EG.qm
usr/share/ati/amdcccle/amdcccle_it_IT.qm
usr/share/ati/amdcccle/amdcccle_de.qm
usr/share/ati/amdcccle/amdcccle_cs.qm
usr/share/ati/amdcccle/amdcccle_he.qm
usr/share/ati/amdcccle/amdcccle_ja.qm
usr/share/ati/amdcccle/amdcccle_no.qm
usr/share/ati/amdcccle/amdcccle_pl.qm
usr/share/ati/amdcccle/amdcccle_th.qm
usr/share/ati/amdcccle/amdcccle_da_DK.qm
usr/share/ati/amdcccle/amdcccle_pt_BR.qm
usr/share/ati/amdcccle/amdcccle_sv_SE.qm
usr/share/ati/amdcccle/amdcccle_tr_TR.qm
usr/share/ati/amdcccle/amdcccle_el_GR.qm
usr/share/ati/amdcccle/amdcccle_ko_KR.qm
usr/share/ati/amdcccle/amdcccle_es_ES.qm
usr/share/ati/amdcccle/amdcccle_zh_CN.qm
usr/share/ati/amdcccle/amdcccle_zh_TW.qm
usr/share/ati/amdcccle/amdcccle_hu_HU.qm
usr/share/ati/amdcccle/amdcccle_fi_FI.qm
usr/share/ati/amdcccle/amdcccle_ru_RU.qm
usr/share/doc/
usr/share/doc/fglrx/
usr/share/doc/fglrx/ATI_LICENSE.TXT
usr/share/doc/fglrx/configure.html
usr/share/doc/fglrx/installer.html
usr/share/doc/fglrx/tips-linux.html
usr/share/doc/fglrx/user-manual/
usr/share/doc/fglrx/user-manual/index.html
usr/share/doc/fglrx/index.html
usr/share/doc/fglrx/LICENSE.xmlconfig
usr/share/doc/fglrx/LICENSE.expat
usr/share/doc/fglrx/driverfaq.html
usr/share/doc/fglrx/LICENSE.GPL
usr/share/doc/fglrx/LICENSE.QPL
usr/share/doc/fglrx/issues.html
usr/share/doc/fglrx/release-notes/
usr/share/doc/fglrx/release-notes/index.html
usr/share/doc/fglrx/release-notes/images/
usr/share/doc/fglrx/release-notes/images/724col.jpg
usr/share/doc/fglrx/release-notes/images/noboarder.gif
usr/share/doc/fglrx/release-notes/images/clipbrd.gif
usr/share/doc/fglrx/release-notes/images/backgrnd.gif
usr/share/doc/fglrx/release-notes/images/linux_10.gif
usr/share/doc/fglrx/release-notes/images/linux_82.gif
usr/share/doc/fglrx/release-notes/images/linux_83.gif
usr/share/doc/fglrx/release-notes/images/linux_84.gif
usr/share/doc/fglrx/release-notes/images/linux_85.gif
usr/share/doc/fglrx/release-notes/images/linux_86.gif
usr/share/doc/fglrx/release-notes/images/linux_87.gif
usr/share/doc/fglrx/release-notes/images/linux_88.gif
usr/share/doc/fglrx/release-notes/images/linux_89.gif
usr/share/doc/fglrx/release-notes/images/linux_8a.gif
usr/share/doc/fglrx/release-notes/images/caution.gif
usr/share/doc/fglrx/articles/
usr/share/doc/fglrx/articles/corruptvtswitch.html
usr/share/doc/fglrx/articles/4478.html
usr/share/doc/fglrx/articles/4479.html
usr/share/doc/fglrx/articles/4480.html
usr/share/doc/fglrx/articles/4481.html
usr/share/doc/fglrx/articles/4482.html
usr/share/doc/fglrx/articles/4483.html
usr/share/doc/fglrx/articles/4484.html
usr/share/doc/fglrx/articles/4485.html
usr/share/doc/fglrx/articles/xrestartpcie.html
usr/share/doc/fglrx/articles/secondheadcorruption.html
usr/share/doc/fglrx/articles/no3d-aiw8500dv.html
usr/share/doc/fglrx/articles/devshm.html
usr/share/doc/fglrx/articles/no3d-kt400.html
usr/share/doc/fglrx/articles/laptopsuspend.html
usr/share/doc/fglrx/articles/xvsatshift.html
usr/share/doc/fglrx/articles/pcie3dmemoryleak.html
usr/share/doc/fglrx/articles/r420blankdisplay.html
usr/share/doc/fglrx/articles/1gbhang.html
usr/share/doc/fglrx/articles/rv280dviblankdisplay.html
usr/share/doc/fglrx/articles/missingdrmheaders.html
usr/share/doc/fglrx/articles/corruptstereo.html
usr/share/doc/fglrx/articles/dualheadvideo.html
usr/share/doc/fglrx/articles/nomembercount.html
usr/share/doc/fglrx/articles/mousecursorhang.html
usr/share/doc/fglrx/articles/4461.html
usr/share/doc/fglrx/articles/4462.html
usr/share/doc/fglrx/articles/4463.html
usr/share/doc/fglrx/articles/doom3corrupt.html
usr/share/doc/fglrx/articles/4464.html
usr/share/doc/fglrx/articles/dga3dhang.html
usr/share/doc/fglrx/articles/4469.html
usr/share/doc/fglrx/articles/xf86_enodev.html
usr/share/doc/fglrx/articles/rv350springdale.html
usr/share/doc/fglrx/articles/4470.html
usr/share/doc/fglrx/articles/4475.html
usr/share/doc/fglrx/examples/
usr/share/doc/fglrx/examples/etc/
usr/share/doc/fglrx/examples/etc/acpi/
usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh
usr/share/doc/fglrx/examples/etc/acpi/events/
usr/share/doc/fglrx/examples/etc/acpi/events/a-ac-aticonfig
usr/share/doc/fglrx/examples/etc/acpi/events/a-lid-aticonfig
usr/share/doc/fglrx/examples/etc/init.d/
usr/share/doc/fglrx/examples/etc/init.d/atieventsd.sh
usr/share/doc/fglrx/linuxfaq.html
usr/share/man/
usr/share/man/man8/
usr/share/man/man8/atieventsd.8.gz
usr/share/gnome/
usr/share/gnome/apps/
usr/share/gnome/apps/amdcccle.desktop
usr/share/icons/
usr/share/icons/ccc_small.xpm
usr/share/icons/ccc_large.xpm
usr/share/applnk/
usr/share/applnk/amdcccle.kdelnk
usr/src/
usr/src/ati/
usr/src/ati/fglrx_sample_source.tgz
usr/src/ati/fglrx_panel_sources.tgz
usr/opt/
usr/opt/kde3/
usr/opt/kde3/share/
usr/opt/kde3/share/applnk/
usr/opt/kde3/share/applnk/amdcccle_kde3.desktop
tar-1.13: fglrx-x690-8.37.6-x86-1.tar is the archive; not dumped

Gzipping fglrx-x690-8.37.6-x86-1.tar...

Renaming fglrx-x690-8.37.6-x86-1.tar.gz to fglrx-x690-8.37.6-x86-1.tgz...

Package creation complete.

Removing temporary directory: fglrx-install.wym71V

Mi ha creato due pacchetti di nome "fglrx-x690-8.37.6-x86-1.tgz" e "fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tgz". Che dite vado per l'installazione!Grazie ancora e ciao!!!

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6469
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » ven giu 22, 2007 0:13

Leddolo ha scritto:...Mi ha creato due pacchetti di nome "fglrx-x690-8.37.6-x86-1.tgz" e "fglrx-module-8.37.6-x86-1_kernel_2.6.17.13.tgz". Che dite vado per l'installazione!Grazie ancora e ciao!!!...


Ok, installa pure. Poi ricordati che devi modificare il file xorg.conf in modo che usi il driver fglrx. comunque, se leggi qui, vedrai che trovi tutte le risposte.
In particolare, per la versione dei driver che hai scaricato, non era necessario installare il mio build, è già incluso nei driver.

Fammi sapere,
Spina

Avatar utente
Leddolo
Linux 1.0
Linux 1.0
Messaggi: 87
Iscritto il: mer gen 24, 2007 18:23
Località: Palermo
Contatta:

Messaggioda Leddolo » ven giu 22, 2007 1:32

Grande funziona tutto!
glxinfo | grep rendering da come ouput "Yes" e fglrxinfo "ati" ed etc etc :D
Come risoluzione ho impostato 1280*800, e dato che i caratteri si vedevano abbastanza piccoli, li ho modificati dal centro di controllo. Per caso ho sbagliato?Oppure bisognava modificarli da qualche rigadello xorg.conf?Grazie ancora e ciao!

P.S. Non funziona la rotellina del mouse...

Avatar utente
absinthe
Iper Master
Iper Master
Messaggi: 2354
Iscritto il: dom mag 15, 2005 0:00
Nome Cognome: Matteo Nunziati
Slackware: 12.1 - defunct
Kernel: 2.6.32-5-amd64
Desktop: gnome
Distribuzione: debian squeeze
Località: Prato
Contatta:

Messaggioda absinthe » ven giu 22, 2007 10:04

Leddolo ha scritto:P.S. Non funziona la rotellina del mouse...

RTFM ovvero leggi S4D!!!! :evil:

;)
M

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6469
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » ven giu 22, 2007 20:36

absinthe ha scritto:
Leddolo ha scritto:P.S. Non funziona la rotellina del mouse...

RTFM ovvero leggi S4D!!!! :evil:

;)
M


Bhé, in effetti la rotellina del mouse non è legata ai driver ATI (normalmente). Per i caratteri, come per ogni altra cosa, ci sono sempre più soluzioni per lo stesso problema, l'importante è che se ne capisca alemeno una ;)!!!

Spina

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6469
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » mar lug 03, 2007 23:54

Ciao,
ho messo il nuovo buil online, lo trovate qui:
http://www.cli.di.unipi.it/~tomasi/ati- ... arch-1.tgz

Non cambia molto con l'ultimo, semplicemente assicura che solo l'utente root abbia i permessi per lanciare amdcccle e fireglcontrolpanel.

Sembra che nella prossima versione dei driver dovrebbero essere sistemati molti segfault relativi proprio a amdcccle.

Ricordo che i driver della ATI contengono già il build, questo che metto on-line contiene solo delle patch che non ho incluso in quello della ATI. Come ad esempio la patch per la compilazione del modulo per il kernel 2.6.22 con arch a 64 bit.

Spina

P.S. Per un resoconto veloce su come installare il build e tutto quanto si veda:
http://www.slacky.eu/forum/viewtopic.ph ... 173#144173

gianogli
Linux 2.0
Linux 2.0
Messaggi: 137
Iscritto il: mer feb 02, 2005 0:00
Località: Brusnengo (BI)

Messaggioda gianogli » sab lug 07, 2007 10:27

spina ha scritto:Ciao,
ho messo il nuovo buil online, lo trovate qui:
http://www.cli.di.unipi.it/~tomasi/ati- ... arch-1.tgz
...
Spina



Per vedere quando esce la versione nuova del tuo pacchetto devo sempre controllare questo thread e ogni tanto me ne perdo un pezzo... :-( (Ad esempio utilizzo ancora la 1.0.9).
C'e' un sito di riferimento dove e' possibile vedere gli aggiornamenti e scaricare il pacchetto direttamente?

Grazie mille...
GiAn

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6469
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

Messaggioda targzeta » sab lug 07, 2007 14:38

gianogli ha scritto:..C'e' un sito di riferimento dove e' possibile vedere gli aggiornamenti e scaricare il pacchetto direttamente?...


Al momento no, ma provvederò, ho in mente anche di scrivere un wiki qui su slacky e anche in versione inglese su http://wiki.cchtml.com/index.php/Main_Page
il sito non ufficiale dei driver ATI per linux.

Quando finisco lo segnalo in questo thread. Fino a quel momento, se per te va bene, ti segnalerò ogni cambiamento con un messaggio privato.

Spina

Avatar utente
targzeta
Iper Master
Iper Master
Messaggi: 6469
Iscritto il: gio nov 03, 2005 14:05
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM
Località: Carpignano Sal. (LE) <-> Pisa

La ATI e,....un altra delle sue

Messaggioda targzeta » sab lug 21, 2007 5:27

Ciao ragazzi,
non so se qualcuno di voi se ne è accorto. La ATI ieri ha rilasciato l'ultima versione dei driver ufficiali fglrx, la 8.39.4....oggi la ritirata :).
Infatti la versione rilasciata era bacata, in pratica conteneva una "Watermark", ovvero un piccolo quadratino trasparente nell'angolino in basso a destra. Questo watermark dovrebbe essere presente solo nelle beta release ed invece compariva anche nella release ufficiale. Questi della ATI sono proprio biricchini, col fatto che vogliono fare tutto di nascosto fanno delle gaff da premio nobel.
In effetti il watermark non compare se installi i driver lanciando il .run in maniera canonica, succede solo se lo si lancia con l'opzione --buildpkg per creare i pacchetti delle varie distro. Io penso che non abbiano voluto farci sapere niente, altrimenti anche nelle beta release elimineremmo il watermark (che è molto fastidioso).

Vedremo come andrà a finire,
Spina

P.S. Sono simpatici anche perchè non ci avvisano mai quando rilasciano i driver, li rilasciano e basta. Magari qualcuno ha correzioni da fare sul packaging script per la propria disto, macché, lo farà un altra volta....bha?

Avatar utente
ekxius
Linux 2.6
Linux 2.6
Messaggi: 831
Iscritto il: sab mar 18, 2006 11:01
Slackware: 12.0
Kernel: 2.6.23.12
Desktop: KDE 3.5.9
Località: Casa <-> Torino <-> Aosta
Contatta:

Messaggioda ekxius » dom lug 22, 2007 23:41

no comment :shock:

LaZyBoY
Linux 2.0
Linux 2.0
Messaggi: 153
Iscritto il: mar mar 14, 2006 21:43

Messaggioda LaZyBoY » lun lug 23, 2007 10:07

spina non so se conosci questo forum: http://www.phoronix.com/forums/forumdisplay.php?f=15
comunque ho letto che stanno sviluppando dei driver open (avivo si chiamano) anche per le nostre schede della serie X1000.
Per ora è ancora in fase embrionale (tipo un vesa poco piu evoluto), ma promette grandi cose, speriamo!!!
http://www.phoronix.com/forums/showthread.php?t=4013

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3968
Iscritto il: lun apr 25, 2005 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggioda Paoletta » lun lug 23, 2007 10:17

io i driver ati proprietari non li uso, mi trovo benissimo con quelli open...

LaZyBoY
Linux 2.0
Linux 2.0
Messaggi: 153
Iscritto il: mar mar 14, 2006 21:43

Messaggioda LaZyBoY » lun lug 23, 2007 11:13

Paoletta ha scritto:io i driver ati proprietari non li uso, mi trovo benissimo con quelli open...


Se solo supportassero le schede della serie X1000 li userei anche io volentieri :D