Repository 32bit  Forum
Repository 64bit  Wiki

ancora sui packages

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

ancora sui packages

Messaggioda kens » lun ott 04, 2004 18:45

Non riesco ad installare con "installpkg" i pacchetti prelevati dal repository di Slacky, mentre se scarico da linuxpackages.net è tutto ok. Credo sia un problema di formato (solitamente estraggo i files con "karc" da kde). <BR>Riporto a titolo di esempio cosa dice la shell a proposito del recentissimo "kaffeine": <BR> <BR>bash-2.05b# ls -l <BR>total 4072 <BR>-rw-r--r-- 1 nicola root 1468578 2004-10-04 19:23 kaffeine-0.4.3b-i486-1.tgz <BR>-rw-r--r-- 1 nicola root 1822720 2004-10-04 19:26 kaffeine-0.5rc1-i486-1sl.tgz <BR> <BR>bash-2.05b# file kaffeine-0.4.3b-i486-1.tgz <BR>kaffeine-0.4.3b-i486-1.tgz: gzip compressed data, was "kaffeine-0.4.3b-i486-1.tar", from Unix, max compression <BR> <BR>bash-2.05b# file kaffeine-0.5rc1-i486-1sl.tgz <BR>kaffeine-0.5rc1-i486-1sl.tgz: POSIX tar archive <BR> <BR>Credo che sia per quello che il mio: <BR>bash-2.05b# installpkg kaffeine-0.5rc1-i486-1sl.tgz <BR>fallisce e bash risponde: <BR>Cannot install kaffeine-0.5rc1-i486-1sl.tgz: package is corrupt (failed ´gzip -l kaffeine-0.5rc1-i486-1sl.tgz´) <BR> <BR>rimedi? ;-) <BR><br>
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

ancora sui packages

Messaggioda Loris » lun ott 04, 2004 19:28

Il CHECKSUMS.md5 che dice ?<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7589
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

ancora sui packages

Messaggioda kens » lun ott 04, 2004 19:39

come si fa a controllarlo? :-) (ma c´entra visto che bash dice che in effetti il package è un tar?)<br>
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

ancora sui packages

Messaggioda Loris » lun ott 04, 2004 20:35

md5sum --check CHECKSUMS.md5 in ogni caso dice "package is corrupt" prova a verificare md5 e poi vediamo.<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7589
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

ancora sui packages

Messaggioda kens » lun ott 04, 2004 21:25

bash-2.05b# md5sum --check CHECKSUMS.md5 <BR>kaffeine-0.5rc1-i486-1sl.tgz: FAILED <BR>kaffeine-0.5rc1-i486-1sl.txt: OK <BR>md5sum: WARNING: 1 of 2 computed checksums did NOT match <BR> <BR> <BR> <BR>Interessante, no? Ma non può essere un problema di corruzione durante il download: l´avrò ripetuto 100 volte e poi da linuxpackages funziona sempre...<br>
Avatar utente
kens
Linux 2.4
Linux 2.4
 
Messaggi: 208
Iscritto il: sab giu 05, 2004 23:00
Slackware: 12.2
Kernel: 2.6.27.7-smp
Desktop: KDE

ancora sui packages

Messaggioda Loris » lun ott 04, 2004 21:37

sh-2.05b$ md5sum --check CHECKSUMS.md5 <BR>kaffeine-0.5rc1-i486-1sl.tgz: OK <BR>kaffeine-0.5rc1-i486-1sl.txt: OK <BR> <BR>Altri possono provare ? e magari dirci se riscontrano problemi ? <BR> <BR>Grazie :) <br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7589
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

ancora sui packages

Messaggioda useless » lun ott 04, 2004 21:40

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>unholycathedral ~ # swaret --install kaffeine <BR>swaret 1.6.2-1 <BR> <BR>Listing available Packages matching Keyword: kaffeine... <BR>kaffeine-0.5rc1-i486-1sl (853 kB) (Slacky.it) <BR> <BR>Install kaffeine-0.5rc1-i486-1sl (Slacky.it)? (y/n/A/Q): [y] <BR>[ <a href="http://www.slacky.it/download" target="_blank" target="_new">http://www.slacky.it/download</a> ] <BR>### Fetching kaffeine-0.5rc1-i486-1sl (853 kB)... <BR>--- 853 kB/853 kB [TOTAL: 853 kB/853 kB] ~ 77 kB/s DONE! <BR>=> <MD5CHECK> MD5 for Package kaffeine-0.5rc1-i486-1sl OK! <BR>=> kaffeine-0.5rc1-i486-1sl has been saved in: /var/swaret/current/repos/Slacky.it! <BR>=> Installing kaffeine-0.5rc1-i486-1sl... <BR>Installing package kaffeine-0.5rc1-i486-1sl... <BR>PACKAGE DESCRIPTION: <BR>kaffeine: Kaffeine (xine based media player for KDE3) <BR>kaffeine: <BR>kaffeine: Xine is a free multimedia player. It plays back CDs, DVDs, and VCDs. <BR>kaffeine: It also decodes multimedia files like AVI, MOV, WMV, and MP3 from <BR>kaffeine: local disk drives, and displays multimedia streamed over the Internet. <BR>kaffeine: It interprets many of the most common multimedia formats available <BR>kaffeine: - and some of the most uncommon formats, too. <BR>kaffeine: <BR>kaffeine: Packages By http://www.slacky.it <BR>Executing install script for kaffeine-0.5rc1-i486-1sl... <BR> <BR> <BR>================================================ <BR> <BR>Attention please required xine-lib 1.0rc4 <BR>and KDE 3.2.x <BR> <BR>================================================ <BR> <BR> <BR> <BR>INFORMATION: Set DEPENDENCY to 0 in /etc/swaret.conf <BR> to disable Dependency Support. <BR> <BR>%%% Verifying Dependencies... Libraries resolved successfully! <BR> <BR>unholycathedral ~ </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --><br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti