Pagina 8 di 37

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: ven giu 13, 2008 13:59
da submax82
c'è un un'errore nello slack-required ... sistemo subito e lo uppo

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: ven giu 13, 2008 16:05
da tigerwalk
ho provato, installa tutto senza problemi ma il programma non si apre. Da terminale mi da i seguenti errori

Codice: Seleziona tutto

/opt/openoffice.org2.4/program/soffice: line 237: /opt/openoffice.org2.4/program/pagein: No such file or directory
/opt/openoffice.org2.4/program/soffice.bin: error while loading shared libraries: libstlport_gcc.so: cannot open shared object file: No such file or directory

Ho notato che in /opt/openoffice.org2.4/program/ mancano tutti i file pagein ed anche soffice.

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: ven giu 13, 2008 20:49
da tigerwalk
Ho provato a scaricare il pacchetto dal 7° mirror invece che dal 1° ed il problema si è risolto!

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: ven giu 13, 2008 21:43
da submax82
tigerwalk ha scritto:Ho provato a scaricare il pacchetto dal 7° mirror invece che dal 1° ed il problema si è risolto!


a ecco !!! mi sembrava strano... grazie della segnalazione, magari capita ad altri ;)

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: sab giu 14, 2008 9:48
da aschenaz
Upgradato stamattina, dal mirror 1: tutto ok, veloce e indolore! :thumbright:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: dom giu 15, 2008 16:09
da tigerwalk
L' autobuilder è semplicemente eccezionale! ;)

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: dom giu 15, 2008 17:27
da submax82
8) 8) 8) eccezzzzziunalu veramente 8) 8) 8)

:lol: :lol: :lol:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: mar giu 17, 2008 0:24
da submax82
come và con slapt-get/swaret ? qualcuno ha provato?

se usate slpat-get/swaret è buona norma rimuovere l'autobuilder dopo che ha creato e installato il pacchetto di openoffice, questo perchè quando aggiornate, aggiorna anche l'autobuilder e riparte la costruzione...

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: mar giu 17, 2008 17:33
da tigerwalk
submax82 ha scritto:come và con slapt-get/swaret ? qualcuno ha provato?

se usate slpat-get/swaret è buona norma rimuovere l'autobuilder dopo che ha creato e installato il pacchetto di openoffice, questo perchè quando aggiornate, aggiorna anche l'autobuilder e riparte la costruzione...

Non li uso ma, buono a sapersi....! :)

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: ven giu 20, 2008 22:07
da Trotto@81
Ma se voglio aggiornare openoffice basta fare l'upgrade dell'autobuilder e aggiorna in automatico il anche package?

EDIT: Ho provato ad aggiornare ma mi da subito questo dopo l'upgradepkg.

Codice: Seleziona tutto

+==============================================================================
| Upgrading openoffice-autobuilder-multilang-2.4.0-i586-3sm package using ./openoffice-autobuilder-multilang-2.4.1-i586-5sm.tgz
+==============================================================================

Pre-installing package openoffice-autobuilder-multilang-2.4.1-i586-5sm...
choice n.:
choice n.:

Com'è possibile??
Questo package mi st afacendo dannare!!
Ma non mi doveva fare scegliere nuovamente la lingua e il resto?
Ho interrotto il tutto con ctrl-c perchè giustamente non sapevo che scegliere e se controllo i package installati con ls /var/log/packages/ | grep open
mi resistuisce
openoffice-autobuilder-multilang-2.4.0-i586-3sm-upgraded-2008-06-20,22:27:58
openoffice-autobuilder-multilang-2.4.1-i586-5sm

Ho provato ad eliminare l'ultimo builder ma naturalmente mi dice questo:

Codice: Seleziona tutto

Removing package /var/log/packages/openoffice-autobuilder-multilang-2.4.1-i586-5sm...
Removing files:
  --> /install/doinst.sh was found in another package. Skipping.
  --> /install/slack-desc was found in another package. Skipping.
  --> /install/slack-required was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/doinst.sh.gz was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/isocodes was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/languages was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/mirrors was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/openoffice-multilang.SlackBuild was found in another package. Skipping.
  --> /usr/src/openoffice-autobuilder-multilang/builder/slack-desc was found in another package. Skipping

Come mi devo comportare ora?

POSTEDIT: Ho eliminato a mano anche il builder del 2.4.0 e ho dovuto eliminare a mano anche il package del 2.4.0 e ora sto reinstallando il builder 2.4.1.
Perchè non mi ha consentito l'aggiornamento?
Ma se elimino il builder perchè non rimuove anche il package annesso?
Sempre per quanto riguarda la puliza del sistema da file svolazzanti la cosa dovrebbe essere tranquilla vero?
Io ci tengo ad avere ogni singolo file del mio sistema tracciato da pkgtool. :)

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: sab giu 21, 2008 4:09
da submax82
è normale se aggiorni l'autobuilder devi dare

Codice: Seleziona tutto

upgradepkg --verbose --install-new openoffice-autobuilder-multilang-*.tgz


Ma se elimino il builder perchè non rimuove anche il package annesso?

l'autobuilder è un pacchetto mentre il vero openoffice-lang è un'altro... non sono connessi... comunque quando crea il pacchetto della nuova versione di openoffice la aggiorna senza problemi, non hai bisogno di rimuovere la vecchia.

Sempre per quanto riguarda la puliza del sistema da file svolazzanti la cosa dovrebbe essere tranquilla vero?


gli unici file tracciati dall'autobuilder sono sotto /usr/src/openoffice-autobuilder-multilang/

quando l'autobuilder ha finito tutto e installato/aggiornato openoffice ripulisci tmp con

Codice: Seleziona tutto

rm -rf /tmp/tgz/*


e sei a posto, tutti file sono tracciati ;)

p.s.: anche io ho la stessa fissa che tutto sia tracciato dai pkgtools, non installo mai nulla con il metodo classico del "make install" proprio per questo :thumbright:

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: sab giu 21, 2008 8:37
da Trotto@81
[quote="submax82"]è normale se aggiorni l'autobuilder devi dare

Codice: Seleziona tutto

upgradepkg --verbose --install-new openoffice-autobuilder-multilang-*.tgz


Ah ecco!! Non sapevo si dovesse passare anche questa opzione.
Grazie mille come sempre per la tua infinita pazienza. :)

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: sab giu 21, 2008 14:35
da submax82
Trotto@81 ha scritto:
submax82 ha scritto:è normale se aggiorni l'autobuilder devi dare

Codice: Seleziona tutto

upgradepkg --verbose --install-new openoffice-autobuilder-multilang-*.tgz


Ah ecco!! Non sapevo si dovesse passare anche questa opzione.
Grazie mille come sempre per la tua infinita pazienza. :)


sono io che devo ringraziarti, perchè grazie alle tue osservazioni e feedback sono riuscito a migliorare il builder ;)

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: gio lug 03, 2008 23:51
da Codemaster71
Ragazzi io ho slackware 12 e nei repository l'autobuilder per lo stesso non funziona... Posso usare tranquillamente quello del 12.1 sulla mia slack o avrei problemi?

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Inviato: ven lug 04, 2008 12:34
da submax82
Codemaster71 ha scritto:Ragazzi io ho slackware 12 e nei repository l'autobuilder per lo stesso non funziona... Posso usare tranquillamente quello del 12.1 sulla mia slack o avrei problemi?


si anzi devi perchè il più recente ed è stato migliorato.