Repository 32bit  Forum
Repository 64bit  Wiki

Open/Libre-Office autobuilder segnalazioni e problemi

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda omar » lun lug 07, 2008 11:08

E' capitato a qualcuno di installare l'ultimo Open Office con l'autobuilder
di Slacky e avere dei caratteri stranissimi sui menu?
Ho Slackware 12.1 e Open Office 2.4.1 scaricato ieri (italiano). Dopo
l'installazione avvio i vari programmi e tutti i menu e le etichette
sembrano scritte in italiano ma con caratteri tipo greco (alfa, beta,
etc...).
Per inciso, se scrivo del testo scrivo normalmente; se apro il menu a tendina dei caratteri li vedo correttamente, poi quando ne scelgo uno me lo mostra sempre in pseudo-greco...
Qualcuno ha dei suggerimenti?

Grazie Omar
omar
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: ven ott 27, 2006 7:06

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » lun lug 07, 2008 12:29

forse hai scaricato l'achivio danneggiato da un mirror... prova a rifare rieseguire il rebuild pulendo prima la tmp in modo che riscarichi il pacchetto.

questo problemi sono relativi al download di openoffice solitamente, difficilmente il problema è nell'autobuild, più avanti inserirò se si può il controllo dell'md5
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda omar » mer lug 09, 2008 12:43

Purtroppo sono sempre + convinto che il problema sia del mio pc...
Dopo aver tentato il download da diversi siti, cancellando i file delle installazioni precedenti, il risultato è il medesimo. Ho ripetuto l'operazione con almeno 4 siti diversi.
Ho anche tentato l'installazione del tgz in inglese da linuxpackages: niente da fare, menu ed etichette in inglese ma sempre con i caratteri dell'alfabeto greco.
Non so + dove sbattere la testa... devo disinstallare qualche altro pacchetto del mio pc?

Grazie, Omar
omar
Linux 1.0
Linux 1.0
 
Messaggi: 6
Iscritto il: ven ott 27, 2006 7:06

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » mer lug 09, 2008 22:44

mmm... sicuramente c'è qualcosa sul tuo sistema...prova con un banale:

Codice: Seleziona tutto
rm -rf ~/.openoffice.org2
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda aLvArO » mar ago 26, 2008 10:39

a me il pacchetto non va.
mi da questo errore.
Codice: Seleziona tutto
Start building...:
- clean necessary after old run
- extract and copy rpm, wait...
mv: impossibile fare stat di `opt': No such file or directory
mv: impossibile fare stat di `usr': No such file or directory
- add menu entry
cp: impossibile fare stat di `/tmp/tgz/package-openoffice/opt/openoffice.org2.4/share/xdg/*.desktop': No such file or directory
./openoffice-multilang.SlackBuild: line 188: cd: /tmp/tgz/package-openoffice/usr/share/applications: No such file or directory
ls: impossibile accedere a *.desktop: No such file or directory
- manage run file
./openoffice-multilang.SlackBuild: line 196: cd: /tmp/tgz/package-openoffice/usr/bin: No such file or directory
sed: impossibile leggere openoffice.org2.4: No such file or directory
sed: impossibile leggere openoffice.org2.4-printeradmin: No such file or directory
ln: creating symbolic link `/tmp/tgz/package-openoffice/usr/bin/soffice': No such file or directory
ln: creating symbolic link `/tmp/tgz/package-openoffice/usr/bin/spadmin': No such file or directory
- add documentation
./openoffice-multilang.SlackBuild: line 208: cd: /tmp/tgz/package-openoffice/opt/openoffice.org2.4: No such file or directory
cp: impossibile fare stat di `LICENSE*': No such file or directory
cp: impossibile fare stat di `README*': No such file or directory
cp: impossibile fare stat di `THIRDPARTYLICENSEREADME.html': No such file or directory
./openoffice-multilang.SlackBuild: line 211: cd: /tmp/tgz/package-openoffice/opt/openoffice.org2.4/share/readme/: No such file or directory
cp: impossibile fare stat di `LICENSE_it*': No such file or directory
cp: impossibile fare stat di `README_it*': No such file or directory
- insert slack install files
- build package, wait...
- your package is saved on /tmp/tgz
- make files checksum and desc
build done.
Cleaning...:
clean done.
all done. bye ;)
Avatar utente
aLvArO
Linux 3.x
Linux 3.x
 
Messaggi: 1201
Iscritto il: mar mar 29, 2005 23:00
Località: Catanzaro Lido (CZ)
Nome Cognome: alessio
Slackware: current64
Kernel: 2.6.30-rc8-smp
Desktop: kde 4.2.4

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » mar ago 26, 2008 15:29

utilizzi l'ultima versione?

hai installato tutti i pacchetti indicati nello slack-required ? a naso ti manca qualche dipendenza...
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda aLvArO » mer ago 27, 2008 11:30

come non detto.
mi mancava il pacchetto rpm anche se mi sembra strano.
devo averlo deselezionato durante l'installazione mentre scartavo qualche altro pacchetto.
Avatar utente
aLvArO
Linux 3.x
Linux 3.x
 
Messaggi: 1201
Iscritto il: mar mar 29, 2005 23:00
Località: Catanzaro Lido (CZ)
Nome Cognome: alessio
Slackware: current64
Kernel: 2.6.30-rc8-smp
Desktop: kde 4.2.4

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » mer ago 27, 2008 18:15

ok perfetto ;)
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda Loris » mer ago 27, 2008 18:59

Submax82 la prossima versione è meglio mettere un controllo sul pacchetto rpm, aLvArO non è il primo ;)
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7593
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda aschenaz » mer set 10, 2008 13:49

pensieriemotivi.aschenaz.eu - music-blog
Avatar utente
aschenaz
Staff
Staff
 
Messaggi: 4438
Iscritto il: mar lug 27, 2004 23:00
Località: Reggio Calabria
Nome Cognome: Nino
Slackware: current 64bit
Kernel: 3.14.24
Desktop: KDE 4.10.5

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » mer set 10, 2008 20:39

aschenaz ha scritto:E' uscita la rc1 di OO 3.0!!!

http://download.openoffice.org/680/?intcmp=1461


lo sto preparando ma rilascerò il nuovo builder solo quando uscirà la 3.0 stabile
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » gio set 11, 2008 11:18

sul mio sito trovate il builder per la nuova versione 3.0.0rc1, ho fatto alcune modifiche al builder quindi spero funzioni tutto

su slacky verrà pubblicato il builder per la 3.0 stabile appena uscirà ;) a meno che Loris decida diversamente :roll:
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda Trotto@81 » gio set 11, 2008 14:15

La rc1 è solo in inglese?
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3043
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda submax82 » gio set 11, 2008 22:04

Trotto@81 ha scritto:La rc1 è solo in inglese?


no... c'è anche in altre lingue comprese l'italiano, altrimenti visto che il pacchetto si chiama multilang non l'avrei neanche fatto.
Avatar utente
submax82
Staff
Staff
 
Messaggi: 3202
Iscritto il: mar ago 30, 2005 23:00
Desktop: xfce
Distribuzione: SalixOS

Re: Openoffice-autobuilder segnalazioni e malfunzionamenti

Messaggioda Trotto@81 » ven set 12, 2008 15:36

Ho fatto l'upgrade dell'autobuilder per passare al 3, ma ha aggiornato solo l'autobuilder e non openoffice.
Ho passato solo l'opzione "--verbose" perchè altrimenti non mi faceva scegliere la lingua, senza "--install-new" visto che il pacchetto del 2.4 era presente e volevo evitare accavallamenti.
Inoltre dopo che ha creato il package è ripartito lo script dell'autobuilder che ho interrotto con crtl-c.
Ho rimosso l'autobuilder del 3, il pacchetto del 2.4 e installato il pacchetto a mano che mi aveva creato in /tmp/tgz.
Non doveva essere tuttp facile e indolore?
Avevi detto che in caso di upgradepkg avrebbe provveduto da solo lo script a fare l'upgrade anche del pacchetto applicazione e così non è stato.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3043
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

PrecedenteProssimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron