Repository 32bit  Forum
Repository 64bit  Wiki

checkinstall

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

checkinstall

Messaggioda goldy » sab ott 23, 2004 18:20

Ho scaricato da questo sito checkinstall , quando provo a creare il pacchetto dopo il make ricevo questo errore <BR> <BR>checkinstall 1.6.0beta3, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran <BR> This software is released under the GNU GPL. <BR> <BR> <BR>The package documentation directory ./doc-pak does not exist. <BR>Should I create a default set of package docs? [y]: y <BR> <BR>Preparing package documentation...OK <BR> <BR>Please write a description for the package. <BR>End your description with an empty line or EOF. <BR>>> <BR> <BR>This package will be built according to these values: <BR> <BR>1 - Summary: [ Package created with checkinstall 1.6.0beta3 ] <BR>2 - Name: [ kommander ] <BR>3 - Version: [ 1.0 ] <BR>4 - Release: [ 1 ] <BR>5 - License: [ GPL ] <BR>6 - Group: [ ] <BR>7 - Architecture: [ i386 ] <BR>8 - Source location: [ kommander-1.0 ] <BR>9 - Alternate source location: [ ] <BR> <BR>Enter a number to change any of them or press ENTER to continue: <BR> <BR>Installing with make install... <BR> <BR>========================= Installation results =========================== <BR>/usr/bin/installwatch: line 345: 22741 Segmentation fault $@ <BR> <BR>**** Installation failed. Aborting package creation. <BR> <BR>Cleaning up...OK <BR> <BR>Bye. <BR> <BR> <BR>Nella linea 345 di installwatch è scritto questo <BR> <BR>echo "debug: INSTW_LOGFILE=${INSTW_LOGFILE}" <BR> <BR> <BR>Specifico che se provo a creare il pacchetto con lo slackbuilds tutto va bene. <BR> <BR>Da cosa può dipendere questo errore? <BR> <BR><br>
Avatar utente
goldy
Packager
Packager
 
Messaggi: 1267
Iscritto il: dom mag 02, 2004 23:00
Località: Bologna
Slackware: Current
Kernel: 2.6.26.5
Desktop: KDE 3.5.10

checkinstall

Messaggioda samiel » sab ott 23, 2004 18:52

Dammi un po´ di tempo <BR>che ho pure amici a cena <BR>e verifico il funzionamento del pacchetto <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

checkinstall

Messaggioda samiel » dom ott 24, 2004 10:21

In effetti checkinstall sembra avere dei problemi, <BR>ma non quella segmentation fault. Prova a ricompilare <BR>checkinstall stesso dai sorgenti con lo slackbuild. <BR>Al momento della compilazione dei programmi poi <BR>prova a passare l´opzione <BR>checkinstall --fstrans=no --install=yes <BR>Intanto continuo a vedere che guai può avere il pacchetto... <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

checkinstall

Messaggioda goldy » dom ott 24, 2004 13:46

Samiel , niente da fare ricevo sempre lo stesso erroe , tra l´altro ho anche provato a compilare il checkinstall originale (non patchato per Slack) , e il problema rimane. <BR>Credo a questo punto che sia un problema nel mio sistema ,non nella patch. <BR>Comunque se hai dei consigli . li accetto volentieri<br>
Avatar utente
goldy
Packager
Packager
 
Messaggi: 1267
Iscritto il: dom mag 02, 2004 23:00
Località: Bologna
Slackware: Current
Kernel: 2.6.26.5
Desktop: KDE 3.5.10

checkinstall

Messaggioda samiel » dom ott 24, 2004 16:25

Mah, io credo che sia un problema di checkinstall... <BR>Nella home page si legge: <BR>There seems to be a bug in the filesystem translation code which seems to be biting people using newer versions of glibc found in most recent linux distributions. It is being worked on. In the meantime you can work around it by disabling the fs translation code and forcing checkinstall to install the package: <BR>checkinstall --fstrans=no --install=yes. <BR>E forse c´è anche qualche altro bug... <BR>comunque sia io sia Lorys stiamo dando un´occhiata. <BR>Ti sapremo dire <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian


Torna a Packages

Chi c’è in linea

Visitano il forum: nyquist e 1 ospite