Repository 32bit  Forum
Repository 64bit  Wiki

Problemi con i pacchetti di Slacky.it

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi con i pacchetti di Slacky.it

Messaggioda wally » dom ott 31, 2004 20:13

Ciao, <BR>ho riscontrato qualche leggero problema con i packages di questo sito. <BR>Dopo aver scaricato il pacchetto, dato che termina con .gz, lo scomprimo con gunzip, e poi lancio installpkg <BR>ma questo mi lascia il seguente messaggio: <BR> <BR>Cannot install parted-1.6.15-i486-1sn.tgz: package is corrupt (failed ´gzip -l parted-1.6.15-i486-1sm.tgz´) <BR> <BR>Se invece ripeto la cosa prima di estrarre con gunzip, non riesco a far nulla perchè mi indica che il file non e´ un package valido. <BR>Oltretutto il tgz finale non lo aprono neppure Ark e FileRoller, cioè, lo aprono, creano la directory per estrarre, ma non estraggono nulla... <BR> <BR>che fare???? :-[ <BR> <BR>Grazie :-)<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

Problemi con i pacchetti di Slacky.it

Messaggioda zevin » dom ott 31, 2004 20:39

Con i packages .tgz per slackware devi solamente portarti nella directory del pacchetto da installare e, da root, dare installpkg se vuoi installare un nuovo pacchetto oppure upgradepkg se vuoi aggiornarne uno preesistente. Semplicissimo!<br>
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Problemi con i pacchetti di Slacky.it

Messaggioda zevin » dom ott 31, 2004 20:40

Usi slackware, vero?<br>
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Problemi con i pacchetti di Slacky.it

Messaggioda wally » dom ott 31, 2004 20:57

Certo..........Super Mega Slack 10!!! <BR> <BR>Ma il problema lo ho solo con i paccetti di questo sito, è come se dopo averli decompressi con gunzip (perchè inzialmente terminano per .tgz.gz) fossero corrotti..... <BR>ma ho provato a comprimere e decomprimere altri file, e non e´ guzip che non funge.... <BR>...oltretutto ho riscaricato più volte il file, con lo stesso risultato.... <BR> <BR>........mah......<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

Problemi con i pacchetti di Slacky.it

Messaggioda zevin » dom ott 31, 2004 21:05

Non capisco perchè vuoi decomprimere i pacchetti .tgz per installarli. Sono già precompilati, non sono sorgenti, pertanto si installano come ti ho detto: #installpkg nome_paccchetto.tgz <br>
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Problemi con i pacchetti di Slacky.it

Messaggioda wally » dom ott 31, 2004 22:09

Mi sa che non ci siamo capiti... <BR>Io VOGLIO usare i pacchetti...mi vanno benissimo. <BR>Il probblema e´ che non ci riesco, come ho detto prima mi viene fuori un messaggio..... <BR>E i pacchetti non si installano, questo mi succede con tutti i pacchetti scaricati da questo sito (i quali terminano in .tgz.gz) <BR> <BR>non trovo il minimo modo di instalarli, anche perche se uso subito installpkg mi viene detto che non e´ un file .tgz (e in questo ha ragione, ma sono disperato).... <BR> <BR>Ciao<br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

Problemi con i pacchetti di Slacky.it

Messaggioda zevin » dom ott 31, 2004 22:41

Scusami, ma non riesco a capire. Quello che vuoi dire è che i pacchetti che scarichi da qui hanno l´estensione .tgz.gz, sia l´una che l´altra insieme? Sono andato a scaricarmi il pacchetto in questione, che a me risulta con la sola estensione .tgz, e si è installato senza problemi. <br>
zevin
Linux 2.0
Linux 2.0
 
Messaggi: 167
Iscritto il: ven dic 05, 2003 0:00
Località: Bolzano
Nome Cognome: Ezio Vinante
Slackware: current x86_64
Kernel: 3.10.12
Desktop: Kde 4.12.0-alien

Problemi con i pacchetti di Slacky.it

Messaggioda samiel » dom ott 31, 2004 23:49

Mi sa che c´è un po´ di confusione. Qui trovi sia i sorgenti <BR>(*tar.gz o *.tar.bz2) che non devono essere installati, <BR>perché sono i pacchetto originali da compilare. <BR>sia i *.tgz che sono i pacchetti compilati. <BR>Essi, come già detto, non vanno decompressi <BR>ma semplicemente installati con installpkg. <BR>Non esistono altre estensioni tipo *.tgz.zg <BR>o *.gz. Puoi verificare melgio? <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Problemi con i pacchetti di Slacky.it

Messaggioda useless » lun nov 01, 2004 2:20

lancia il comando file sui file incriminati (prima e dopo lo scompattamento) e posta i risultati.<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problemi con i pacchetti di Slacky.it

Messaggioda wally » lun nov 01, 2004 11:35

Et voila´... <BR>il problema e´ risolto... <BR>come il solito e´ la maledetta casa M$. :-Y Dato che sono costretto a usare un modem ADSL usb, sempre il solito di ALICE, non mi sono mai interesato a ricompilare il kernel per farlo funzionare con Linux, anche perche´ nella casa dove lo uso ci sto solo raramente... <BR>Mentre solitamente uso un modem con interfaccia ethernet, con Linux. <BR>:-D <BR> <BR>E a quanto pare sto maledetto WinXp, in irtu´ del fatto che ha installato ZipGenius, aggiungeva dopo tgz anche gz....quindi l´uica cosa da fare e´ rinomirare i pacchetti che terminano con .tgz.gz con .tgz .... <BR> <BR>Grazie per l´attenzione, :-] <BR>ma ala fine si rivela sempre esser colpa degli stessi..... bye-bye bill.... <br>
Avatar utente
wally
Linux 2.6
Linux 2.6
 
Messaggi: 519
Iscritto il: ven ott 29, 2004 23:00
Località: Genova

Problemi con i pacchetti di Slacky.it

Messaggioda useless » lun nov 01, 2004 13:33

ah, effettivamente è successo anche a me qualche giorno fa: scaricando con IE dei file .tar.gz, lui me li salvava come .tar.tar, bah!<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti