Errori scilab 5.0.2

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
mimmoforlug
Packager
Packager
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox
Località: Caserta
Contatta:

Errori scilab 5.0.2

Messaggioda mimmoforlug » dom ott 19, 2008 10:25

In Scilab 5.0.2 non si riesce a plottare nessun grafico e a volte va in crash
pacchetto scilab-5.0.2-i486-1sl.tgz
lanciandolo da console pare che vi siano problemi con java.
A qualcuno funziona?

Avatar utente
lyapunov
Linux 2.x
Linux 2.x
Messaggi: 204
Iscritto il: dom mag 04, 2008 16:12

Re: Errori scilab 5.0.2

Messaggioda lyapunov » dom ott 19, 2008 11:11

Il problema con l'ultima versione di scilab è che i furbetti hanno usato per il plotting delle librerie java che funzionano bene solo con schede di tipo nvidia, il resto del mondo continua ad avere problemi. E' normale....

Avatar utente
mimmoforlug
Packager
Packager
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox
Località: Caserta
Contatta:

Re: Errori scilab 5.0.2

Messaggioda mimmoforlug » dom ott 19, 2008 11:32

ma che bravi!
Ho già disinstallato su tutte le macchine scilab 5.0.2 e forse non la rimettero mai più!
Grazie

Avatar utente
michele.p
Packager
Packager
Messaggi: 1276
Iscritto il: ven nov 24, 2006 16:52
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva
Località: Pontecorvo(FR)
Contatta:

Re: Errori scilab 5.0.2

Messaggioda michele.p » dom ott 19, 2008 12:29

...effettivamente Scilab sebbene sia andato molto avanti con le funzionalità, l'aver "spostato" l'interfaccia dalle Tcl/Tk (se ben ricordo) a Java l'ha appesantito non poco e in termini di richiesta di memoria RAM (a me prende almeno 180-200MB a "regime") e in termini di grafica (ad esempio refresh video).

IMHO; un eccellente programma (praticamente dal suo fork nacque Matlab) "rovinato" per ricercare la grafica (ma non solo) multipiattaforma....mah...chissà se ne sarà valsa (o se ne valeva) la pena... :-k ...ai posteri l'ardua sentenza... :-k

Bye 8)

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Errori scilab 5.0.2

Messaggioda phobos3576 » dom ott 19, 2008 14:57

lyapunov ha scritto:Il problema con l'ultima versione di scilab è che i furbetti hanno usato per il plotting delle librerie java che funzionano bene solo con schede di tipo nvidia, il resto del mondo continua ad avere problemi. E' normale....

Confermo che con le schede nVidia funziona a meraviglia.

Consiglio a Mimmoforlug di provare a ricompilare da sorgente usando lo SlackBuild; a volte, procedendo in questo modo si risolvono molti problemi di stabilità.
Attenzione perché, tra i prerequisiti (non elencati nello slack-required) c'è anche apache-ant, disponibile qui su Slacky.

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven mag 25, 2007 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: Errori scilab 5.0.2

Messaggioda neongen » dom ott 19, 2008 16:27

[-( mi sa che serve a poco ricompilare scilab. il problema è in jogl

http://wiki.scilab.org/Troubleshooting_ ... b_5.0_beta

puoi provare a ricompilare jogl ma credo che non cambi niente
https://jogl.dev.java.net/nonav/source/ ... =text/html
n.b. i .jar vanno in /usr/share/scilab/thirdparty e i .so in /usr/lib/scilab

Avatar utente
mimmoforlug
Packager
Packager
Messaggi: 143
Iscritto il: lun dic 04, 2006 13:09
Nome Cognome: Domenico Suppa
Slackware: 13.37
Kernel: 3.2.11
Desktop: fluxbox
Località: Caserta
Contatta:

Re: Errori scilab 5.0.2

Messaggioda mimmoforlug » dom ott 19, 2008 17:39

Grazie,
per il momento mi accontenterò di utilizzare la vecchia versione se necessario, intanto ho octave e wxmaxima che mi sono sufficienti.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Errori scilab 5.0.2

Messaggioda phobos3576 » dom ott 19, 2008 23:58

neongen ha scritto:[-( mi sa che serve a poco ricompilare scilab. il problema è in jogl

http://wiki.scilab.org/Troubleshooting_ ... b_5.0_beta

puoi provare a ricompilare jogl ma credo che non cambi niente
https://jogl.dev.java.net/nonav/source/ ... =text/html
n.b. i .jar vanno in /usr/share/scilab/thirdparty e i .so in /usr/lib/scilab


Caspita! Ho provato le demo basate su JOGL. Veramente impressionanti!

Sfido io che venga richiesta una scheda video piuttosto potente ...

Avatar utente
neongen
Packager
Packager
Messaggi: 827
Iscritto il: ven mag 25, 2007 12:37
Nome Cognome: Enrico
Slackware: 14.0_64
Kernel: 3.4.4
Desktop: KDE 4.5.5
Distribuzione: Maemo 5
Contatta:

Re: Errori scilab 5.0.2

Messaggioda neongen » lun ott 20, 2008 12:21

:wav:

Mesa-7.2 aiuta

libdrm
mesa
(WITHOUT ANY WARRANTY)

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2899
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Errori scilab 5.0.2

Messaggioda 414N » mer ott 22, 2008 12:52

michele.p ha scritto:IMHO; un eccellente programma (praticamente dal suo fork nacque Matlab) "rovinato" per ricercare la grafica (ma non solo) multipiattaforma

Molto multipiattaforma...
Sono su una macchina a 64 bit e ho dovuto ricompilare a manazza un paio di jar perché facevano uso di librerie native a 32 bit...
Questo naturalmente non mi ha portato a nulla, perché sono un povero cristo con una ATI e non una Nvidia, quindi non posso pretendere di visualizzare un grafico a due dimensioni perché la mia X800 non riuscirebbe a starci dietro (sarcastic mode OFF).
Appoggiarsi a Java per cercare la "multipiattaformità" e poi usare librerie non multipiattaforma sinceramente non lo capisco...

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2899
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Errori scilab 5.0.2

Messaggioda 414N » dom nov 09, 2008 14:26

È uscita la versione 5.0.3!
Grandi novità!
:blob7: :blob7: :blob7:
Non va ancora una mazza :angryfire:

Avatar utente
michele.p
Packager
Packager
Messaggi: 1276
Iscritto il: ven nov 24, 2006 16:52
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva
Località: Pontecorvo(FR)
Contatta:

Re: Errori scilab 5.0.2

Messaggioda michele.p » dom nov 09, 2008 14:37

...se "smicci" :D un po di Inglese e/o Francese prova ad inserire il tuo problema direttamente nella mailing list degli utenti e/o degli sviluppatori, vedi mai che possano (alla buon'ora :? ) risolvere la cosa. ;)

Bye 8)

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2899
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: Errori scilab 5.0.2

Messaggioda 414N » dom nov 09, 2008 15:48

Presumo che il mio problema sia da ricondurre all'adozione delle JOgl da parte del team di sviluppo di scilab.
Quindi dovrei incacchiarmi con la Sun...

Avatar utente
michele.p
Packager
Packager
Messaggi: 1276
Iscritto il: ven nov 24, 2006 16:52
Nome Cognome: Michele Petrecca
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: KDE
Distribuzione: ..Fedora e Mandriva
Località: Pontecorvo(FR)
Contatta:

Re: Errori scilab 5.0.2

Messaggioda michele.p » dom nov 09, 2008 16:03

...se il problema sai per certo riconducibile alle JOgl e alle schede ATi, prova allora a scrivere nelle mailing list degli sviluppatori di entrambi i progetti; JOgl e Ati....vedi mai che riescono un po a migliorare la cosa. :?

Bye 8)

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Errori scilab 5.0.2

Messaggioda phobos3576 » lun nov 10, 2008 23:39

414N ha scritto:È uscita la versione 5.0.3!
Grandi novità!
:blob7: :blob7: :blob7:
Non va ancora una mazza :angryfire:

Ho creato il package di Scilab 5.0.3 ma il programma non parte nemmeno; avviando da terminale mi dice che non trova dei file JAVA in /tmp/tgz ????

Forse il vecchio SlackBuild non va bene per Scilab 5.0.3