Avidemux 2.5.0: non funziona nulla!

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Avidemux 2.5.0: non funziona nulla!

Messaggioda phobos3576 » gio giu 25, 2009 2:46

Avidemux 2.5.0 non rileva quasi nessun plugin o libreria presente sulla Slackware 12.2 (menu "Aiuto" - "Supporto incorporato")!

Tra le librerie, vengono viste solo Gettext, SDL e XVideo; niente ALSA, OSS, ARTS, per cui, niente audio.
Tra i codec, vengono rilevati solo i codec video XVid e X264; nessun altro codec video e nessun codec audio.
Praticamente, il programma è inutilizzabile; ho anche provato a ricompilare da sorgente, ma non cambia nulla.

La precedente versione di Avidemux rilevava tutti i codec audio/video e tutte le librerie presenti sul sistema.

P.S. Sul sito di Avidemux non sembra essere presente la versione stabile 2.5.0.

EDIT: Ho ricompilato Avidemux 2.4.4 e, in effetti, adesso funziona tutto correttamente.
Attenzione però al fatto che, durante la compilazione, Avidemux 2.4.4 va a cercare la libreria libdts e termina con un errore; sulla Slackware quella libreria è rimpiazzata da libdca.
Il problema è che il package libdca-0.0.5 crea solo il link simbolico libdts.a -> libdca.a
Sono necessari però anche i link simbolici
libdts.so ->libdca.so
libdts.so.0 ->libdca.so.0

idefix
Linux 2.0
Linux 2.0
Messaggi: 144
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Desktop: tde 14.0.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda idefix » gio giu 25, 2009 13:50

pazzesco!
a me invece capita il contrario, non vede ne xvid ne x264,
oltre ovviamenete ad alsa e oss. boh.
da quando han cambiato la procedura di compilazione
dal configure a cmake, tutto è piu complesso.
io lo compilo per 64 bit ma è la stessa cosa,
anche usando vari flag non funziona mai come vorrei.

per sfizio ho usato lo slackbuild di slacky invece del mio
ma neanche cosi funziona.

idefix
Linux 2.0
Linux 2.0
Messaggi: 144
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Desktop: tde 14.0.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda idefix » gio giu 25, 2009 13:54

dimenticavo, nello slackbuild di slacky
la versione solo gtk vuole eliminare gli eseguibili non gtk
presenti in /usr/bin peccato che avidemux voglia a tutti i costi
usare /usr/local/bin quindi non riesce a togliere i 3 non richiesti.


i link simbolici a libdca li avevo gia messi a posto e avevo risolto
per la versione 2.4.4, con la 2.5 son di nuovo daccapo.

Meskalamdug
Iper Master
Iper Master
Messaggi: 3759
Iscritto il: ven mag 14, 2004 0:00

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda Meskalamdug » gio giu 25, 2009 19:48

Confermo,è evidente che qualcuno ha
pasticciato passando da configure
a cmake :D
A me non rileva neppure gettext.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda gohanz » gio giu 25, 2009 20:11

A me lo SlackBuild presente su Slacky, funziona alla perfezione. Questo con la versione 2.4.4, su di una Slackware 12.2 con le dipendenze accessorie. Nessuna problema neanche con libdca, si linka staticamente.


Codice: Seleziona tutto

*******************
**  Summary      **
*******************
Gtk         TRUE
Qt4         
*** Video Codec ***
X264        Yes
Xvid4       Yes
*** Audio Codec ***
LAME        Yes
FAAD        Yes
FAAC        Yes
Vorbis      Yes
Aften       Yes
libDCA      Yes
libAMRNB    Yes
*** Audio Device ***
ESD         Yes
OSS         Yes
ARTS        Yes
JACK        Yes
PULSE SIMP  Yes
*** Misc       ***
SDL         Yes
FreeType    Yes
FontConfig  Yes
Gettext     Yes
Xvideo      Yes
samplerate  Yes
*******************
*******************
-- Configuring done
CMake Warning (dev) at avidemux/CMakeLists.txt:66 (ADD_EXECUTABLE):
  Policy CMP0003 should be set before this line.  Add code such as

idefix
Linux 2.0
Linux 2.0
Messaggi: 144
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Desktop: tde 14.0.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda idefix » gio giu 25, 2009 21:52

infatti quello rognoso è la versione 2.5,
la 2.4.4 va benissimo.

idefix
Linux 2.0
Linux 2.0
Messaggi: 144
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Desktop: tde 14.0.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda idefix » gio giu 25, 2009 21:55

tra le altre cose è sparito da slacky....
il link del 2.5 punta al 2.4.4

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda phobos3576 » gio giu 25, 2009 22:07

gohanz ha scritto:A me lo SlackBuild presente su Slacky, funziona alla perfezione. Questo con la versione 2.4.4, su di una Slackware 12.2 con le dipendenze accessorie. Nessuna problema neanche con libdca, si linka staticamente.

Che versione hai delle libdca?
Probabilmente il problema è presente nel package libdca-0.0.5 che installa le varie librerie libdca.so.x e poi crea il solo link simbolico:

libdts.a -> libdca.a

Per la compilazione di Avidemux-2.4.4 sono necessari però anche i link simbolici
libdts.so -> libdca.so
libdts.so.0 -> libdca.so.0

Come avevo già scritto altre volte, spesso si ottengono package malfunzionanti in quanto nello SlackBuild manca il comando

set -e

che blocca tutto in caso di errori; prova a ricompilare avidemux-2.4.4 con quel comando così vediamo che succede.

P.S. I problemi con Avidemux 2-5-0 sono già stati segnalati sul loro forum:

http://avidemux.org/admForum/viewtopic.php?id=6165

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda gohanz » ven giu 26, 2009 11:13

Ho ricompilato ancora una volta aggiungendo "set -e" allo SlackBuild senza nessun problema. Ho libdca di Slacky.
Immagine

Codice: Seleziona tutto

[ 98%] Built target avidemux2_gtk
[ 98%] Built target tester
[100%] Built target mofiles
CMakeFiles/Makefile2:698: warning: overriding commands for target `avidemux/ADM_filter/CMakeFiles/ADM_filter.dir/all'
CMakeFiles/Makefile2:348: warning: ignoring old commands for target `avidemux/ADM_filter/CMakeFiles/ADM_filter.dir/all'
CMakeFiles/Makefile2:710: warning: overriding commands for target `avidemux/ADM_filter/CMakeFiles/ADM_filter.dir/rule'
CMakeFiles/Makefile2:360: warning: ignoring old commands for target `avidemux/ADM_filter/CMakeFiles/ADM_filter.dir/rule'
CMakeFiles/Makefile2:721: warning: overriding commands for target `avidemux/ADM_filter/CMakeFiles/ADM_filter.dir/clean'
CMakeFiles/Makefile2:371: warning: ignoring old commands for target `avidemux/ADM_filter/CMakeFiles/ADM_filter.dir/clean'

idefix
Linux 2.0
Linux 2.0
Messaggi: 144
Iscritto il: gio giu 19, 2008 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Desktop: tde 14.0.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda idefix » lun giu 29, 2009 19:45

scusate, so di essere un pochino tardo,
ma non ho mica capito come è finita con l'ultimo avidemux.
gohanz ha compilato l'ultimo o il penultimo?
sul repository non c'è il 2.5 quindi immagino abbia dei problemi irrisolti
e si debba attendere una versione nuova.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda gohanz » mar giu 30, 2009 8:12

idefix ha scritto:scusate, so di essere un pochino tardo,
ma non ho mica capito come è finita con l'ultimo avidemux.
gohanz ha compilato l'ultimo o il penultimo?
sul repository non c'è il 2.5 quindi immagino abbia dei problemi irrisolti
e si debba attendere una versione nuova.



Io ho compilato la 2.4.4. Comunque leggevo adesso sul sito di Avidemux un avvertenza.

And finally the first 2.5.x version. A note of warning, the build is done in two steps : Build the application(s), and then build the plugins.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda phobos3576 » ven lug 03, 2009 5:01

Ho provato i nuovi package 2.5.0 ma niente da fare; il problema con ALSA sembra persistere (anche ricompilando da sorgente).

Adesso tutte le librerie e i codecs vengono visti come plugins; i vari plugin di output audio/video funzionano, ad eccezione appunto di ALSA; il problema è che, a differenza di quanto accade con la 2.4.4, la 2.5.0 non dà la possibilità di impostare il dispositivo ALSA.

In pratica, con la 2.4.4, nel menu "Modifica" - "Preferenze" - "Audio", trovo le voci "Downmixing riproduzione locale", "Controllo volume", "Output audio" e "Dispositivo ALSA"; con la 2.5.0 sono presenti solo "Downmixing riproduzione locale" e "Output audio".

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda gohanz » ven lug 03, 2009 7:54

Phobos ho compilato io stesso i nuovi pacchetti su di una Slackware 12.2 fresca di installazione più i fix di sicurezza. Sul mio pc funziona tutto correttamente. Il nuovo Avidemux della serie 2.5.* non usa più un binario statico, ma un binario con una serie di librerie shared e di plugins. Come puoi vedere dall'immagine Alsa funziona correttamente.

Immagine

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda phobos3576 » ven lug 03, 2009 20:51

Nel mio caso, tutte le applicazioni multimediali mi permettono di selezionare quale dispositivo ALSA voglio utilizzare; io seleziono sempre "default" e tutto funziona correttamente.
Così succedeva anche con Avidemux 2.4.4; invece, Avidemux 2.5.0 si ostina ad usare un dispositivo ALSA chiamato "dmix" che nel mio caso non esiste neppure.
Ho provato anche a modificare manualmente il file $HOME/.avidemux/config, ma Avidemux continua ad usare questo dannato "dmix".

Messaggi dal terminale:

Codice: Seleziona tutto

[Alsa] Using device :dmix
[Alsa]Error setting format.
[Alsa] Using device :dmix
[Alsa]Error setting format.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Avidemux 2.5.0: non funziona nulla!

Messaggioda gohanz » sab lug 04, 2009 11:43

phobos3576 ha scritto:Nel mio caso, tutte le applicazioni multimediali mi permettono di selezionare quale dispositivo ALSA voglio utilizzare; io seleziono sempre "default" e tutto funziona correttamente.
Così succedeva anche con Avidemux 2.4.4; invece, Avidemux 2.5.0 si ostina ad usare un dispositivo ALSA chiamato "dmix" che nel mio caso non esiste neppure.
Ho provato anche a modificare manualmente il file $HOME/.avidemux/config, ma Avidemux continua ad usare questo dannato "dmix".

Messaggi dal terminale:

Codice: Seleziona tutto

[Alsa] Using device :dmix
[Alsa]Error setting format.
[Alsa] Using device :dmix
[Alsa]Error setting format.


Ma è un problema solo tuo? Qualcuno mi può confermare il corretto funzionamento di Avidemux?


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti