Repository 32bit  Forum
Repository 64bit  Wiki

dipendenze kde

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

dipendenze kde

Messaggioda kireime » mar dic 14, 2004 12:07

Ho aggiornato kde a 3.3.2 ma ho due librerie mancanti che non riesco a trovare: <BR>libpam <BR>libsensor <BR> <BR>dove posso trovarle?<br>
kireime
Linux 2.0
Linux 2.0
 
Messaggi: 179
Iscritto il: lun gen 26, 2004 0:00

dipendenze kde

Messaggioda cddm66 » mar dic 14, 2004 21:01

Anche a me da gli stessi problemi... ho cercato in giro ma non ho trovato nulla di significativo. In piu´ "non suona", ma questo e´ un problema che indaghero´ appena avro´ un po´ di tempo.... <BR><br>
cddm66
Linux 2.0
Linux 2.0
 
Messaggi: 121
Iscritto il: lun dic 29, 2003 0:00
Località: Torino
Nome Cognome: Davide Camerano
Distribuzione: Ubuntu

dipendenze kde

Messaggioda samiel » mar dic 14, 2004 22:01

PAM l´ho fatto, ma l´ha fatto anche Lorys. <BR>Lm_sensor mi dava problemi e comunque implica <BR>aver inserito nel kernel alcune opzioni. <BR>Non ho abilitato quei supporti perché ho compilato <BR>su una Slack 10 pura e semplice. Quel paio di cose <BR>che ho aggiunto sono segnalate nei slack-required. <BR>Il fatto è che KDE supporta moltissime altre cose <BR>che però Slack non contempla (fra l´altro Audiophile, Ctags, Gnokii, <BR>Ghostscript, GpgME, Htdig, Libgphoto. Libmusicbrainz, Libtunepimp, <BR>OpenEXR, Pam, Perforce, Ruby ecc ecc). Inserirle tutte avrebbe <BR>significato snaturare Slack. In ogni caso, sono pacchetti <BR>che ho fatto, con un po´ di calma li metto in nogood. <BR>Magari appena rinvengo dall´influenza che mi sono beccato... <BR>In tutti questi casi è sufficiente installare il pacchetto, <BR>e poi ricompilare con lo SlackBuild. KDE trova i pacchetti <BR>che cerca e abilita automaticamente le opzioni <BR> <BR>Non suona? Che tipo di problemi ti dà? <BR>Ovvio che appena fatto l´aggiornamento bisogna <BR>dare l´unmute al mixer di KDe, ma credo <BR>che sia fin troppo banale dirlo... <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

dipendenze kde

Messaggioda cddm66 » mer dic 15, 2004 22:44

Per quanto riguarda il suono, non era ovviamente l´unmute. Grazie comunque x i suggerimenti. Non so da cosa dipendesse, perche´ ho deciso di ritornare alla 3.3.1. E´ un periodo che non ho voglia di sbattermi a risolvere problemi... passera´. <BR>Comunque vi segnalo quello che ho trovato: <BR>- Piu´ lenta, in modo abbastanza percettibile. E non ho un PC poco potente (AMD Athlon 64 3200+,Asus K8V, 1G RAM). <BR>- Il suddetto problema del suono <BR>- La mancanza di PAM, che provoca il fatto di non poter accedere ad init 4. <BR>- Ho fatto x sbaglio il "blocca sessione" e si rifiutava di sbloccarla, diceva che non era riuscito a connettersi ad un certo processo <BR>saluti a tutti <BR><br>
cddm66
Linux 2.0
Linux 2.0
 
Messaggi: 121
Iscritto il: lun dic 29, 2003 0:00
Località: Torino
Nome Cognome: Davide Camerano
Distribuzione: Ubuntu

dipendenze kde

Messaggioda samiel » mer dic 15, 2004 23:03

----------------------------------------------------------- <BR>Piu´ lenta, in modo abbastanza percettibile. <BR>----------------------------------------------------------- <BR>Anche a me pare un po´ più lenta. comunque volevo provare <BR>una compilazione maggiormente ottimizzata <BR>(CFLAGS="-O3 -march=i686 -mcpu=i686). <BR> <BR>---------------------------------------------------------- <BR>- Il suddetto problema del suono <BR>---------------------------------------------------------- <BR>A me il suono funziona, non so nel tuo caso <BR>da che cosa possa dipendere... <BR> <BR>----------------------------------------------------------- <BR>- La mancanza di PAM, che provoca il fatto <BR>di non poter accedere ad init 4. <BR>----------------------------------------------------------- <BR>E´ sufficiente che ti installi PAM <BR>(e le cracklib che PAM richiede) <BR>e che ricompili lanciando lo SlackBuild, <BR>senza modificarlo. Lui trova PAM <BR>e ti compila automaticamente il supporto. <BR> <BR>------------------------------------------------------------ <BR>- Ho fatto x sbaglio il "blocca sessione" <BR>e si rifiutava di sbloccarla <BR>------------------------------------------------------------ <BR>Il problema l´ho riscontrato anch´io. <BR>Ho scritto al team di KDE per sapere <BR>se poteva essere un problema di compilazione <BR>o un bug eventuale. Appena mi rispondono, <BR>vi comunico tutto. <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

dipendenze kde

Messaggioda Eriol » gio dic 16, 2004 2:07

<!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR> 15-12-2004 alle ore 23:03, samiel : <BR> <BR>- Il suddetto problema del suono <BR>---------------------------------------------------------- <BR>A me il suono funziona, non so nel tuo caso <BR>da che cosa possa dipendere... <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Anche a me funziona perfettamente <BR> <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR>----------------------------------------------------------- <BR>- La mancanza di PAM, che provoca il fatto <BR>di non poter accedere ad init 4. <BR>----------------------------------------------------------- <BR>E´ sufficiente che ti installi PAM <BR>(e le cracklib che PAM richiede) <BR>e che ricompili lanciando lo SlackBuild, <BR>senza modificarlo. Lui trova PAM <BR>e ti compila automaticamente il supporto. <BR> <BR>------------------------------------------------------------ <BR>- Ho fatto x sbaglio il "blocca sessione" <BR>e si rifiutava di sbloccarla <BR>------------------------------------------------------------ <BR>Il problema l´ho riscontrato anch´io. <BR>Ho scritto al team di KDE per sapere <BR>se poteva essere un problema di compilazione <BR>o un bug eventuale. Appena mi rispondono, <BR>vi comunico tutto. <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Io ho utilizzato un altro approccio che ha risolto tutti e due i problemi. Dato che l´uso di PAM è stato deprecato da Patrick stesso ho optato per una soluzione che non lo coinvolgesse. <BR>All´interno del tar.bz2 del kdebase si trova "README.pam". Quoto direttamente da esso: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR>By default, PAM is automatically used, if it is found. Use <BR>./configure --without-pam to disable it. <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Qualche rigo più avanti si può leggere: <BR> <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> <BR>PAM configuration files have four types of entries for each service: <BR> <BR>type used by kdm used by kscreensaver <BR>---- ----------- -------------------- <BR>auth x x <BR>account x <BR>password x <BR>session x <BR></BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR> <BR>Per cui semplicemente compilando kdebase con un ./configure --without-pam si sono risolti tutti e due i problemi. Non ho fatto un pkg perchè su questa macchina non ho un slackware pura e pulita, ma è la macchina che utilizzo abitualmente. Inoltre devo vedere meglio come funziona makepak perchè mi ha dato degli errori. Ma sta funzionando tutto perfettamente adesso. Ho anche provato il kdm proprio per sincerarmene (abitualmente uso il runlevel 3). <BR> <BR>Spero di esser stato utile :-D <BR> <BR>Notte!<br>
Eriol
Linux 1.0
Linux 1.0
 
Messaggi: 17
Iscritto il: mer ott 27, 2004 23:00

dipendenze kde

Messaggioda samiel » gio dic 16, 2004 9:27

Non utile, utilissimo! <BR>Passo subito alla compilazione! <BR> <BR>Mlle grazie <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

dipendenze kde

Messaggioda Claudio » gio dic 16, 2004 11:43

Il suono... <BR>A me crashava arts, perchè mancava libjack.so.0 : allora ho preso il sorgente di arts e me lo sono ricompilato, ma continuava a chiedermi la dipendenza, ho provato il pacchetto non ufficiale di kde.org, stesso problema. E allora ho trovato jack e l´ho installato e adesso arts non crasha più, c...o! <BR>Ora sembra funzionare, ma lo provo un po´ prima... magari adesso riesce a funzionare il midi senza i soundfonts, chissà... <BR><br>
Claudio
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: gio ago 05, 2004 23:00
Località: Venezia

dipendenze kde

Messaggioda meritil » gio dic 16, 2004 11:59

Ragazzi io sono un accanito sostenitore di xfce4 e un acerrimo nemico di kde, premesso questo, vorrei consigliarvi di dare una sbirciata a xfce4.2 disponibile nel repository slacky.it. <BR>Per dare un occhiata non c´è bisogno di impostarlo come WM predefinito, invece di startx date startxfce4... <BR> <BR>Ciao <BR> <BR>ps: Più che altro vi dico questo perchè la maggior parte dei post sono un ricettacolo di problemi riscontrati con kde, che secondo me sta diventando un vero e proprio polmone.. pieno di richieste e causa di molti mali^^ Detto ciò, massimo rispetto a Samiel che si sbatte per la gioia di tutti noi.... Tnx <BR><br>
meritil
Master
Master
 
Messaggi: 1651
Iscritto il: lun ago 23, 2004 23:00
Slackware: bluewhite64

dipendenze kde

Messaggioda twister » gio dic 16, 2004 12:30

Complimenti per l´offtopic e il flame-starter :-] <br>
Avatar utente
twister
Staff
Staff
 
Messaggi: 1598
Iscritto il: mar nov 11, 2003 0:00
Località: Roma
Slackware: current

dipendenze kde

Messaggioda meritil » gio dic 16, 2004 12:38

LOL dai sono un po´ rompi@@ ma non un flamer... hihihi <BR>Cmqe fa una cosa... nel motorino di ricerca del forum scrivi "kde" e fatti due risate... <BR> <BR>Ciao<br>
meritil
Master
Master
 
Messaggi: 1651
Iscritto il: lun ago 23, 2004 23:00
Slackware: bluewhite64

dipendenze kde

Messaggioda valfe » gio dic 16, 2004 13:42

mai pensato al fatto che kde è più complesso e ha un bacino di utenti maggiore e quindi di conseguenza si trovano più problemi ..... ;-) <br>
valfe
Linux 2.4
Linux 2.4
 
Messaggi: 342
Iscritto il: mar nov 04, 2003 0:00

dipendenze kde

Messaggioda samiel » gio dic 16, 2004 18:02

Per Eriol: <BR>ho ricompilato e adesso il monitor di KDE funziona <BR>e non perde la connessione a localhost. <BR>La sessine si sblocca regolarmente, ma resta <BR>un problema: lo screensaver protetto da psw <BR>si sblocca da root, ma non da user... <BR>A te si sblocca in entrambi i casi? <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

dipendenze kde

Messaggioda twister » gio dic 16, 2004 21:41

Scusa Samiel. <BR>devo aggiornare kdebase dal tuo repository, o un altro pacchetto?<br>
Avatar utente
twister
Staff
Staff
 
Messaggi: 1598
Iscritto il: mar nov 11, 2003 0:00
Località: Roma
Slackware: current

dipendenze kde

Messaggioda samiel » gio dic 16, 2004 22:11

Aspe fino a domani, <BR>che sto vedendo di risolvere... <BR>comunque solito sito, vedi la release progressiva <BR> <BR>Un grazie a tutti quelli <BR>che fanno da cavia. <BR>KDE 3.4 non ci troverà impreparati! <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite