libfaac.so.0

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
gunnar
Linux 0.x
Linux 0.x
Messaggi: 4
Iscritto il: ven nov 27, 2009 18:18
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Kde

libfaac.so.0

Messaggioda gunnar » ven nov 27, 2009 19:04

Credo di aver bisogno qualche informazione,
ho reinstllato mplayer ed i codec per vedere i dvd
ma da terminale mi dice:
mplayer: error while loading shared libraries: libfaac.so.0: cannot open shared object file: No such file or directory

oa ho cercato le libfaac.so.0, ma non riesco a trovarle da nessuna parte (sono menzionate dappertutto, ma non trovo
materilamente un file che si chiama così da scaricare)

Qualcuno che ha già avuto il problema mi può dire dove reperirle, o più probabilmente dove sbaglio, e con che comandi "installarle".

[sono reduce un pò deluso da Ubuntu e con Slackware devo riprenderci molto la mano]
Ho slackware 13.0 kernel 2.6.29.6
Grazie anticipate a chi mi dedica un pò di tempo.

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2899
Iscritto il: mer feb 13, 2008 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: libfaac.so.0

Messaggioda 414N » ven nov 27, 2009 19:15

Devi reinstallare i plugin per decoding (e forse anche encoding se usi mencoder) per AAC, forniti dai pacchetti faac e faad2, dei quali trovi tranquillamente gli slackbuild su slackbuilds.org oppure i pacchetti qui su slacky.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: libfaac.so.0

Messaggioda phobos3576 » ven nov 27, 2009 19:17

Mi sa però che c'è un problema nel package faac qui su Slacky; ho notato che installa solo libfaac.la e libfaac.so.0.0.0 in /usr/lib, mentre io ho la stessa versione del package che però stranamente mi ha installato libfaac.la libfaac.so.0.0.0 libfaac.so libfaac.so.0.

gunnar
Linux 0.x
Linux 0.x
Messaggi: 4
Iscritto il: ven nov 27, 2009 18:18
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Kde

Re: libfaac.so.0

Messaggioda gunnar » ven nov 27, 2009 19:46

Vi ringrazio entrambi, rapidissimi!
Ci metterò un pò a districarmi,
farò seguito certamente.

Grazie.

gunnar
Linux 0.x
Linux 0.x
Messaggi: 4
Iscritto il: ven nov 27, 2009 18:18
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Kde

Re: libfaac.so.0

Messaggioda gunnar » sab nov 28, 2009 16:57

Ho trovato le faac nel nuovo mirror segnalato da loris
in http://www.slacky.eu/forum/viewtopic.php?f=4&t=26642
ora mi da mancante libx264.so.73,
[nel nuovo mirror non mi sembra ci sia]
Sembra una quest!

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: libfaac.so.0

Messaggioda phobos3576 » sab nov 28, 2009 19:31

gunnar ha scritto:Ho trovato le faac nel nuovo mirror segnalato da loris
in http://www.slacky.eu/forum/viewtopic.php?f=4&t=26642
ora mi da mancante libx264.so.73,
[nel nuovo mirror non mi sembra ci sia]
Sembra una quest!


Infatti, prima di riuscire a far partire MPlayer, devi superare diversi livelli di gioco ... :D

Comunque, le libx264 sono in questo package:

http://www.slacky.eu/aadm/pkgs/index.php?pkg=834&ver=13

Già che ci sei, controlla l'elenco completo delle dipendenze di MPlayer:

http://repository.slacky.eu/slackware-1 ... k-required

Ma che versione di Slackware stai usando?

gunnar
Linux 0.x
Linux 0.x
Messaggi: 4
Iscritto il: ven nov 27, 2009 18:18
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Kde

Re: libfaac.so.0

Messaggioda gunnar » sab nov 28, 2009 23:05

Ho scaricato
h264enc-9.0.5-noarch-1sl.txz
e l'ho installato con installpkg
ma quando lancio mplayer da terminale
mi dice sempre che non trova le libx264.so.73
(No such file or directory) :doubt:

[l'incredibile è che da questo sito http://ultilex.linux-bg.org/ (è bulgaro, ma scritto in inglese)
ho scaricato un'ISO e poi masterizzata che da la possibilità
di avere una live con tante distro(ma veramente tante ed è solo un CD non un DVD),
la prima, basata su slackware,
ha un Kplayer che mi fa vedere benissimo i DVD]

Comunque lotto ancora un pò.

Grazie.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom apr 17, 2005 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: libfaac.so.0

Messaggioda phobos3576 » sab nov 28, 2009 23:14

Devi installare il decoder x264 e non l'encoder h264.

Avatar utente
mohaa
Linux 1.x
Linux 1.x
Messaggi: 181
Iscritto il: mar mar 04, 2008 8:52
Slackware: 12.1
Kernel: 3
Desktop: Gnome2
Distribuzione: Gentoo
Località: Francia

Re: libfaac.so.0

Messaggioda mohaa » gio dic 03, 2009 20:12

It is not only libfaac missing. Type :

Codice: Seleziona tutto

$ ldd `which mplayer`
to have all deps of the one you want to use.
Missing libs will be flagged not found or such. You'll have to install those to use mplayer... /be warned, this may not work/