[RISOLTO] Dipendenze compiz

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

[RISOLTO] Dipendenze compiz

Messaggioda brainvision » ven feb 05, 2010 13:41

ciao ragazzi,

volevo installare compiz ed i suoi plugin e nel prelevare gli lsackbuild dal repository per la 12.2 (qui su slacky, ovviamente) ho visto che tra le dipendenze ci sono i pacchetti kde-base e kde-libs, nonché le qt3.3.
Volevo sapere se qualcuno sa il motivo di questa dipendenza..

Sono andato a vedere su compiz.org ed ho trovato questa pagina: http://wiki.compiz.org/Installation, dove leggo:

Codice: Seleziona tutto

Build-System switches

Compiz-Core's configure file also contains a number of switches to disable certain dependencies. They are:

# --disable-kde - Disable KDE window decorator
# --disable-kde4 - Disable KDE 4 window decorator
# --disable-kconfig - Disable kconfig plugin


Credo che basterà compilare inserendo queste opzioni nello slackbuild se non desidero avere quelle dipendenze di cui sopra.. Il problema è che non so a cosa servono quelle dipendenze.. se alcuni plugin non verranno installati o cose del genere.. in pratica non si dice a cosa servono!

Qualcuno sa dirmi qualcosa di più specifico?

Grazie mille!
Ultima modifica di brainvision il ven feb 05, 2010 15:58, modificato 1 volta in totale.

Avatar utente
sya54M
Master
Master
Messaggi: 1562
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.5.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: Dipendenze compiz

Messaggioda sya54M » ven feb 05, 2010 14:35

è scritto nelle descrizioni cosa sono:
brainvision ha scritto:# --disable-kde - Disable KDE window decorator
# --disable-kde4 - Disable KDE 4 window decorator
# --disable-kconfig - Disable kconfig plugin

quindi se non usi ne kde3 ne kde4, puoi usare quelle opzioni.

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: Dipendenze compiz

Messaggioda brainvision » ven feb 05, 2010 14:55

sì infatti, alla fine volevo sapere più che altro in quale pacchetti usare quelle opzioni.. farò in maniera indiretta: vedo quelli che le richiedono come dipendenze e le uso lì..

grazie mille comunque..

Avatar utente
sya54M
Master
Master
Messaggi: 1562
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.5.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: Dipendenze compiz

Messaggioda sya54M » ven feb 05, 2010 15:01

quelle opzioni riguardano il pacchetto compiz ovvero il core.

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2665
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.4.8-ck1
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: Dipendenze compiz

Messaggioda Ansa89 » ven feb 05, 2010 15:18

sya54M ha scritto:quelle opzioni riguardano il pacchetto compiz ovvero il core.

Esatto, negli altri pacchetti non serve aggiungere queste opzioni perché non sono contemplate dal "configure".

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: Dipendenze compiz

Messaggioda brainvision » ven feb 05, 2010 15:57

ok, ragazzi, grazie mille a entrambi!!

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda brainvision » ven feb 05, 2010 18:05

scusate ragazzi,

visto che sembrate saperne abbastanza su compiz.. ho finito di creare i pacchetti (aggiornati alla versione 0.8.4) e li ho installati.. compreso il pacchetto fusion-icon, per comodità
Ed infatti avvio il tutto con fusion-icon.. ho xfce e mi scompare il window decorator di xfce ma non mi viene rimpiazzato da emerald.. ho anche provato ad usare --replace ma senza successo.. c'è qualcosa che mi sfugge ma non ricordo cosa. Avevo letto di un problema simile qui sul forum ma non riesco a trovare niente che faccia al mio caso..

Sapete suggerirmi il da farsi per favore?
Accidenti, ricordo che se ne parlava recentemente!!!

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda brainvision » ven feb 05, 2010 19:45

Ok, come non detto, era davvero una fesseria.. :), non avevo abilitato il plugin!!! decorazione finestre, pensa un po'!!!

Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
Messaggi: 1027
Iscritto il: ven lug 28, 2006 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda DanBadJar » gio lug 22, 2010 18:31

Ma tu poi le finestre riesci a muoverle?
Anche io ho abilitato il plugin ma le finestre rimangono fisse con xfce!

Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
Messaggi: 1027
Iscritto il: ven lug 28, 2006 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda DanBadJar » gio lug 22, 2010 18:34

Risolto. Il plugin (un altro!) da attivare è ovviamente "Muovi finestre" :roll:

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda brainvision » gio lug 22, 2010 19:11

cia Dan,
scusa ma non ho avuto neanche il tempo di accorgermi che avevi scritto su questo post vecchiotto! :D

volevo però chiederti che versione di compiz hai installato e se per caso hai ripacchetizato tutto, magari..
l'ultima versione è la 0.9 e pare abbiano anche cambiato il compiler passando a cmake, quindi ciò vuol dire praticamente rifare i pacchetti!
inoltre ci sono stati dei cambiamenti, come ad esempio copmpiz-bcop che è stato fatto confluire direttamente nel core (cose che mi hanno detto nella chat di compiz): volevo fare i nuovi pacchetti, ma ora.. non so, l'estate incombe.:! :D

Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
Messaggi: 1027
Iscritto il: ven lug 28, 2006 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda DanBadJar » gio lug 22, 2010 19:18

Guarda io ho appena ricompilato la 0.8.4, ma ho usato gli slackbuilds di slackbuild.org
Pare che funzioni tutto, ma della 0.9 non so niente ;)

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda brainvision » ven lug 23, 2010 7:22

ok allora mi metto a compilare la 0.8.6!, va'.. ma scusa, non potevi usare gli slackbuild di slacky??

Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
Messaggi: 1027
Iscritto il: ven lug 28, 2006 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda DanBadJar » ven lug 23, 2010 8:18

Ho visto che i pacchetti non erano disponibili per la 13.1 e ho voluto provare questo SBO, sono rimasto piacevolmente colpito! :)

Avatar utente
brainvision
Packager
Packager
Messaggi: 761
Iscritto il: ven dic 26, 2008 18:23
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10
Località: bologna (bo)
Contatta:

Re: [RISOLTO] Dipendenze compiz

Messaggioda brainvision » ven lug 23, 2010 11:51

LOL, piacevolmente colpito! :D :D

Allora, visto che comunque la 0.9 non è né completa né (del tutto) stabile) ho deciso di fare i pacchetti della 0.8.6, dai.. son già a buon punto, spero che quando avrò finito tu voglia aggiornarla ed usare pacchetti slacky original!! :D


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite