[RISOLTO] Rosegarden non trova liblo.so.0

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
nyquist
Linux 2.4
Linux 2.4
Messaggi: 230
Iscritto il: sab ago 02, 2008 16:02
Nome Cognome: Cristiano Urban
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: Fedora
Località: Gonars (UD)
Contatta:

[RISOLTO] Rosegarden non trova liblo.so.0

Messaggioda nyquist » mer feb 10, 2010 12:10

Salve a tutti,
di nuovo un problemino...
Ho scaricato Rosegarden con Slackyd e l'ho installato.
Quando lo lancio dal menù di Kde non parte...
Ho provato a lanciarlo anche da linea di comando ma non trova una libreria

Codice: Seleziona tutto

bash-3.1$ rosegarden
rosegarden: error while loading shared libraries: liblo.so.0: cannot open shared object file: No such file or directory


Dando un 'occhiata alle librerie richieste

Codice: Seleziona tutto

ldd /usr/bin/rosegarden

il risultato è

Codice: Seleziona tutto

linux-gate.so.1 =>  (0xffffe000)
        /usr/lib/libv4l/v4l1compat.so (0xb808e000)
        libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xb79c1000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xb79b9000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xb79a2000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb78bb000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb78ad000)
        libdl.so.2 => /lib/libdl.so.2 (0xb78a8000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7891000)
        libkdecore.so.4 => /usr/lib/libkdecore.so.4 (0xb765b000)
        liblo.so.0 => not found
        liblrdf.so.2 => /usr/lib/liblrdf.so.2 (0xb764d000)
        libfftw3f.so.3 => /usr/lib/libfftw3f.so.3 (0xb7589000)
        libXft.so.2 => /usr/lib/libXft.so.2 (0xb7577000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb756f000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7546000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb74d6000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb74c2000)
        libjack.so.0 => /usr/lib/libjack.so.0 (0xb74a9000)
        librt.so.1 => /lib/librt.so.1 (0xb749f000)
        libkio.so.4 => /usr/lib/libkio.so.4 (0xb7165000)
        libkdeui.so.4 => /usr/lib/libkdeui.so.4 (0xb6e8b000)
        libkdeprint.so.4 => /usr/lib/libkdeprint.so.4 (0xb6dc0000)
        libm.so.6 => /lib/libm.so.6 (0xb6d9a000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb6cb4000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb6ca8000)
        libc.so.6 => /lib/libc.so.6 (0xb6b5c000)
        libDCOP.so.4 => /usr/lib/libDCOP.so.4 (0xb6b2a000)
        libkdefx.so.4 => /usr/lib/libkdefx.so.4 (0xb6b02000)
        libv4l1.so.0 => /usr/lib/libv4l1.so.0 (0xb6afe000)
        libmng.so.1 => /usr/lib/libmng.so.1 (0xb6a9c000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb6a7c000)
        libpng.so.3 => /usr/lib/libpng.so.3 (0xb6a41000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0xb69e9000)
        libXmu.so.6 => /usr/lib/libXmu.so.6 (0xb69d4000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xb69ce000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xb69c4000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb69c1000)
        libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb69bf000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb69a8000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb69a5000)
        /lib/ld-linux.so.2 (0xb8091000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb6991000)
        libutil.so.1 => /lib/libutil.so.1 (0xb698d000)
        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0xb6977000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0xb6947000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6942000)
        libraptor.so.1 => /usr/lib/libraptor.so.1 (0xb68e7000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb68c7000)
        libsamplerate.so.0 => /usr/lib/libsamplerate.so.0 (0xb675d000)
        libcelt.so.0 => /usr/lib/libcelt.so.0 (0xb6750000)
        libkdesu.so.4 => /usr/lib/libkdesu.so.4 (0xb6738000)
        libkwalletclient.so.1 => /usr/lib/libkwalletclient.so.1 (0xb6726000)
        liblcms.so.1 => /usr/lib/liblcms.so.1 (0xb66ef000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xb66a0000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xb669b000)
        libfam.so.0 => /usr/lib/libfam.so.0 (0xb6694000)
        libacl.so.1 => /lib/libacl.so.1 (0xb668d000)
        libattr.so.1 => /lib/libattr.so.1 (0xb6688000)
        libkparts.so.2 => /usr/lib/libkparts.so.2 (0xb6644000)
        libv4l2.so.0 => /usr/lib/libv4l2.so.0 (0xb663b000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb6635000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xb6632000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0xb6629000)
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0xb65e8000)
        libxslt.so.1 => /usr/lib/libxslt.so.1 (0xb65b4000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb6498000)
        libv4lconvert.so.0 => /usr/lib/libv4lconvert.so.0 (0xb6435000)
        libldap-2.3.so.0 => /usr/lib/libldap-2.3.so.0 (0xb63ff000)
        libssl.so.0 => /usr/lib/libssl.so.0 (0xb63bd000)
        libcrypto.so.0 => /usr/lib/libcrypto.so.0 (0xb6280000)
        liblber-2.3.so.0 => /usr/lib/liblber-2.3.so.0 (0xb6274000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb625e000)

in particolare dando

Codice: Seleziona tutto

ldd /usr/bin/rosegarden | grep liblo

si nota

Codice: Seleziona tutto

liblo.so.0 => not found


Avevo trovato un post di qualche anno fà sul forum che parlava del problema... Li consigliavano di scaricare i sorgenti e compilarli... Non c'è un altro modo per risolvere il problema? Che so, creare un link simbolico o qualcosa del genere... :-k
Qualcuno saprebbe come fare???


Ringrazio in anticipo.
Ultima modifica di nyquist il mer feb 10, 2010 18:39, modificato 1 volta in totale.

Avatar utente
teox99
Linux 2.6
Linux 2.6
Messaggi: 737
Iscritto il: ven lug 25, 2008 14:54
Slackware: 13.37
Desktop: KDE - Xfce
Località: Roma[Eur]
Contatta:

Re: Rosegarden non trova liblo.so.0

Messaggioda teox99 » mer feb 10, 2010 12:24

Liblo (Lightweight OSC implementation) liblo is an implementation of the Open Sound Control protocol for POSIX systems, started by Steve Harris. It is released under the GNU General Public Licence. This means that it cannot be used in closed-source systems you intend to distribute - if you have a specific requirement for liblo in a close-source system then mail me and I may relicense it on an individual basis.

http://repository.slacky.eu/slackware-1 ... 86-2sl.txz

Avatar utente
conraid
Staff
Staff
Messaggi: 12678
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Rosegarden non trova liblo.so.0

Messaggioda conraid » mer feb 10, 2010 12:33

devi installare anche le dipendenze che ti vengono segnalate, tra cui liblo
Se continua ad esserci un problema segnalalo con pkgreports
http://www.slacky.eu/aadm/pkgreports/

Avatar utente
nyquist
Linux 2.4
Linux 2.4
Messaggi: 230
Iscritto il: sab ago 02, 2008 16:02
Nome Cognome: Cristiano Urban
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: Fedora
Località: Gonars (UD)
Contatta:

Re: Rosegarden non trova liblo.so.0

Messaggioda nyquist » mer feb 10, 2010 12:44

Innanzitutto grazie mille per le risposte.
Però il pacchetto era già installato, infatti

Codice: Seleziona tutto

bash-3.1$ ls /var/log/packages | grep liblo
liblo-0.26-i486-1

Ho provato anche a reinstallarlo ma non funzia lo stesso...

P.S. Uso la Slackware 12.2, scusate se non l'ho scritto sopra :D

Avatar utente
conraid
Staff
Staff
Messaggi: 12678
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Rosegarden non trova liblo.so.0

Messaggioda conraid » mer feb 10, 2010 12:47

rosegarden è stato compilato con la versione 0.25
http://repository.slacky.eu/slackware-1 ... k-required

un "errore" di chi ha ricompilato liblo senza accertarsi se servisse ad altri programmi
purtroppo il repository 12.2 è fermo

prova a farti il pacchetto da solo

Avatar utente
nyquist
Linux 2.4
Linux 2.4
Messaggi: 230
Iscritto il: sab ago 02, 2008 16:02
Nome Cognome: Cristiano Urban
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: Fedora
Località: Gonars (UD)
Contatta:

Re: Rosegarden non trova liblo.so.0

Messaggioda nyquist » mer feb 10, 2010 18:39

Ah ok, ho capito.

Ho scaricato la versione 0.25 di liblo. Ho utilizzato i sorgenti.
Ora il programma parte. Di nuovo grazie per l'aiuto.


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite